老钱庄股票论坛

 找回密码
 5秒快速注册
查看: 9730|回复: 11

[通达信] 请高改为通达信,(飞狐画线公式很优秀!)

[复制链接]
发表于 2009-9-20 09:59 | 显示全部楼层 |阅读模式
只要画线完整是重点,其他方面不能改的无关紧要。先谢!
{新结构波浪+三角形}
S:=('股票代码:' + 品种代码);
显示文字((系统参数(2) = 数据位置),收盘价,S),ALIGN4,Color00FFFF;
显示文字((数据位置 = 系统参数(2)),最高价,(((((((((((((((((((((((((((((((((('                 所属板块:' + 所属板块) + '\n') + '发行价') + 数字转化为字符串(财务数据(51),2)) + '元') + '  发行量') + 数字转化为字符串(财务数据(52),2)) + '万股') + '\n') + '总股本') + 数字转化为字符串(财务数据(1),0)) + '万股') + '  流通A股') + 数字转化为字符串(财务数据(7),0)) + '万股') + '  净资产') + 数字转化为字符串(财务数据(35),2)) + '亿元') + '  每股收益') + 数字转化为字符串(财务数据(33),2)) + '元') + '  每股未分配') + 数字转化为字符串(财务数据(32),2)) + '元') + '\n') + '市盈率') + 数字转化为字符串(动态行情(39),2)) + '%') + '  投资收益') + 数字转化为字符串(财务数据(24),2)) + '元') + '  股东总数') + 数字转化为字符串(财务数据(50),0)) + '户')),ALIGN4,ColorFFFF93;
variable:wday[7]='星期六';
wday[1]:='星期日';
wday[2]:='星期一';
wday[3]:='星期二';
wday[4]:='星期三';
wday[5]:='星期四';
wday[6]:='星期五';
fy:=年份;
fm:=月份;
fd:=日期;
wd:=星期;
p:=系统参数(1);
str1:='                                         
           今天是:'+numtostr(fy[p],0)+'年'+numtostr(fm[p],0)+'月'
+数字转化为字符串(fd[p],0)+'日, '+wday[wd[p]+1];
显示文字(数据位置=系统参数(2),最高价,str1),ALIGN1,coloryellow;
A1:=向前引用(最高价,3)=最高值(最高价,2*3+1); B1:=信号过滤(A1,3); C1:=向前赋值(B1,3+1); D1:=信号过滤(C1,3);{高点}
A2:=向前引用(最低价,3)=最低值(最低价,2*3+1); B2:=信号过滤(A2,3); C2:=向前赋值(B2,3+1); D2:=信号过滤(C2,3);{低点}
E1:=(向前引用(最低值(最低价,2*3),1)+向前引用(最高值(最高价,2*3),1))/2; E2:=(最高价+最低价)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND 求逻辑非(D2 AND E1>=E2)) OR 数据位置状态=2 OR 有效值周期数(收盘价)=1;
L1:=(D2 AND 求逻辑非(D1 AND E1=E2));
X1:=向前引用(上一次条件成立位置(H1),1)+1; F1:=向前赋值(H1 AND 统计总数(L1,X1)>0,上一低点位置(条件函数(L1,最低价,10000),X1));
G1:=F1>向前引用(F1,1); I1:=向前赋值(G1,2); LD:=I1>向前引用(I1,1);{过滤后低点}
L2:=LD OR 数据位置状态=2 OR 有效值周期数(收盘价)=1;
X2:=向前引用(上一次条件成立位置(L2),1)+1; F2:=向前赋值(L2 AND 统计总数(H1,X2)>0,上一高点位置(条件函数(H1,最高价,0),X2));
G2:=F2>向前引用(F2,1); I2:=向前赋值(G2,2); HD:=I2>向前引用(I2,1);{过滤后高点}
画直线(LD,最低价,HD,最高价,0),COLORWHITE,LINETHICK1,点状线;
画直线(HD,最高价,LD,最低价,0),COLORWHITE,LINETHICK1,点状线;
J1:=向前赋值(数据位置状态=2,最小值(上一次条件成立位置(HD),上一次条件成立位置(LD))+1); J2:=J1>向前引用(J1,1);
画直线(J2,条件函数(HD,最高价,最低价),数据位置状态=2,条件函数(上一次条件成立位置(HD)>上一次条件成立位置(LD),最高价,最低价),0),COLORWHITE,LINETHICK1,点状线;
A3:=最高价; B3:=向前引用(最高价,向前引用(上一次条件成立位置(HD),1)+1)>向前引用(最高价,向前引用(上一次条件成立位置(HD),1)+2+向前引用(上一次条件成立位置(HD),向前引用(上一次条件成立位置(HD),1)+2));
D3:=A3 AND B3 AND HD; E3:=向前赋值(D3,向前引用(上一次条件成立位置(HD),1)+2); HH:=E3>向前引用(E3,1);{找出全部长期高点}
A4:=最低价>向前引用(最低价,向前引用(上一次条件成立位置(LD),1)+1);
B4:=向前引用(最低价,向前引用(上一次条件成立位置(LD),1)+1); D4:=A4 AND B4 AND LD; E4:=向前赋值(D4,向前引用(上一次条件成立位置(LD),1)+2); LL:=E4>向前引用(E4,1);{找出全部长期低点}
画图标(HH,最高价,10),ALIGN1;      画图标(LL,最低价,12),ALIGN1;
H3:=HH OR 数据位置状态=2 OR 有效值周期数(收盘价)=1; {后面进行过滤,方法同前。只是不用考虑高低点出现在同一K线}
X3:=向前引用(上一次条件成立位置(H3),1)+1; F3:=向前赋值(H3 AND 统计总数(LL,X3)>0,上一低点位置(条件函数(LL,最低价,乘幂(10,20)),X3));
G3:=F3>向前引用(F3,1);  I3:=向前赋值(G3,2);  LZ:=I3>向前引用(I3,1); {长期低点,也可供引用}
L4:=LZ OR 数据位置状态=2 OR 有效值周期数(收盘价)=1;
X4:=向前引用(上一次条件成立位置(L4),1)+1; F4:=向前赋值(L4 AND 统计总数(HH,X4)>0,上一高点位置(条件函数(HH,最高价,-乘幂(10,20)),X4));
G4:=F4>向前引用(F4,1);  I4:=向前赋值(G4,2);  HZ:=I4>向前引用(I4,1);{长期高点,也可供引用}
画直线(HZ,最高价,LZ,最低价,0),COLORGREEN,LINETHICK1;
画直线(LZ,最低价,HZ,最高价,0),COLORGREEN,LINETHICK1;{长期连线}
K1:=向前赋值(数据位置状态=2,最小值(上一次条件成立位置(HZ),上一次条件成立位置(LZ))+1); K2:=K1>向前引用(K1,1);
画直线(K2,条件函数(HZ,最高价,最低价),数据位置状态=2,收盘价,0),COLORGREEN,LINETHICK1; {最后的长期连线,连在收盘价上}
UU:=向前赋值(数据位置状态=2,上一次条件成立位置(LD)+1);
VV:=UU>向前引用(UU,1);
WW:=向前赋值(VV,向前引用(上一次条件成立位置(LD),1)+2);
XX:=WW>向前引用(WW,1);
画直线(XX,最低价,VV,最低价,1),COLORMAGENTA,LINETHICK1;
UU2:=向前赋值(数据位置状态=2,上一次条件成立位置(HD)+1);
VV2:=UU2>向前引用(UU2,1);
WW2:=向前赋值(VV2,向前引用(上一次条件成立位置(HD),1)+2);
XX2:=WW2>向前引用(WW2,1);
画直线(XX2,最高价,VV2,最高价,1),COLORMAGENTA,LINETHICK1;
前一低:向前引用(最低价,上一次条件成立位置(VV)),COLOR99FF66,点状线,LINETHICK3;
前二低:向前引用(最低价,上一次条件成立位置(XX)),COLORFF66FF,点状线,LINETHICK3;
前一高:向前引用(最高价,上一次条件成立位置(VV2)),COLOR99FF66,点状线,LINETHICK3;
前二高:向前引用(最高价,上一次条件成立位置(XX2)),COLORFF66FF,点状线,LINETHICK3;
短高:=向前引用(最高价,上一次条件成立位置(VV2));
短低:=向前引用(最低价,上一次条件成立位置(VV));
{短比: (收盘价-短低)/(短高-短低),LINETHICK0;}{说明:跟随k线的波动分段线及变化变色}
常数:=向前引用(对应大盘收盘价,上一次条件成立位置(VV))/向前引用(收盘价,上一次条件成立位置(VV));

{以下语句为三角形部分}
底:向前引用(最低价,上一次条件成立位置(VV)),COLORred,LINETHICK2;
頂:向前引用(最高价,上一次条件成立位置(VV2)),COLORGreen,LINETHICK2;
{下迭三角形:藍色三角形畫完介入}
画柱线(VV,頂,底,0,0),Colorff6633,linethick3;{}
画直线(VV2,最高价,VV,最低价,0),Colorff6633,linethick3;{斜}
画直线(VV2,最高价,VV,頂,0),Colorff6633,linethick3;{?}
{上漲三角形:紅色三角形畫完出局}
画柱线(VV2 ,頂,底,0,0),Colorred,linethick3;{}
画直线(VV,最低价,VV2,最高价,0),Colorred,linethick3;{斜}
画直线(VV,最低价,VV2,底,0),Colorred,linethick3;{?};
VG:=(简单移动平均((向前引用(最高价,1) / 向前引用(收盘价,2)),27) * 向前引用(收盘价,1));
VD:=(简单移动平均((向前引用(最低价,1) / 向前引用(收盘价,2)),27) * 向前引用(收盘价,1));
A5:=VD[系统参数(1)];
RA5:=VD[(系统参数(1) - 1)];
A10:=VG[系统参数(1)];
RA10:=VG[(系统参数(1) - 1)];
JT5:=条件函数((A5 > RA5),'↑','↓');
JT10:=条件函数((A10 > RA10),'↑','↓');
P:=系统参数(1);
条件函数  P < 0  THEN
DTR:=最大值(最大值((收盘价 - 最高价),绝对值((向前引用(收盘价,1) - 收盘价))),绝对值((向前引用(收盘价,1) - 最低价)));
DTR1:=简单移动平均(DTR,13);
DTR2:=(向前引用(收盘价,1) - 向前引用(DTR1,1));
买卖:最高值(DTR2,13),LINETHICK0,PRECISION2,colorE9E9FF;
X1:=((((开盘价 + (3 * 收盘价)) + 最低价) + 最高价) / 6);
X2:=加权移动平均(加权移动平均(X1,3),5);
X3:=(求相反数(X1) + (2 * X2));
X4:=加权移动平均(加权移动平均(X1,1),5);
X5:=(求相反数(X1) + (2 * X4));
注意: ((3 * X5) - (2 * 移动平均(X5,2,1))),LINETHICK0,PRECISION2,color9F02;
FBARS:=(系统参数(3) - 1);
TJ:=(第一个条件成立位置(收盘价) > (FBARS - 8));
TJ1:=(第一个条件成立位置(收盘价) > (FBARS - 9));
FC:=注意;
FO:=注意;
FL:=最低值(注意,3);
FH:=最高值(注意,3);
画分段线(TJ,FC),短虚线,SHIFT8,colorFF;
TD1:=(((7 * 移动平均((((收盘价 - 最低值(最低价,27)) / (最高值(最高价,27) - 最低值(最低价,27))) * 30),4,1)) - (3 * 移动平均(移动平均((((收盘价 - 最低值(最低价,27)) / (最高值(最高价,27) - 最低值(最低价,27))) * 30),4,1),3,1))) - 移动平均(移动平均(移动平均((((收盘价 - 最低值(最低价,27)) / (最高值(最高价,27) - 最低值(最低价,27))) * 30),4,1),3,1),2,1));
FO:=开盘价;
FH:=最高价;
FL:=最低价;
FC:=收盘价;
KK:=条件函数(((FC >= FO) AND ((FC >= 向前引用(FC,1)) OR (向前引用(FC,1) >= 向前引用(FO,1)))),1,条件函数(((FC < FO) AND ((FC < 向前引用(FO,1)) OR (向前引用(FC,1) < 向前引用(FO,1)))),(0 - 1),0));
显示文字((数据位置 = 系统参数(2)),最高价,' 紅色三角形画完出局;'),ColorFF00FF;
显示文字((数据位置 = 系统参数(2)),最高价,'  \n 藍色三角形画完介入;'),Color00FF00;
显示文字((数据位置 = 系统参数(2)),最高价,(('                        开盘测最高:' + 数字转化为字符串(VG[P],2)) + JT5)),ColorFF00FF;
显示文字((数据位置 = 系统参数(2)),最高价,((' \n                        开盘测最低:' + 数字转化为字符串(VD[P],2)) + JT10)),Color00FF00;
{画分段线(收盘价,注意);}{说明:跟随k线的波动分段线及变化变色}
发表于 2009-9-20 10:41 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2009-9-20 11:24 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2009-9-20 12:37 | 显示全部楼层
回报为大家免费破解通达信加密指标,希望大家能在明白原基础修改公式,明白原理运用
回复 支持 反对

使用道具 举报

发表于 2009-9-21 02:26 | 显示全部楼层
{新结构波浪+支撑+压力等}
{参数:N:1,100,5;S:0,2,2;}
GET:ZIG(3,N),COLORYELLOW;
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,13);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,26);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,55);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'(Ⅰ)'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'(Ⅱ)'),COLORFFFF00;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'(Ⅲ)'),COLORFFFF00;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'⑴'),COLORFF0000;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'⑵'),COLORFF0000;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'⑶'),COLORFF0000;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'⑷'),COLORFF0000;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'⑸'),COLORFF0000;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.94,'【A】'),COLOR00FF00;
DRAWTEXT(EX2 AND DTJD10=2,H*1.03,'【B】'),COLOR00FF00;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.94,'【C】'),COLOR00FF00;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.04,'①'),LINETHICK3,COLORFFFFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.94,'②'),LINETHICK3,COLORFFFFFF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.04,'③'),LINETHICK3,COLORFFFFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.94,'④'),LINETHICK3,COLORFFFFFF;
DMLJ:=HHV(H,120);
{--------------------------------------------}
E:=(H+L+O+2*C)/5;
CRTP:=E+(H-L);
CRZL:=2*E-L;
CRZC:=2*E-H;
CRFZ:=E-(H-L);
CRXL:=(E+CRTP+CRZL+CRZC+CRFZ)/5;
高:=CONST(CRTP),COLORRED;
阻:=CONST(CRZL),COLORC7C9FF;
支:=CONST(CRZC),COLOR7C9CFF;
反:=CONST(CRFZ),COLORDD00DD;
心理:=CONST(CRXL);
高TP:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,高,ISLASTBAR,高,1),COLOR0000FF;
IF(S=1, CRTP,DRAWNULL),COLORRED;
阻力:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,阻,ISLASTBAR,阻,1),COLORC7C9FF;
IF(S=1, CRZL,DRAWNULL),COLORC7C9FF;
支撑:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,支,ISLASTBAR,支,1),COLOR7C9CFF;
IF(S=1, CRZC,DRAWNULL),COLOR7C9CFF;
反转价:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,反,ISLASTBAR,反,1),COLORDD00DD;
IF(S=1, CRFZ,DRAWNULL),COLORDD00DD;
次日心理价:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,心理,ISLASTBAR,心理,1),COLORGREEN;
IF(S=1, CRXL,DRAWNULL),COLORGREEN;
DRAWTEXT(ISLASTBAR,反,'反转价'),LINETHICK1,COLORDD00DD;
DRAWTEXT(ISLASTBAR,支,'支撑'),LINETHICK1,COLOR7C9CFF;
DRAWTEXT(ISLASTBAR,阻,'阻力'),LINETHICK1,COLORC7C9FF;
DRAWTEXT(ISLASTBAR,高,'高TP'),LINETHICK1,COLOR0000FF;{
DRAWTEXT(ISLASTBAR,心理,'心理价'),COLORGREEN;}
T1:=CONST(LLVBARS(LOW,10));
T1HIGH:=CONST(REF(HIGH,T1));
CC:=CONST(CURRBARSCOUNT);
T2:=CONST(BARSLAST(CURRBARSCOUNT>CC+T1 AND H>T1HIGH));
T2HIGH:=CONST(REF(HIGH,T2));
T3:=CONST(BARSLAST(CURRBARSCOUNT>CC+T2 AND HIGH>T2HIGH));
T3HIGH:=CONST(REF(HIGH,T3));
猎击线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),LINETHICK2,COLOR0000FF;
DRAWTEXT(ISLASTBAR, T3HIGH, '猎击线')LINETHICK1,COLOR0000FF;


注:因软件的限制,三角形部分没法做入,我换了别的,你看看吧。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2009-9-21 10:24 | 显示全部楼层
谢谢老师!
回复 支持 反对

使用道具 举报

发表于 2009-9-21 10:25 | 显示全部楼层
谢谢老师提供!
回复 支持 反对

使用道具 举报

发表于 2009-11-6 22:02 | 显示全部楼层
有1个未来函数,问题不大吧
回复 支持 反对

使用道具 举报

发表于 2009-11-6 22:17 | 显示全部楼层
试试吧,先顶了
回复 支持 反对

使用道具 举报

发表于 2009-11-7 23:39 | 显示全部楼层
不能用,还有未来
回复 支持 反对

使用道具 举报

关闭

老钱庄消息上一条 /1 下一条

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-10-24 02:44 , Processed in 0.107856 second(s), 16 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表