老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

关闭
关闭
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 15983|回复: 106

[大智慧] 一年十二倍源码 带选股公式

[复制链接]
发表于 2009-4-21 21:07 | 显示全部楼层 |阅读模式
一年十二倍源码 带选股公式
顶不顶由你.最好不要拿了就跑.

“一年十二倍”

公式原码:
R:=((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100);
K:=EMA(R,3);
D:=EMA(K,3);
一年十二倍:20,colorred;
陡峭度:=IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1);
N:=IF((陡峭度 > 0.35),6,65);
VAR1:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))))*((DATE < 20070110));
VAR1A:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))) + 100)*((DATE < 20070110));
获利盘:=(WINNER(CLOSE))*(100);
获利线:=FORCAST(获利盘,7);
线:=(FORCAST(VAR1A,7))*((DATE < 20070110));
满仓:=((线 > REF(线,1)) and (线 < 25) and (COUNT((线 > REF(线,1)),5) = 1) and IF((N = 6),(获利盘 < 60),(获利盘 < 40)) and (COUNT((获利线 > 20),20) > 0))*(40);
STICKLINE(满仓,0,40,5,0),Color008000;
DRAWTEXT(满仓,45,'满仓'),ColorWHITE;
轻仓:=IF((获利盘 >= 60) and (线 > REF(线,1)) and (REF(线,1) < 20) and (线 < 40) and (COUNT((线 > REF(线,1)),5) = 1) and (REF(N,1) = 6),1,0);
STICKLINE(轻仓,20,D,4,1),ColorFF00FF;
DRAWTEXT(轻仓,45,'轻仓'),ColorFF00FF;
出击:=CROSS(线,20) and IF((COUNT(CROSS(K,D),3) = 1) and (D < 40),1,(线 > D) or (K > D) and (D < 60)) and IF((N = 6),(获利盘 < 70),(获利盘 < 40)) and (COUNT((获利线 > 20),20) > 0);
STICKLINE(出击,0,50,3,1),Color44BB00;
DRAWTEXT(出击,55,'出击'),colorred;
进一:CROSS(线,D) and (D > 30) and (D > REF(D,1)) and (D < 80);
进二:CROSS(线,获利线) and (D > 30) and (获利线 > 25) and (D > REF(D,1));
低进:=IF(进一 and (D > 获利线),进二,进一);
DRAWTEXT(低进,30,'低进'),ColorWHITE;
STICKLINE(低进,20,30,3,1),Color000080;
DRAWTEXT(进二,50,'高进'),Color800080;
STICKLINE(进二,30,50,3,1),coloryellow;
狂喜:=(30)*(CROSS(VAR1,(-2)));
STICKLINE(狂喜,0,20,3,1),coloryellow;
DRAWTEXT(狂喜,(-5),'要涨停'),coloryellow;
狂喜过望:=(50)*((VAR1 = 0));
恐慌:=(20)*(VAR1 < -94);      
STICKLINE(恐慌,0,(-20),5,0),ColorC1C1C1;
DRAWTEXT(恐慌,(-25),'恐慌'),ColorC1C1C1;
极度恐慌:=(-40)*(VAR1 = (-100));            
STICKLINE(极度恐慌,0,(-40),7,1),Color800000;
DRAWTEXT(极度恐慌,(-45),'极度恐慌'),ColorGREEN;
半仓:=(30)*(CROSS(VAR1,(-94)) and (COUNT(恐慌,5) > 0) and (N = REF(N,1)) and IF((N = 6),(获利盘 < 60),(获利盘 < 40)) and (COUNT((获利线 > 20),20) > 0));
STICKLINE(半仓,0,30,4,1),ColorFFFF00;
DRAWTEXT(半仓,35,'半仓'),ColorFFFF00;
加仓:=(30)*(CROSS(K,20) and (COUNT(半仓,5) > 0));
STICKLINE(加仓,0,20,6,1),Color808080;
DRAWTEXT(加仓,25,'加仓'),Color808080;
背离:=(COUNT(恐慌,2) > 0) and (CLOSE < REF(CLOSE,1)) and (VAR1 > REF(VAR1,1));
DRAWICON(背离,0,1),ColorFFFFFF;
================================================================================================
{一年十二倍--满仓选股 }
R:=((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100);
K:=EMA(R,3);
D:=EMA(K,3);
陡峭度:=IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1);
N:=IF((陡峭度 > 0.35),6,65);
VAR1:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))))*((DATE < 30070110));
VAR1A:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))) + 100)*((DATE < 30070110));
获利盘:=(WINNER(CLOSE))*(100);
获利线:=FORCAST(获利盘,7);
线:=(FORCAST(VAR1A,7))*((DATE < 30070110));
((线 > REF(线,1)) and (线 < 25) and (COUNT((线 > REF(线,1)),5) = 1) and IF((N = 6),(获利盘 < 60),(获利盘 < 40)) and (COUNT((获利线 > 20),20) > 0))*(40);
=================================================================================================
{一年十二倍--低进选股 }
R:=((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100);
K:=EMA(R,3);
D:=EMA(K,3);
陡峭度:=IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1);
N:=IF((陡峭度 > 0.35),6,65);
VAR1:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))))*((DATE < 30070110));
VAR1A:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))) + 100)*((DATE < 30070110));
获利盘:=(WINNER(CLOSE))*(100);
获利线:=FORCAST(获利盘,7);
线:=(FORCAST(VAR1A,7))*((DATE < 30070110));
轻仓:=IF((获利盘 >= 60) and (线 > REF(线,1)) and (REF(线,1) < 20) and (线 < 40) and (COUNT((线 > REF(线,1)),5) = 1) and (REF(N,1) = 6),1,0);
出击:=CROSS(线,20) and IF((COUNT(CROSS(K,D),3) = 1) and (D < 40),1,(线 > D) or (K > D) and (D < 60)) and IF((N = 6),(获利盘 < 70),(获利盘 < 40)) and (COUNT((获利线 > 20),20) > 0);
进一:=CROSS(线,D) and (D > 30) and (D > REF(D,1)) and (D < 80);
进二:=CROSS(线,获利线) and (D > 30) and (获利线 > 25) and (D > REF(D,1));
IF(进一 and (D > 获利线),进二,进一);
================================================================================================
{一年十二倍--高进选股 }
R:=((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100);
K:=EMA(R,3);
D:=EMA(K,3);
陡峭度:=IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1);
N:=IF((陡峭度 > 0.35),6,65);
VAR1:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))))*((DATE < 30070110));
VAR1A:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))) + 100)*((DATE < 30070110));
获利盘:=(WINNER(CLOSE))*(100);
获利线:=FORCAST(获利盘,7);
线:=(FORCAST(VAR1A,7))*((DATE < 30070110));
轻仓:=IF((获利盘 >= 60) and (线 > REF(线,1)) and (REF(线,1) < 20) and (线 < 40) and (COUNT((线 > REF(线,1)),5) = 1) and (REF(N,1) = 6),1,0);
出击:=CROSS(线,20) and IF((COUNT(CROSS(K,D),3) = 1) and (D < 40),1,(线 > D) or (K > D) and (D < 60)) and IF((N = 6),(获利盘 < 70),(获利盘 < 40)) and (COUNT((获利线 > 20),20) > 0);
进一:=CROSS(线,D) and (D > 30) and (D > REF(D,1)) and (D < 80);
进二:=CROSS(线,获利线) and (D > 30) and (获利线 > 25) and (D > REF(D,1));
CROSS(线,获利线) and (D > 30) and (获利线 > 25) and (D > REF(D,1));
================================================================================================================================

{一年十二倍--要涨停选股 }
R:=((CLOSE - LLV(LOW,9))/(HHV(HIGH,9) - LLV(LOW,9)))*(100);
K:=EMA(R,3);
D:=EMA(K,3);
陡峭度:=IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1);
N:=IF((陡峭度 > 0.35),6,65);
VAR1:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))))*((DATE < 30070110));
VAR1A:=((-((100)*(HHV(HIGH,N) - CLOSE))/(HHV(HIGH,N) - LLV(LOW,N))) + 100)*((DATE < 30070110));
获利盘:=(WINNER(CLOSE))*(100);
获利线:=FORCAST(获利盘,7);
线:=(FORCAST(VAR1A,7))*((DATE < 30070110));
轻仓:=IF((获利盘 >= 60) and (线 > REF(线,1)) and (REF(线,1) < 20) and (线 < 40) and (COUNT((线 > REF(线,1)),5) = 1) and (REF(N,1) = 6),1,0);
出击:=CROSS(线,20) and IF((COUNT(CROSS(K,D),3) = 1) and (D < 40),1,(线 > D) or (K > D) and (D < 60)) and IF((N = 6),(获利盘 < 70),(获利盘 < 40)) and (COUNT((获利线 > 20),20) > 0);
进一:=CROSS(线,D) and (D > 30) and (D > REF(D,1)) and (D < 80);
进二:=CROSS(线,获利线) and (D > 30) and (获利线 > 25) and (D > REF(D,1));
CROSS(VAR1,(-2));

评分

参与人数 1威望 +2 收起 理由
了得 + 2 我很赞同您的观点

查看全部评分

发表于 2009-4-21 21:39 | 显示全部楼层
抢沙发ddddddddd
回复 支持 反对

使用道具 举报

发表于 2009-4-21 21:45 | 显示全部楼层
板凳,这个指标已经有了但还是要顶!
回复 支持 反对

使用道具 举报

发表于 2009-4-21 22:09 | 显示全部楼层
试一试
回复 支持 反对

使用道具 举报

发表于 2009-4-21 22:18 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2009-4-21 22:38 | 显示全部楼层
真是个好东东。。要大力支持啊!
回复 支持 反对

使用道具 举报

发表于 2009-4-21 22:53 | 显示全部楼层
多谢楼主的分享
回复 支持 反对

使用道具 举报

发表于 2009-4-21 22:57 | 显示全部楼层
第9行包含未来函数:winner
第55行包含未来函数:winner
第68行包含未来函数:winner
第85行包含未来函数:winner
第103行包含未来函数:winner
回复 支持 反对

使用道具 举报

发表于 2009-4-21 23:11 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2009-4-21 23:28 | 显示全部楼层
这个指标已经有了但还是要顶!在”我的公式“里
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2018-7-21 10:21 , Processed in 0.110930 second(s), 19 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表