老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 505|回复: 0

[通达信] 请老师把公式中出现<抄底>信号时,改写一个预警选股公式,谢谢!

[复制链接]
发表于 2016-12-22 10:23 | 显示全部楼层 |阅读模式

R1:=(RSI-50)/1.5;{将RSI指标转换到零轴附近并按比例缩小}
DRAWBAND(R1,RGB(0,180,255),18,RGB(00,00,00));
R2:=IF(R1>=0,0,R1);
DRAWBAND(-15,RGB(255,100,155),R2,RGB(00,00,00));
R:R1,COLORWHITE,LINETHICK2;
F:=100*(C/REF(C,1)-1);{单日涨幅}
MAR:=EMA(R,13);{均}
XX:R-MAR,COLORSTICK;
GD:=(C=HHV(C,5) OR H=HHV(H,5));
排除1:=NOT(GD OR REF(GD,1));
排除2:=NOT(EXIST(F<-9,3));
排除3:=C/EXPMA(C,50)-1<0.1;
入:DRAWICON(CROSS(XX,-10) AND 排除1 AND 排除2 AND 排除3,-10,1);
CHUTJ:=XX<REF(XX,1) AND REF(XX,1)>REF(XX,2);
出:DRAWTEXT(FILTER(COUNT(CHUTJ,BARSLAST(入))=2 AND XX>0,6) ,10,'!'),COLORGREEN;
IF(R>=18 ,R,DRAWNULL),COLORMAGENTA,LINETHICK3;
IF(R<=-15 ,R,DRAWNULL),COLORFFFF00,LINETHICK3;
-10,COLORMAGENTA,LINETHICK2;
18,COLORCYAN,LINETHICK2;
-15,COLORRED,LINETHICK2;
DRAWTEXT(CROSS(-15,R),R*1.20,'底'),COLORGREEN;
DRAWTEXT(CROSS(R,18),R*1.10,'顶'),COLORYELLOW;
R买入:STICKLINE(CROSS(R,-24),0,60,3,0),LINETHICK2,COLORMAGENTA;
DRAWTEXT(CROSS(R,-24),50,'-抄底'),COLORYELLOW;
















关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-12-13 17:20 , Processed in 1.199444 second(s), 17 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表