老钱庄股票论坛

 找回密码
 5秒快速注册
查看: 2017|回复: 1

[通达信] 哪位老师帮忙改一个预警公式

[复制链接]
发表于 2016-5-20 12:58 | 显示全部楼层 |阅读模式
Var1:=(CLOSE-LLV(LOW,80))/(HHV(HIGH,80)-LLV(LOW,80))*200; Var2:=SMA(Var1,3,1); Var3:=SMA(Var2,3,1); Var4:=3*Var2-2*Var3; Var5:=LLV(LOW,5); Var6:=HHV(HIGH,5); Var7:=EMA((CLOSE-Var5)/(Var6-Var5)*100,4)*2; Var8:=EMA(0.667*REF(Var7,1)+0.333*Var7,2); Var9:=3*Var7-2*Var8; VarA:=POW(MA(CLOSE,5),2)+MA(CLOSE,5); VarB:=POW(MA(LOW,5),2)+MA(LOW,5); VarC:=POW(MA(HIGH,5),2)+MA(HIGH,5); VarD:=(VarA-LLV(VarB,64))/(HHV(VarC,64)-LLV(VarB,64))*150+65-10; VarE:=SMA(VarD,3,1)*1.5-100; VarF:=SMA(VarE,3,1); Var10:=3*VarE-2*VarF; Var11:=(HIGH+LOW+CLOSE*2)/4; Var12:=EMA(Var11,13); Var13:=STD(Var11,13); Var14:=(Var11-Var12)*100/Var13; Var15:=EMA(Var14,5); Var17:=EMA(Var15,13)+200-100; Var18:=EMA(Var17,10); Var19:=3*Var17-2*Var18; Var1A:=Var2+Var7+VarE+Var17; Var1B:=Var3+Var8+VarF+Var18; Var1C:=Var4+Var9+Var10+Var19; Var1D:=(HIGH+LOW+CLOSE)/3; Var20:=(Var1D-MA(Var1D,34))/(0.015*AVEDEV(Var1D,34)); Var21:=DMA(AMOUNT/VOL/100,VOL/CAPITAL); Var22:=(HIGH+LOW+CLOSE+Var1D)/4; Var23:=EMA(Var22,24); Var24:=STD(Var22,24); Var25:=(Var22-Var23)/Var24*100; Var26:=(Var1D-MA(Var1D,24))/(0.015*AVEDEV(Var1D,24)); Var27:=EMA(Var25,5); Var2A:=((Var27+Var26+Var20)/3+165)/4; Var2B:=(EMA(EMA(EMA(Var2A,15),10),5)-25)*2+Var21; Var2C:=(Var1A+Var1B+Var1C*30)/32/5-15; Var2D:=EMA(Var2C,13); Var2E:=(Var2A+Var2C)/2/1.1; Var28:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100; Var29:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100; Var30:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100; Var31:=REF(CLOSE,1); Var32:=SMA(MAX(CLOSE-Var31,0),5,1)/SMA(ABS(CLOSE-Var31),5,1)*100; Var33:=(HIGH+LOW+CLOSE)/3; Var34:=(Var33-MA(Var33,14))/(0.015*AVEDEV(Var33,14)); 超短:EMA(Var2E,3),colorred ; 短线:EMA(超短,5),colorwhite; 趋势线:EMA((Var2B+Var2D)/2,2) ,coloryellow;

要求:红线上穿白线时作为选股预警。谢谢!
发表于 2016-5-21 11:53 | 显示全部楼层
DRAWICON( CROSS(超短,短线),超短,1);
回复 支持 反对

使用道具 举报

关闭

老钱庄消息上一条 /1 下一条

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-10-24 19:10 , Processed in 0.105330 second(s), 16 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表