老钱庄股票论坛

 找回密码
 5秒快速注册
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 20352|回复: 110

[通达信] 东郭立体指标公式通达信的“均线”原码放送!决无未来!

[复制链接]
发表于 2008-8-12 15:00 | 显示全部楼层 |阅读模式


上任初始,没什么礼物送给大家,只好把自编常用公式“均线”献给大家,

做个见面礼,好不好欢迎大家品评!

用东郭版的朋友,可以直接考入原公式“均线”里,将其复盖既可!

{通达信 均线 东郭常用系列 主图}
{M1  2  1000  5
M2  2  1000  10
M3  2  1000  20
M4  2  1000  30
M5  2  1000  60
M6  2  1000  120
M7  2  1000  250}
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR000033;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000066;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000CC;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000FF;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCC66FF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR990000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
MA5:MA(CLOSE,M1);
MA10:MA(CLOSE,M2);
MA20:MA(CLOSE,M3);
MA30:MA(CLOSE,M4);
MA60:MA(CLOSE,M5);
{MA120:MA(CLOSE,M6);
MA250:MA(CLOSE,M7);}
十日叉:IF(CROSS(MA5,MA10),MA5,DRAWNULL),CROSSDOT,COLORFFFFFF,LINETHICK2;
廿日叉:IF(CROSS(MA10,MA20),MA10,DRAWNULL),CROSSDOT,COLOR00FFFF,LINETHICK2;
卅日叉:IF(CROSS(MA20,MA30),MA20,DRAWNULL),CROSSDOT,COLOR0099FF,LINETHICK2;
五日线:IF(MA5>=REF(MA5,1) AND MA5>=MA10,MA5,DRAWNULL),COLORFFFFFF,LINETHICK2;
十日线:IF(MA10>=REF(MA10,1) AND MA10>=MA20,MA10,DRAWNULL),COLOR00FFFF,LINETHICK2;
廿日线:IF(MA20>=REF(MA20,1) AND MA20>=MA30,MA20,DRAWNULL),COLORFF00FF,LINETHICK2;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
MACD1:=CROSS(DIFF,DEA) AND COUNT(MACD>0,1)=1;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,9,1);
D:=SMA(K,9,1);
J:=3*K-2*D;
KDJ1:=CROSS(K,D) AND CROSS(J,D);
均线:=CROSS(MA(C,5),MA(C,10));
量线:=CROSS(MA(V,5),MA(V,10));
SCC:=MACD1 AND KDJ1 AND 均线 AND 量线;
SC1:=MACD1 AND KDJ1;
SC2:=均线 AND 量线;
SC3:=均线 AND MACD1;
SC4:=量线 AND KDJ1;
SC5:=均线 AND KDJ1;
SC6:=MACD1 AND 量线;
DRAWICON(SC1 OR SC2 OR SC3 OR SC4 OR SC5 OR SC6,L*0.94,11);
DRAWICON(SCC,L*0.96,7);
DRAWICON(CROSS(MA5,MA10),L*0.98,1);
DRAWICON(CROSS(MA10,MA20),L*0.98,1);
DRAWICON(CROSS(MA20,MA30),L*0.98,1);
DRAWICON(CROSS(MA10,MA5),H*1.02,2);
DRAWICON(CROSS(MA20,MA10),H*1.02,2);
DRAWICON(CROSS(MA30,MA20),H*1.02,2);

如果你的公式管理器报错,那是你的通达信版本太低了,到老钱庄这里回帖升级:
http://bbs.laoqianzhuang.com/viewthread.php?tid=360756&extra=page%3D2
http://bbs.laoqianzhuang.com/viewthread.php?tid=356293&extra=page%3D2&page=1


欢迎回帖下载(内含说明):   如果你喜欢,可不要忘记评分,可以在首帖中留下名字?增进关系!

[ 本帖最后由 lngyj 于 2008-8-18 19:04 编辑 ]

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x

评分

参与人数 4威望 +7 庄币 +6 收起 理由
zhl110 + 2 + 2 很给力!
小老牛 + 1 还可以
672648178 + 2 + 2 我很赞同
东郭老先生 + 2 + 2 精品文章

查看全部评分

发表于 2008-8-12 15:32 | 显示全部楼层
超级感谢
回复 支持 反对

使用道具 举报

发表于 2008-8-12 15:36 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2008-8-12 16:29 | 显示全部楼层
首先感谢你发的源码。支持你当版主。但是就此主图来讲,我觉得一般,加入了MACD和Kdj而已,没多少自己额特色。见谅。

评分

参与人数 1威望 +2 庄币 +4 收起 理由
lngyj + 2 + 4 原创内容

查看全部评分

回复 支持 反对

使用道具 举报

发表于 2008-8-12 16:32 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2008-8-12 17:09 | 显示全部楼层
路过  支持下
回复 支持 反对

使用道具 举报

发表于 2008-8-12 17:15 | 显示全部楼层
看看!!!!!!!
回复 支持 反对

使用道具 举报

发表于 2008-8-12 17:19 | 显示全部楼层
首先感谢你发的源码。支持你当版主。

评分

参与人数 1威望 +2 庄币 +2 收起 理由
lngyj + 2 + 2 感谢参与

查看全部评分

回复 支持 反对

使用道具 举报

发表于 2008-8-12 17:23 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2008-8-12 17:58 | 显示全部楼层
dddddd
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-11-21 01:14 , Processed in 0.121238 second(s), 17 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表