老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 1487|回复: 9

[通达信] 请老师为风险控制买入卖出做个选股预警

[复制链接]
发表于 2016-1-11 21:27 | 显示全部楼层 |阅读模式
STICKLINE(C>0,90,95,10,0),COLOR408000;
STICKLINE(C>0,10,5,10,0),COLOR408000;
HDY:=EMA (100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
DRAWBAND(HDY,RGB(255,000,139),10,RGB(255,255,71));
STICKLINE(C>0,90,10,10,0),COLOR000000;
风险值:HDY,COLORCYAN,LINETHICK1;
警示线:45,COLORBLACK,LINETHICK1,POINTDOT;
DIF:EMA(CLOSE,9)-EMA(CLOSE,21), COLORBLACK;
DEA:EMA(DIF,5) COLORBLACK;
MACD:(DIF-DEA)*2,COLORRED;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线: EMA(V11,3), COLORBLACK;
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;
AA:=(趋势线<=13) AND FILTER((趋势线<=13),15);
买入股票: STICKLINE(趋势线<=13 AND V12>13,0,50,5,0),COLOR0099FF;
V1:=EMA(CLOSE,5)-EMA(CLOSE,340);
V2:=EMA(V1,144);
V3:(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,COLORBLACK;
卖出:-1*IF((CROSS(98.5,V3) AND V1>V2) AND COUNT(V3>97,3)=2,20,0)+90,COLORBLACK;
买入:IF(CROSS(V3,5) AND V1<V2,20,0)+10,COLOR0090FF;
DRAWTEXT(CROSS(V3,5) AND V1<V2,25,'买入'),COLORFF00FF;
DRAWTEXT(CROSS(98.5,V3) AND V1>V2,75,'卖出'),COLOR00FF00;
请老师在指标中出现粗的黄色柱子的时候做个选股预警,里面有2个黄色信号买入,我说的是粗的柱子买入信号哦。

发表于 2016-1-11 21:48 | 显示全部楼层
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:= EMA(V11,3);
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;
买入股票: 趋势线<=13 AND V12>13;
回复 支持 反对

使用道具 举报

 楼主| 发表于 2016-1-11 21:58 | 显示全部楼层
米兹 发表于 2016-1-11 21:48
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55) ...

谢谢老师,另外还有个低进指标能帮我优化下吗,出现低级信号的时候会漂移。RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH),COLORRED,NODRAW;
低进:IF(黄金 AND RSVV<VARB2-2,28,0),STICK,COLOR00FFFF,LINETHICK2;
DRAWTEXT(低进>0,40,'-低进'),COLORYELLOW;
DRAWICON(低进>0,42,1 );
STICKLINE(低进,0,40,1,9),COLORWHITE;
回复 支持 反对

使用道具 举报

发表于 2016-1-12 11:30 | 显示全部楼层
路过围观一下...............
回复 支持 反对

使用道具 举报

 楼主| 发表于 2016-1-12 11:38 | 显示全部楼层
老覃阿呜 发表于 2016-1-12 11:30
路过围观一下...............

老覃老师,上次你做的那个低进指标感觉界面很不清楚,看不大清楚,能否再改一下呢?》
回复 支持 反对

使用道具 举报

发表于 2016-1-12 12:38 | 显示全部楼层
本帖最后由 老覃阿呜 于 2016-1-12 13:18 编辑
yuzelonger 发表于 2016-1-12 11:38
老覃老师,上次你做的那个低进指标感觉界面很不清楚,看不大清楚,能否再改一下呢?》

按照不同思路,在公式中可选用的函数、算法、提示方式等等,或许多种多样。一旦选定函数、算法、方式后,整个公式就具备了唯一性,仅改选股预警----满足条件则 1 “是”,不满足条件则 0 “非”,不管谁改、怎么改,大同小异,不离其宗。
同一个问题,反复求助,姑且视作你的一种玩法,各有各的玩法,我继续围观。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2016-1-12 20:22 | 显示全部楼层
本帖最后由 yuzelonger 于 2016-1-12 20:35 编辑
老覃阿呜 发表于 2016-1-12 12:38
按照不同思路,在公式中可选用的函数、算法、提示方式等等,或许多种多样。一旦选定函数、算法、方式后, ...

下面这张是老师修改过后的副图显示,同一个股票,就单单显示比较模糊,看起来不清楚,而且是连续发出低进信号,这样的话就失去参考价值了,莫非也要连续买进?


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x
回复 支持 反对

使用道具 举报

发表于 2016-1-12 21:17 | 显示全部楼层
本帖最后由 老覃阿呜 于 2016-1-12 21:25 编辑
yuzelonger 发表于 2016-1-12 20:22
下面这张是老师修改过后的副图显示,同一个股票,就单单显示比较模糊,看起来不清楚,而且是连续发出低进 ...

我建议你直接用回原公式,那个比较准,提示也不多。
以你原公式,单纯直接去掉未来,就成这样。
要再进一步优化,过滤掉部分信号,可跟原公式的立意不符,也会滞后,而且不准,甚至提示低进的地方该跑。。

RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=CROSS(0,提纯),COLORRED,NODRAW;
低进:IF(FILTER(黄金,5) AND RSVV<VARB2-2,28,0),STICK,COLOR00FFFF,LINETHICK2;
DRAWTEXT(低进>0,40,'-低进'),COLORYELLOW;
DRAWICON(低进>0,42,1 );
STICKLINE(低进,0,40,1,9),COLORWHITE;
回复 支持 反对

使用道具 举报

 楼主| 发表于 2016-1-13 15:38 | 显示全部楼层
老覃阿呜 发表于 2016-1-12 21:17
我建议你直接用回原公式,那个比较准,提示也不多。
以你原公式,单纯直接去掉未来,就成这样。
要再进 ...

也是,去掉函数之后发出的信号的确不准了。还是用原来的做一下参考吧,虽然会漂移但是起码也是短期底部,不是高价位买入。谢谢老师、。
回复 支持 反对

使用道具 举报

发表于 2016-1-21 11:51 | 显示全部楼层
yuzelonger 发表于 2016-1-11 21:58
谢谢老师,另外还有个低进指标能帮我优化下吗,出现低级信号的时候会漂移。RSVV:=(CLOSE-LLV(LOW,10))/(H ...

ZXNH 直线拟合函数 调取日后数据 自然会飘移 修改为其他就没这么准了 弃用
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-12-18 16:53 , Processed in 0.104472 second(s), 19 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表