老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

关闭
关闭
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 5331|回复: 5

[通达信] 【通达信】源码分时有庄特别

[复制链接]
头像被屏蔽
发表于 2015-12-31 13:45 | 显示全部楼层 |阅读模式
{分时控盘}
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,1,1),COLOR00FF00;
STICKLINE(控盘>REF(控盘,1) AND 控盘<0,控盘,0,1,1),COLORFF00FF;
无庄控盘:=控盘<0;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLOR0000FF;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,1),COLORFFFF00;
主力出货:=控盘<REF(控盘,1) AND 控盘>0;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,1),COLOR00FFFF;
高度控盘: VAR2>50 AND COST(85)<CLOSE AND 控盘>0,COLOR00FFFF,LINETHICK2;
A10:=CROSS(控盘,0);
控盘B:=FILTER(IF(A10,1,0),5);
{分时价格原码}
JJ:=DYNAINFO(11);
{波段买卖原码}
P:=55;S:=8;M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;
神:=EMA(财,M1),COLORGREEN,LINETHICK1;
DRAWBAND(财,RGB(255,0,0),神,RGB(0,100,50));
{股价与均线偏离买卖条件}
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
{控盘买卖条件}
STJ01:=控盘<REF(控盘,1)  AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
{波段买卖条件}
BTJ3:=CROSS(财,神) AND  财<-0.3;
BTJ32:=CROSS(财,神) AND  财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND  财>1.618;
{以下为信号};
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
DRAWICON(BTJ82,神,23);{追买};
DRAWICON(BTJ81 AND TIME>10,神,27);{};
DRAWICON(BTJ811 AND TIME>10,神,26);{有庄};
DRAWTEXT(BTJ81,神,''),COLORRED;
DRAWTEXT(BTJ811,神*1.2,'有庄'),COLORWHITE;
STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
DRAWICON(STJ81,神,19);
STJ82:=FILTER(STJ02 AND STJ32 ,13);
DRAWICON(STJ82,神,15);
STJ83:=STJ81 AND STJ82;
DRAWTEXT(STJ83,神,'必卖'),COLOR00FF00;

这是通达信的源码高手优化下大智慧的通过调整控盘幅度的参数大于0.8的话可以选出几只涨停的测试了下信号买点很不错哪位高手优化下大智慧在作个预警条件就更完美了.大家一起研究.


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x
发表于 2016-1-2 13:04 | 显示全部楼层
谢谢分享,感谢楼主。
回复 支持 反对

使用道具 举报

头像被屏蔽
发表于 2016-1-6 09:37 | 显示全部楼层
昨日沪深股指惯性大幅低开,沪指开盘即破位3200整数关口,开市后个股全面回升,股指快速回抽并翻红,沪指快速站稳3300之后陷入横盘整理。临近11:00部分个股涨幅扩大,船舶制造行业板块盘中涨幅近8%领涨两市,钢铁蓝筹板块涨幅亦超过5%,但股指并未再度刷新日内高位。随后个股普遍回落、下跌个股跌幅扩大,股指也再次下行并于午后创下盘中新低点,而尾盘在多头反扑之下各股指回升并收于日内相对高位。两市成交量较前出现明显放大,中小盘个股居弱。
回复 支持 反对

使用道具 举报

发表于 2016-1-20 12:48 | 显示全部楼层
感谢楼主分享大家一起研究
回复 支持 反对

使用道具 举报

头像被屏蔽
 楼主| 发表于 2016-1-21 09:43 | 显示全部楼层
davidyxw 发表于 2016-1-20 12:48
感谢楼主分享大家一起研究

多谢支持~!~!~!~!~!~!~!
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2018-5-22 12:23 , Processed in 0.095172 second(s), 19 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表