老钱庄股票论坛

 找回密码
 5秒快速注册
查看: 833|回复: 4

[通达信] 请老师帮忙做个出现“黑马”报警选股公式,谢谢!

[复制链接]
发表于 2015-11-17 16:49 | 显示全部楼层 |阅读模式


请老师帮忙做个出现“黑马”两字时报警选股公式!万分感谢!


A1:=1;
A2:=(5);
A3:=(((2*CLOSE)+HIGH)+LOW)/4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((((A3-A4)/(A5-A4))*100),13);
A7:=(EMA(((0.667*(REF(A6,1)))+(0.333*A6)),2))*A1;
决策线:(EMA(A7,A2))*A1,COLORRED;
A8:=(HHV(HIGH,9))-(LLV(LOW,9));
A9:=(HHV(HIGH,9))-CLOSE;
A10:=CLOSE-(LLV(LOW,9));
A11:=((A9/A8)*100)-70;
A12:=((CLOSE-(LLV(LOW,60)))/((HHV(HIGH,60))-(LLV(LOW,60))))*100;
A13:=SMA(((A10/A8)*100),3,1);
A14:=(SMA(A13,3,1))-(SMA(A11,9,1));
A15:=IF((A14>100),(A14-100),0);
A16:=(EMA((((A3-A4)/(A5-A4))*100),8))*A1;
A17:=(EMA(A16,5))*A1;
STICKLINE(((A16-A17)>0),A16,A17,3,1),COLORFFAA18;
STICKLINE(((A16-A17)<0),A16,A17,3,0),COLORGREEN;
A18:=(EMA(CLOSE,2))*A1;
A19:=(EMA((((SLOPE(CLOSE,21))*20)+CLOSE),42))*A1;
A20:=(HHV((MA(HIGH,13)),13))*A1;
A21:=(LLV((MA(HIGH,13)),1))*A1;
A22:=(EMA(CLOSE,4))*A1;
A23:=((((A18>=A19) AND (A21=A20)) AND (A18>A22)) AND (CLOSE>A21)) AND ((REF(A21,1))<(REF(A20,1)));
A24:=BARSLAST(A23)+1;
A25:=(LLV(LOW,A24))*1.3;
A26:=(LLV(LOW,20))*1.418;
A27:=(((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26);
A28:=A27 AND (FILTER(A27,A24));
{A29:=(STRFIND(STKNAME,'ST',1)) > 0;}
A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ;
A31:=A30 AND (FILTER(A30,20));
DRAWICON((A28 OR A31),决策线,1);
DRAWTEXT((A28 OR A31),决策线,'←黑马'),COLORRED;
 楼主| 发表于 2015-11-17 21:36 | 显示全部楼层
我顶!!!!!!帮帮忙呀~!
回复 支持 反对

使用道具 举报

发表于 2015-11-17 21:41 | 显示全部楼层
A18:=(EMA(CLOSE,2));
A19:=(EMA((((SLOPE(CLOSE,21))*20)+CLOSE),42));
A20:=(HHV((MA(HIGH,13)),13));
A21:=(LLV((MA(HIGH,13)),1));
A22:=(EMA(CLOSE,4));
A23:=((((A18>=A19) AND (A21=A20)) AND (A18>A22)) AND (CLOSE>A21)) AND ((REF(A21,1))<(REF(A20,1)));
A24:=BARSLAST(A23)+1;
A25:=(LLV(LOW,A24))*1.3;
A26:=(LLV(LOW,20))*1.418;
A27:=(((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26);
A28:=A27 AND (FILTER(A27,A24));
A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ;
A31:=A30 AND (FILTER(A30,20));
A28 OR A31;
回复 支持 反对

使用道具 举报

 楼主| 发表于 2015-11-18 00:28 | 显示全部楼层
谢谢老师!!!!!!
回复 支持 反对

使用道具 举报

发表于 2015-11-23 16:30 | 显示全部楼层
yuhan1043 发表于 2015-11-17 21:36
我顶!!!!!!帮帮忙呀~!

这个是黑马雷达指标吧。感觉也有点迟钝。
回复 支持 反对

使用道具 举报

关闭

老钱庄消息上一条 /1 下一条

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-10-21 18:08 , Processed in 0.103055 second(s), 16 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表