老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 1978|回复: 3

[通达信] 把MACD和KDJ整合在一起,显示背离的副图指标

[复制链接]
发表于 2015-8-17 23:31 | 显示全部楼层 |阅读模式
本帖最后由 老覃阿呜 于 2015-8-17 23:35 编辑

JJ:=(HIGH+LOW+2*CLOSE)/4;
QJ0:=VOL/IF(HIGH=LOW,1,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/SUM(VOL,10)*100;
DX:=MA(DDX,13)*38.2;
DIF:SMA(DX,7,1)+50,COLORFFFFFF;
DEA:SMA(DIF,3,1),COLOR00FFFF;
MACD:(DIF-DEA)*4,COLORSTICK;
DRAWBAND(DIF,RGB(220,160,230),DEA,RGB(110,90,150));

RSV:=(JJ-MA(JJ,14.14))/(0.015*AVEDEV(JJ,14.14))/3.82+50;
K:EMA(RSV,3.5),COLORWHITE;
D:EMA(K,3.5),COLORYELLOW;
J:3*K-2*D,COLORMAGENTA;

A11:=BARSLAST(REF(CROSS(DIF,DEA),1));
B1:=REF(C,A11+1)>C AND REF(DIF,A11+1)<DIF AND CROSS(DIF,DEA);

A12:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(C,A12+1)>C AND REF(K,A12+1)<K AND CROSS(K,D);

LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;

A13:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A13+1)>C AND REF(RSI1,A13+1)<RSI1 AND CROSS(RSI1,RSI2);

C1:=BARSLAST(REF(CROSS(DEA,DIF),1));
D1:=REF(C,C1+1)<C AND REF(DIF,C1+1)>DIF AND CROSS(DEA,DIF);

C2:=BARSLAST(REF(CROSS(D,K),1));
D2:=REF(C,C2+1)<C AND REF(K,C2+1)>K AND CROSS(D,K);

C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);

MACD底离:STICKLINE(B1>0,0,10,1,0),COLORRED;
DRAWTEXT(B1>0,10,'M底离'),COLORRED;
KDJ底离:STICKLINE(B2>0,0,20,0.5,0),COLORFF00FF;
DRAWTEXT(B2>0,20,'K底离'),COLORFF00FF;
RSI底离:STICKLINE(B3>0,0,25,0.1,0),COLORLIRED;
DRAWTEXT(B3>0,25,'R底离'),COLORLIRED;
MACD顶离:STICKLINE(D1>0,95,100,1,0),COLOR00FF00;
DRAWTEXT(D1>0,94,'M顶离'),COLOR00FF00;
KDJ顶离:STICKLINE(D2>0,90,100,0.5,0),COLORFFCC66;
DRAWTEXT(D2>0,89,'K顶离'),COLORFFCC66;
RSI顶离:STICKLINE(D3>0,85,100,0.1,0),COLORWHITE;
DRAWTEXT(D3>0,86,'R顶离'),COLORWHITE;



发表于 2015-8-18 20:30 | 显示全部楼层
谢谢,您辛苦了!...................
回复 支持 反对

使用道具 举报

发表于 2016-1-16 00:52 | 显示全部楼层

谢谢,您辛苦了!...................
回复 支持 反对

使用道具 举报

发表于 2016-10-31 11:18 | 显示全部楼层
谢谢,您辛苦了!...................
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-12-19 04:33 , Processed in 0.096468 second(s), 18 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表