老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

关闭
关闭
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 1785|回复: 4

[通达信] 量价MACD分时主图指标公式

[复制链接]
发表于 2015-5-19 08:42 | 显示全部楼层 |阅读模式
{放量}
放量:=SUM(V,3)>REF(SUM(V,7),3)*2;
DRAWICON(放量=1 AND FILTER(放量=1,6),C,11);
DRAWTEXT(放量=1 AND FILTER(放量=1,6),C-C*0.015,'量'),COLORYELLOW;
{价}
现价:C,COLORMAGENTA,LINETHICK3;
均价:SUM(V*C,0)/SUM(V,0),COLORGREEN,LINETHICK3;
绿跌:IF(均价<=REF(均价,1),均价,DRAWNULL),COLORGREEN,LINETHICK5;
蓝涨:IF(均价>=REF(均价,1),均价,DRAWNULL),COLORBLUE,LINETHICK5;
{分时MACD}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
X:=CONST(HHV(ABS(C-DYNAINFO(3)),FROMOPEN))/CONST(HHV(ABS(DIF),FROMOPEN))*0.6;
DI:DIF*X+DYNAINFO(3),COLORGRAY;
DE:DEA*X+DYNAINFO(3),COLOR7700AA;
MAC:=MACD*X;
STICKLINE(MAC>0,DYNAINFO( 3),MAC+DYNAINFO( 3),0,1),COLORRED;
STICKLINE(MAC<0,DYNAINFO( 3),MAC+DYNAINFO( 3),0,1),COLORCYAN;
DRAWTEXT((CROSS(DIF,DEA) AND 蓝涨),C,'买'),COLORYELLOW;.


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x
发表于 2015-5-19 20:02 | 显示全部楼层
辛苦了  !  谢谢分享  !
回复 支持 反对

使用道具 举报

发表于 2015-5-20 00:55 | 显示全部楼层
辛苦了  !  谢谢分享  !
回复 支持 反对

使用道具 举报

发表于 2015-5-20 07:20 | 显示全部楼层
多 谢 提 供  !辛苦了
回复 支持 反对

使用道具 举报

发表于 2018-6-13 11:03 | 显示全部楼层
学习中  
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 1239457655 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2018-8-15 21:28 , Processed in 1.428809 second(s), 23 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表