老钱庄股票论坛

 找回密码
 5秒快速注册
查看: 4719|回复: 9

[技术研讨] 吴迪选股公式原码

[复制链接]
发表于 2008-7-1 17:11 | 显示全部楼层 |阅读模式
识货的是宝,不识货的是草!!

先建一个公式,选股公式引用的!

YY0

yyINDEXO,colorred,linethick2;
yyh:INDEXH,coloryellow,linethick2;
yyl:INDEXL,colorblue,linethick2;
yyc:INDEXC,colorgreen,linethick2;

{!A地量}
b1:=ma(v,3);
b2:=v
b3:=CAPITAL/v/100<0.25;
地量:count(v=1 or b2 or b3;

{回档}
aa1:=(max(c,o)+h)/2;
aa2:=(min(c,o)+l)/2;
a2:=c>=ref(c,2)+(ref(c,1)-ref(c,2))/ref(c,2)/4;
a3:=ref(c,1)>ref(c,2)*1.03 or ref(c,1)>ref(c,3)*1.04 or
count(ref(c,1)>ref(c,2),3)=3;
a4:=(aa1-aa2)/ref(c,1)<0.04 and
(c-ref(c,1))/ref(c,1)<=0.75*(ref(c,1)-ref(c,2))/ref(c,2);
a5:=(aa1-aa2)/ref(c,1)<0.6*(ref(c,1)-ref(c,2))/ref(c,2);
a6:=(ref(h,1)-ref(c,1))<(ref(c,1)-ref(c,2))*1.5 and ref(c,1)>=ref(o,1);
回档:a2 and a3 and a4 and a5 and a6;

{回调整理}
{参数设置1:振幅:1-8,默认值3.}
{参数设置2:量比:1-5,默认值1.}
H1:=CLOSE > MA(CLOSE,5);
H2:=MA(CLOSE,10) > MA(CLOSE,5);
H3:=MA(CLOSE,10) > MA(CLOSE,30);
H4:=MA(CLOSE,30) > REF(MA(CLOSE,30),1);
H5:=MA(CLOSE,10) > REF(MA(CLOSE,10),1);
HP3R:=(HHV(HIGH,3)-LLV(LOW,3))/LLV(LOW,3) < 振幅/100;
HP4R:=(HHV(HIGH,4)-LLV(LOW,4))/LLV(LOW,4) < 振幅/100;
HP5R:=(HHV(HIGH,5)-LLV(LOW,5))/LLV(LOW,5) < 振幅/100;
HP6R:=(HHV(HIGH,6)-LLV(LOW,6))/LLV(LOW,6) < 振幅/100;
HP7R:=(HHV(HIGH,7)-LLV(LOW,7))/LLV(LOW,7) < 振幅/100;
HP8R:=(HHV(HIGH,8)-LLV(LOW,8))/LLV(LOW,8) < 振幅/100;
HP9R:=(HHV(HIGH,9)-LLV(LOW,9))/LLV(LOW,9) < 振幅/100;
HP10R:=(HHV(HIGH,10)-LLV(LOW,10))/LLV(LOW,10) < 振幅/100;
HP11R:=(HHV(HIGH,11)-LLV(LOW,11))/LLV(LOW,11) < 振幅/100;
HP12R:=(HHV(HIGH,12)-LLV(LOW,12))/LLV(LOW,12) < 振幅/100;
HP312:=HP3R OR HP4R OR HP5R OR HP6R OR HP7R OR HP8R OR HP9R OR HP10R OR HP11R OR HP12R;
V3R:=LLV(VOL,3) / HHV(VOL,20) < 量比/10;
V4R:=LLV(VOL,4) / HHV(VOL,20) < 量比/10;
V5R:=LLV(VOL,5) / HHV(VOL,20) < 量比/10;
V35R:=V3R OR V4R OR V5R;
回调: H1 AND H2 AND H3 AND H4 AND H5 AND HP312 AND V35R;

{短暂整理}
aa1:="EXPLORER.W回档";
a1:=ref(aa1,1)=1;
a2:=(c-ref(c,1))/ref(c,1)<0.03 and (h-l)/ref(c,1)<0.06;
t1:=a1 and a2;
t2:=ref(t1,1)=1 and (c-ref(c,1))/ref(c,1)<0.03 and (h-l)/ref(c,1)<0.06 ;
t3:=SLOPE(ma(c,5),2)*100>3;
短暂整理: (t1 or t2) and t3 and c>ma(c,13);

{天量,N,26,5,300}
a1:=ma(c,250)<=ref(ma(c,250),1);
a2:=cma(c,250)*0.90;
a3:=ma(c,5)ref(ma(c,5),1);
a4:=CAPITAL/v/100>0.03;
xx:= (HIGH+LOW+CLOSE)/3;
a5:=SUM(MAX(0,HIGH-REF(xx,1)),N)/SUM(MAX(0,REF(xx,1)-L),N)*100>175;
tj1:=a1 and a2 and a3 and a4 and a5;
b1:=v>ma(v,5)*3.33 and v>ref(v,1)*2.5;
b2:=v>ma(v,5)*2.5 and ma(v,5)>ma(v,10) and ma(v,10)>ma(v,30);
tj2:=b1 or b2 or v>ref(ma(v,3),1)*4 or 100*v/CAPITAL>10;
tj3:=tj2 and ma(c,5)>ref(ma(c,5),1) and 100*v/CAPITAL>1;
天量:tj1 or tj3;

{横盘30分,N,30,1,240;P,10,1,240}(这个公式分析周期是1分钟)
a1:=(hhv(h,n)-llv(l,n))/ma(c,n)

这个公式也是我在网上找的。但确实是不会用啊,请高手发个用法
发表于 2008-7-1 17:14 | 显示全部楼层
老大,你都不会用。。。
回复 支持 反对

使用道具 举报

发表于 2008-10-4 09:16 | 显示全部楼层
就是有知道的吗,说说
回复 支持 反对

使用道具 举报

发表于 2008-10-4 15:31 | 显示全部楼层
input:T(38,1,100),DDF(18,13,30);
VAR1N:=1980331;
U1:=IF(DATE<=VAR1N,1,0);
N:=13;
【箱顶】:PEAK(CLOSE,N,1)*U1*0.98,LINETHICK2,colorFF99FF;
PEAK(CLOSE,N,1)*U1*0.99,LINETHICK2,colorFF99FF;
【箱顶】B:=PEAK(CLOSE,N,1)*U1*0.95;
【箱底】:TROUGH(CLOSE,N,1)*U1*1.02,LINETHICK2;
TROUGH(CLOSE,N,1)*U1*1,LINETHICK2;
VARA:=IF(CLOSE>150,91.3,0.913);
箱下沿:=INTPART(CLOSE/VARA)*VARA;
箱上沿:=箱下沿+VARA;
箱中线:=(箱下沿+箱上沿)/2;
走势:=SMA(FORCAST(CLOSE,18),6,1);
黄金定位线:HHV(走势,3)*0.96*U1,LINETHICK4,color4080;
EMA(黄金定位线,3)*0.98*U1,LINETHICK2,color4080;
LC:=REF(CLOSE,1);
RSI:=(SMA(MAX(CLOSE-LC,0),6,1))/(SMA(ABS(CLOSE-LC),6,1))*100;
E:=CROSS(83,RSI);
DRAWICON(E,HIGH,2);
DRAWTEXT(E,HIGH,'准备减仓'),colorFF9966;
VAR0:=EMA(EMA(EMA(CLOSE,2),2),2);
钓鱼线:HHV(VAR0,5)*0.98*U1,LINETHICK2,colorFF00;
EMA(钓鱼线,3)*U1,LINETHICK1;
收盘价格:CLOSE,POINTDOT;
B0:=REF(CLOSE-OPEN,2);
B1:=REF(CLOSE,1);
B2:=REF(CLOSE,2);
B3:=REF(CLOSE,3);
B4:=REF(CLOSE,4);
CMAX:=MAX(MAX(MAX(CLOSE,B1),B2),B3);
CMIN:=MIN(MIN(MIN(CLOSE,B1),B2),B3)*U1;
STICKLINE(CLOSE=CMAX AND (B1>=B2 OR B1>=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND CLOSE>=B2 OR B2=CMAX AND B3=CMIN AND CLOSE>=B1 OR B3=CMAX AND CLOSE>=B1 AND CLOSE>=B2,B1,CLOSE,5,1),colorFF;
STICKLINE(CLOSE=CMAX AND B1=CMIN,B2,CLOSE,5,1),colorFF;
STICKLINE(CLOSE=CMIN AND (B1<B2 OR B1<B3) OR B1=CMIN AND (B2=CMAX OR B3=CMAX) AND CLOSE<B2 OR B2=CMIN AND B3=CMAX AND CLOSE<B1 OR B3=CMIN AND CLOSE<B1 AND CLOSE<B2,B1,CLOSE,5,0),colorFF00;
STICKLINE(B1=CMAX AND CLOSE=CMIN,B2,CLOSE,5,0),colorFF00;
STICKLINE(B1=CMIN AND CLOSE>=B2 OR (B2=CMIN AND B1<=B3 OR B3=CMIN AND B1<=B2) AND B2<B4 AND CLOSE>=B1,B1,B2,5,0),colorFF00;
STICKLINE(B1=CMAX AND CLOSE<B2 OR (B2=CMAX AND B1>B3 OR B3=CMAX AND B1>B2) AND B2>=B4 AND CLOSE<B1,B1,B2,5,1),colorFF;
K1:=EMA(CLOSE,3);
K2:=EMA(CLOSE,5);
K3:=EMA(CLOSE,8);
K4:=EMA(CLOSE,13);
K5:=EMA(CLOSE,15);
K:=EMA(CLOSE,21);
QQ:=(MA(K1,1)+MA(K2,3)+MA(K3,5)+MA(K4,7)+MA(K5,9))/5;
K6:=EMA(CLOSE,30);
MA13:=MA(QQ,13);
暗器24:=IF(CROSS(K6,QQ),【箱底】,0);
DRAWTEXT(暗器24>0,LOW,'■神偷关注'),colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,'《股海神偷独门暗器指标》:版块:'+BLKNAME),ALIGN4,colorFFFF;
DRAWTEXT(SYSPARAM(3)=BARPOS,CLOSE,'《联系电话:0539--3226027》证券代码:'+STKLABEL),ALIGN5,PXUP4,colorFF00;
MA6:=MA(CLOSE,5);
MA18:=MA(CLOSE,21);
MA55:=MA(CLOSE,34);
MA125:=MA(CLOSE,125);
MA250:=MA(CLOSE,250);
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
加码价:=((CLOSE-REF(MA18,1))/18+MA18)*1.004;
加码条件:=CROSS(CLOSE,加码价) AND 加码价>REF(加码价,1);
黄K出现股价站上临界点加码:=IF(加码条件,LOW,HIGH)*U1;
STICKLINE(加码条件 AND MACD<0.1,HIGH,LOW,0,1),LINETHICK2,colorFFFF;
STICKLINE(加码条件 AND MACD<0.1,OPEN,CLOSE,4,1),LINETHICK2,colorFFFF;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
HH:=MA(CLOSE,10);
GG:=MA(CLOSE,12);
上:=FFT(MA(HIGH,3)*1.05,30);
下:=FFT(MA(LOW,3)*0.96,30);
DIFF2:=EMA(CLOSE,2)-EMA(OPEN,5);
操盘手:=DIFF2;
短线5%选股2:=IF(CROSS(操盘手,MACD) AND MACD<=-0.12 AND LOW<=下,1,0);
DRAWTEXT(短线5%选股2>0,【箱底】*0.98,'●'),PXUP6,color4600FF;
DRAWTEXT(短线5%选股2>0,【箱底】*0.95,'红球出现等股价靠近钓鱼线qqc
'),colorFFFF;
VAR1:=IF(DATE<=1090531,1,0);
TYP:=(HIGH+LOW+CLOSE)/3;
CCIX:=(TYP-MA(TYP,3))/(0.055*AVEDEV(TYP,3));
超声波:=EMA(CCIX,2)*VAR1;
短线进出:=3*SMA((CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100,5,1),3,1);
低吸区:=(IF(短线进出<=10 AND 超声波<-20,-20,0))*(U1);
DRAWTEXT(低吸区<0,【箱底】*1.12,'◎\n==\n出\n手\n赢\n赢\n**\n'),PXUP6,color4600FF;
VAR1R:=LLV(LOW,2)=LLV(LOW,16) AND CLOSE>=OPEN*1.04;
VAR2R:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
VAR3R:=VAR1R AND VAR2R;
BY20:=MA(CLOSE,5);
招财猫:=MA(CLOSE,20)*U1;
助涨线:=(IF(BY20>招财猫,招财猫,BY20))*U1;
回复 支持 反对

使用道具 举报

发表于 2008-10-4 23:38 | 显示全部楼层
错误百出的指标
回复 支持 反对

使用道具 举报

发表于 2009-1-30 11:57 | 显示全部楼层
4楼的公式无法通过
回复 支持 反对

使用道具 举报

发表于 2009-1-30 12:12 | 显示全部楼层
看不懂.
回复 支持 反对

使用道具 举报

发表于 2009-2-1 09:34 | 显示全部楼层
精品公式 多谢楼主!
回复 支持 反对

使用道具 举报

发表于 2009-4-23 18:45 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2010-4-5 22:14 | 显示全部楼层
公式无法通过
回复 支持 反对

使用道具 举报

关闭

老钱庄消息上一条 /1 下一条

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-10-23 12:20 , Processed in 0.088653 second(s), 16 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表