老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 16833|回复: 83

[通达信] 【通达信】极品收费公式

  [复制链接]
发表于 2013-3-31 12:21 | 显示全部楼层 |阅读模式
Var1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
Var2:=2*ABS(Var1);
Var3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var4:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
Var5:=(HIGH+LOW+CLOSE)/3;
Var6:=(Var5-MA(Var5,14))/(0.015*AVEDEV(Var5,14));
Var7:=(Var5-MA(Var5,70))/(0.015*AVEDEV(Var5,70));
Var8:=IF(Var6>=150 AND Var6<200 AND Var7>=150 AND Var7<200,10,0);
Var9:=IF(Var6<=-150 AND Var6>-200 AND Var7<=-150 AND Var7>-200,-10,Var8);
VarA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VarB:=100-ABS(VarA);
VarC:=3*SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VarD:=3*SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VarE:=REF(LOW,1)*0.9;
VarF:=LOW*0.9;
Var10:=(VarF*VOL+VarE*(CAPITAL-VOL))/CAPITAL;
Var11:=EMA(Var10,30);
Var12:=Var11-CLOSE;
Var13:=REF(CLOSE,1);
Var14:=SMA(MAX(CLOSE-Var13,0),7,1)/SMA(ABS(CLOSE-Var13),7,1)*100;
Var15:=SMA(MAX(CLOSE-Var13,0),13,1)/SMA(ABS(CLOSE-Var13),13,1)*100;
Var16:=BARSCOUNT(CLOSE);
Var17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
Var18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
Var19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var1A:=(SMA(Var19,4,1)-50)*2;
Var1B:=SMA(Var1A,3,1);
Var1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var1D:=SMA(Var1C,4,1);
Var1E:=SMA(Var1D,3,1);
Var1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
Var20:=IF(Var17<=25 AND Var18<-95 AND Var1F>20 AND Var1B<-30 AND Var1E<30 AND Var12>=-0.25 AND Var14<22 AND Var15<28 AND Var16>50,80,0);
情报: Var3;
天线: IF(VarB<90,VarB,100);
红军: IF(Var1>0,Var1,0),colorred, LINESTICK;
绿军: IF(Var1<0,Var2,0),colorgreen,LINESTICK;
导弹: Var20;
预警系统: IF(Var7>=200 AND Var6>=150,15,IF(Var7<=-200 AND Var6<=-150,-15,Var9))+60;
STICKLINE(Var3>=REF(Var4,1),Var3,Var4,8,0);
STICKLINE(Var3<REF(Var4,1),Var3,Var4,8,0);
Var21:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);
Var22:=CLOSE<MA(CLOSE,20) AND MA(CLOSE,20)<REF(MA(CLOSE,20),1);
Var23:=红军>50 AND 预警系统>60 AND 天线=100;
Var24:=红军>48 AND 预警系统>60 AND 天线<100;
Var25:=绿军>38 AND 预警系统<55;
Var26:=导弹>50 AND 天线<90;
Var27:=Var3<REF(Var4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
Var28:=Var3>=REF(Var4,1) AND CLOSE<REF(CLOSE,1) AND 预警系统=60 AND 导弹=0 AND 绿军>=REF(绿军,1) AND VarC<REF(VarD,1);
DRAWTEXT(Var21 AND COUNT(Var21,30)=1,100,'上升通道,持股待长或高抛低吸!');
DRAWTEXT(Var22 AND COUNT(Var22,30)=1,90,'下降通道,小心无量阴跌! ');
DRAWTEXT(Var23 AND COUNT(Var23,30)=1,70,'上涨过急,需要调整,短线先抛出! ');
DRAWTEXT(Var24 AND COUNT(Var24,30)=1,80,'庄家出货,大跌在即,中线抛出! ');
DRAWTEXT(Var25 AND COUNT(Var25,30)=1,50,'不必杀跌,应有小反弹 ,跌停除外!');

DRAWTEXT(Var26 AND COUNT(Var26,30)=1,30,'坚决抢反弹,但巨量封跌停除外 ');
DRAWTEXT(Var27 AND COUNT(Var27,30)=1,40,'有大资金进场迹象,关注!');
DRAWTEXT(Var28 AND COUNT(Var28,30)=1,20,'见顶回落');
买入:IF(VAR27 AND COUNT(VAR27,30)=1,100,0),LINETHICK3,COLORBLUE;

评分

参与人数 1庄币 +2 收起 理由
红心K + 2 赞一个!

查看全部评分

发表于 2013-3-31 14:04 | 显示全部楼层
谢谢分享周末快乐
回复 支持 反对

使用道具 举报

发表于 2013-3-31 14:49 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2013-3-31 14:56 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2013-3-31 15:15 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2013-3-31 15:16 | 显示全部楼层
谢谢分享
回复 支持 反对

使用道具 举报

发表于 2013-3-31 17:28 | 显示全部楼层
谢谢分享
回复 支持 反对

使用道具 举报

发表于 2013-3-31 18:04 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2013-3-31 20:02 | 显示全部楼层
谢谢分享 周末愉快!!!
回复 支持 反对

使用道具 举报

发表于 2013-3-31 20:48 | 显示全部楼层

评分

参与人数 1威望 +1 庄币 +1 收起 理由
张海苍天 + 1 + 1 神马都是浮云

查看全部评分

回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2018-1-16 17:32 , Processed in 0.138406 second(s), 22 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表