老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 7633|回复: 21

[通达信] 组合了一下机构K线(源码 贴图 副图 )

[复制链接]
发表于 2013-1-11 09:11 | 显示全部楼层 |阅读模式
1:
N:=7; N2:=8; N3:=9;
VAR1:=REF(MA(C,20),10);开:=O-VAR1;高:=H-VAR1;低:=L-VAR1;收:=C-VAR1;MID:=MA(C,20);
UPPER:=MID+2*STD(C,20);LOWER:=MID-2*STD(C,20);V1:=(C-LOWER)/(UPPER-LOWER)*100;
V2:=V1-EMA(V1,5);K1:=SUM(LLV(V2,4),4)/4;V3:=EMA(V2,64)*10;V4:=EMA(0.4*V2*(-1),3);
V5:=-1*EMA(V2,39)*10;A:=V3>10;B:=V2>V4;D:=V5>10;E:=V3<=10 OR V2<=V4 OR V5<=10;
均线1:MA(收, N);
均线2:MA(收, N2);
均线3:MA(收, N3);
STICKLINE(C,0,0,6,0),COLORD9D919;
STICKLINE(收>=开 AND E,高,低,0,0), COLORYELLOW;
STICKLINE(收>=开 AND E,收,开,2,0) ,COLORYELLOW;
STICKLINE(收< 开 AND E,高,低,0,0) ,COLORYELLOW;
STICKLINE(收< 开 AND E,收,开,2,0) ,COLORYELLOW;
STICKLINE(开> 收 AND A ,低,高,0,0),COLORFF0000;
STICKLINE(开> 收 AND A ,收,开,2,0),COLORFF0000;
STICKLINE(开<=收 AND A,低,高,0,0),COLORYELLOW;
STICKLINE(开<=收 AND A,收,开,2,1),COLORYELLOW;
STICKLINE(开> 收 AND B,低,高,0,0),COLORRED;
STICKLINE(开> 收 AND B,收,开,2,0),COLORRED;
STICKLINE(开<=收 AND B,低,高,0,0),COLORRED;
STICKLINE(开<=收 AND B,收,开,2,1),COLORRED;
STICKLINE(开> 收 AND D,低,高,0,0),COLORGREEN;
STICKLINE(开> 收 AND D,收,开,2,0),COLORGREEN;
{STICKLINE(开<=收 AND D,收,开,2,1),COLORGREEN;}
HIGHN:=8;LOWN:=8;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(高,HIGHN)=HHV(高,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND 高=HHV(高,HIGHN+1);
DRAWICON(CC,高*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(高,DDD),高);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力1:DRAWLINE(CURRBARSCOUNT=GDCS2,高,CURRBARSCOUNT=GDCS1,高,1) ;
高点压力2:DRAWLINE(CURRBARSCOUNT=GDCS2,高,ISLASTBAR,REF(高,GDCS2-1),1);
高点压力3:DRAWLINE(CURRBARSCOUNT=GDCS1,高,ISLASTBAR,REF(高,GDCS1-1),1);
AA1:=REF(低,LOWN)=LLV(低,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND 低=LLV(低,LOWN+1);
DRAWICON(CC1,低*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(低,DD1),低);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,低,1) ;
ZGSTAR:=(高点压力1+低点支撑)/2;
ZGEND:=CONST((高点压力1+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
低点支撑1:DRAWLINE(CURRBARSCOUNT=DDCS1,低,ISLASTBAR,REF(低,DDCS1-1),1);
低点支撑2:DRAWLINE(CURRBARSCOUNT=DDCS2,低,ISLASTBAR,REF(低,DDCS2-1),1);
DRAWTEXT(CROSS(高,高点压力1),低*0.99,'↖卖房了'),COLORRED;
DRAWTEXT(CROSS(高,高点压力2),低*0.99,'↖全压了'),COLORMAGENTA;
DRAWTEXT(CROSS(高,高点压力3),低*0.99,'↖全压了'),COLORLIRED;

2:
N:=7; N2:=8; N3:=9;
C1:=10000*CLOSE/INDEXC;
O1:=10000*OPEN/INDEXO;
H1:=10000*HIGH/INDEXH;
L1:=10000*LOW/INDEXL;
LL:=IF(L1<C1 AND L1<O1,L1,MIN(C1,O1));
HH:=IF(H1>C1 AND H1>O1,H1,MAX(C1,O1));
均线1:MA(C1, N);
均线2:MA(C1, N2);
均线3:MA(C1, N3);
MID:=MA(C,20);
UPPER:=MID+2*STD(C,20);
LOWER:=MID-2*STD(C,20);
V1:=(C-LOWER)/(UPPER-LOWER)*100;
V2:=V1-EMA(V1,5);
V3:=EMA(V2,64)*10;V4:=EMA(0.4*V2*(-1),3);
V5:=-1*EMA(V2,39)*10;
A:=V3>10;B:=V2>V4;D:=V5>10;E:=V3<=10;
{STICKLINE(C,0,0,6,0),COLORD9D919;}
STICKLINE(C1>=O1 AND E,HH,LL,0,0), COLORYELLOW;
STICKLINE(C1>=O1 AND E,C1,O1,2,0) ,COLORYELLOW;
STICKLINE(C1< O1 AND E,HH,LL,0,0) ,COLORYELLOW;
STICKLINE(C1< O1 AND E,C1,O1,2,0) ,COLORYELLOW;
STICKLINE(O1> C1 AND A ,LL,HH,0,0),COLORFF0000;
STICKLINE(O1> C1 AND A ,C1,O1,2,0),COLORFF0000;
STICKLINE(O1<=C1 AND A,LL,HH,0,0),COLORYELLOW;
STICKLINE(O1<=C1 AND A,C1,O1,2,1),COLORYELLOW;
STICKLINE(O1> C1 AND B,LL,HH,0,0),COLORRED;
STICKLINE(O1> C1 AND B,C1,O1,2,0),COLORRED;
STICKLINE(O1<=C1 AND B,LL,HH,0,0),COLORRED;
STICKLINE(O1<=C1 AND B,C1,O1,2,1),COLORRED;
STICKLINE(O1> C1 AND D,LL,HH,0,0),COLORGREEN;
STICKLINE(O1> C1 AND D,C1,O1,2,0),COLORGREEN;
{STICKLINE(O1<=C1 AND D,C1,O1,2,1),COLORGREEN;};
HIGHN:=8;LOWN:=8;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(HH,HIGHN)=HHV(HH,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND HH=HHV(HH,HIGHN+1);
DRAWICON(CC,HH*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(HH,DDD),HH);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力1:DRAWLINE(CURRBARSCOUNT=GDCS2,HH,CURRBARSCOUNT=GDCS1,HH,1) ;
高点压力2:DRAWLINE(CURRBARSCOUNT=GDCS2,HH,ISLASTBAR,REF(HH,GDCS2-1),1);
高点压力3:DRAWLINE(CURRBARSCOUNT=GDCS1,HH,ISLASTBAR,REF(HH,GDCS1-1),1);
AA1:=REF(LL,LOWN)=LLV(LL,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND LL=LLV(LL,LOWN+1);
DRAWICON(CC1,LL*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(LL,DD1),LL);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,LL,1) ;
ZGSTAR:=(高点压力1+低点支撑)/2;
ZGEND:=CONST((高点压力1+低点支撑)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
低点支撑1:DRAWLINE(CURRBARSCOUNT=DDCS1,LL,ISLASTBAR,REF(LL,DDCS1-1),1);
低点支撑2:DRAWLINE(CURRBARSCOUNT=DDCS2,LL,ISLASTBAR,REF(LL,DDCS2-1),1);
DRAWTEXT(CROSS(HH,高点压力2),LL*0.99,'↖全压了'),COLORMAGENTA;
DRAWTEXT(CROSS(HH,高点压力3),LL*0.99,'↖全压了'),COLORLIRED;
DRAWTEXT(CROSS(HH,高点压力1),LL*0.99,'↖卖房了'),COLORRED;




位庄友2013年已经到来,感谢庄友们在过去一年的大力支持!有了你们论坛才会更精彩。在2013年利用工作之余,我会尽力为大家提供更多更好的股软,但愿在股市中助庄友们一臂之力!
希望庄友们积极参加“2012年优秀版主评选活动http://bbs.laoqianzhuang.com/thread-1995954-1-1.html欢迎各位庄友踊跃参与投票,投票回复奖励10庄币哦!你们的投票将会让我们版主们更有热情服务庄友们!




本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x

评分

参与人数 1威望 +2 庄币 +5 收起 理由
红心K + 2 + 5 赞一个!

查看全部评分

发表于 2013-1-11 14:17 | 显示全部楼层
打都顶顶顶顶顶顶顶顶顶顶
回复 支持 反对

使用道具 举报

发表于 2013-1-11 14:38 | 显示全部楼层
谢谢分享
回复 支持 反对

使用道具 举报

发表于 2013-1-11 19:06 | 显示全部楼层
谢谢分享

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x
回复 支持 反对

使用道具 举报

发表于 2013-1-11 19:42 | 显示全部楼层

谢谢版主提供分享!能否提供您的主图源码?谢谢了!

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x
回复 支持 反对

使用道具 举报

发表于 2013-1-11 20:06 | 显示全部楼层
未来函数大大底
回复 支持 反对

使用道具 举报

发表于 2013-1-13 12:07 | 显示全部楼层
谢谢楼主
回复 支持 反对

使用道具 举报

发表于 2013-1-13 12:35 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2013-2-12 16:24 | 显示全部楼层
谢谢楼主
回复 支持 反对

使用道具 举报

发表于 2013-4-14 02:51 | 显示全部楼层
一定要支持,版主的信心!!!!!!
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-12-13 00:05 , Processed in 0.105732 second(s), 23 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表