老钱庄股票论坛

 找回密码
 5秒快速注册
查看: 117042|回复: 701

[通达信] 免费帮助大家编辑、修改通达信各种指标!(请大家回帖前详细查看一下1楼信息)

  [复制链接]
发表于 2012-9-12 19:01 | 显示全部楼层 |阅读模式
本帖最后由 linju9 于 2012-10-9 21:41 编辑

本人新任实习版主,愿为大家多多服务!
现免费为大家编辑和修改各种通达信内核的技术指标,大家可以把自己需要的条件(条件请尽量详细)和已有的源码需要修改的部分和需求以跟帖的形式发出,必回!
谢谢大家支持,愿与大家一起分享股市盛宴!

--------------------------------------------我是分割线--------------------------------------------------------------------------------------
因为审核的原因,有部分股民朋友的帖子不能及时的发布。请大家不要着急,谢谢大家耐心等待一下,不要重复发帖。如果我长时间没有回复,请留言,必回!谢谢大家的配合。


--------------------------------------------我是分割线--------------------------------------------------------------------------------------

和一个想进股市的朋友聊完,写点随感,欢迎大家讨论!

所谓技术指标,基本元素就是oclh和成交量。通达信软件自带的指标,已经可以很好的判断和预测走势。
不过作为一个纯技术流,我曾今也很迷信指标选股,也很理解广大会员希望能找到一个竟可能准确指标的想法。
在这里,也说一下自己对技术流的看法。
技术分析的基本原理之一,历史总会重演。所谓技术分析的基本都是过去式,就如同我刚才说的ochl和v一样,都是已经产生的数值。我们只能通过对过去数值的分析以及曾经出现过的模型来判断和预测未来数值的走向和走势。技术分析中金叉之后有可能马上出现死叉,死叉过后可能马上又是金叉,其原因,主要是主力机构的洗盘、挖坑、拉高或者出货的需要;另一方面,也是技术分析存在死角,过去式的分析方式。
综上,技术分析就是预测。那么如何来提高我们预测的成功率呢?我在来谈谈我的作法:
第一,止损。其实这个我就不多说了,一般准备进场的朋友,都会有学习。如果大家想详细了解我的作法,可以单独留言。
第二,仓位控制。这点我的作法和很多朋友不同。我的建议是仓位要做到“分而不散”。所谓“分”,不要满仓一只股票。当然有内幕的我就不多说了。通过上面的分析,我们知道技术指标其实就是预测。通过预测结果,将所有的鸡蛋放进一个篮子,是非常不明智的。“不散”,不要看这个金叉,那个上穿,忍不住这边买一点,那边买一点。。。结果打开持仓一看,满满的一版全是。我总资金10万,最多买入4只票,每票大约就是2万5。出现机会买入,能持仓就持仓,不行就止损。止损出来的资金不动,继续跟踪这只票,下次再亏,继续止损,按50%的成功概率来算,只要一波行情出现就能回本赚钱。
先写到这里吧,如果大家感兴趣,欢迎跟帖讨论!!!

--------------------------------------------我是分割线--------------------------------------------------------------------------------------
其实技术流最好的操作方法就是找一条基准线,按照上穿或者下破买入或者卖出,推荐个文章大家看下:《海龟交易法》!


--------------------------------------------我是分割线--------------------------------------------------------------------------------------
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),30);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),30);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),30);
PDI: DMP*100/MTR;
MDI: DMM*100/MTR;
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,3);
MADX:MA(ADX,3),DOTLINE;

以上是dmi趋向指标,使用的是通达信自带源码。我做了2个地方的修改,一个是将pdi和mdi(也就是多空动能)由默认的周期14日,改为30日。一个是将adx(多空动能差值)的周期由默认周期6日,改为3日。具体的方法呢,我先卖个关子,稍后在来讲解。另外,关于dmi的原理这里就不多解释了,大家可以自己搜一下。可以这样说dmi是一个非常优秀的指标,首先,它不会出现类似kdj的钝化。其次,dmi展示的是多空力量的对比,较macd而言dmi的信号更灵敏。最后,dmi是经过历时考验的实战指标,较自编指标或者大家收集的指标来说,dmi更具备实战性,适合对于各种行情的判断。

下面,以dmi指标为列,我来向大家展示一下我的选股流程:
第一步,初筛。我虽然从事证券工作很久了,其实也和大家一样对于内幕、消息什么的都是一样的茫然。所以我能做的也只是通过自己对市场的理解和国家大的政策方向来创建自己的股票池。我的初选条件如下:

去除ST股:=IF(NAMELIKE('S'),0,1);
去除星股:=IF(NAMELIKE('*'),0,1);
去除停牌:=VOL>0;
去创业板:=IF(CODELIKE('300'),0,1);
流通股:=FINANCE(1)<=1000000000;
上市日期:=FINANCE(42)>300;
XH:C<=15 AND 流通股 AND 上市日期 AND 去除ST股 AND 去除星股 AND 去除停牌 AND 去创业板;

简单说一下初选的条件,收盘价小于等于15元,流通盘小于10亿股,上市日期大于300天,去除st,*st和创业板。(因为本人十分厌恶这3类,所以剔除,大家可以根据自己喜好自行调整。)

评分

参与人数 8威望 +27 庄币 +27 收起 理由
zgs405 + 1 + 1 很给力!
zj8850 + 2 + 2 赞一个!
mlc666 + 15 + 15 很给力!
lgt236 + 2 + 2 很给力!
wp0922 + 1 谢谢老师!

查看全部评分

发表于 2012-9-12 19:29 | 显示全部楼层
你好,请你把量价突破,修改成选股公式:多头:STICKLINE((CLOSE > MA(CLOSE,60)),0,VOL,10,1),colorred;  
空头:STICKLINE((CLOSE < MA(CLOSE,60)),0,VOL,10,1),colorred;  
量能突变:=V+REF(V,1)>=(REF(V,2)+REF(V,3)+REF(V,4)+REF(V,5)+REF(V,6))/5*3 AND V<2*REF(V,1) AND C>O AND C>MA(C,21);
STICKLINE(量能突变,2*V/10,V,10,0),colorred;
量价配合:=REF(V,1)<MAX(MA(V,5),MAX(MA(V,10),MA(V,20))) AND
V>MAX(MA(V,5),MAX(MA(V,10),MA(V,20))) AND V<2*REF(V,1) AND CROSS(C,MA(C,21));
STICKLINE(量价配合,V/10,2*V/10,10,0),coloryellow;
STICKLINE(V=LLV(V,15),0,V,10,0),colorred;
量价突破:=C>=HHV(C,6) AND V>=HHV(V,6);
STICKLINE(量价突破,0,V/10,10,0),COLORFF00FF;
价量突破15:0,COLORFF00FF;
量能堆积:0,colorred;
量3价21:0,colorwhite;
回复 支持 反对

使用道具 举报

 楼主| 发表于 2012-9-12 19:40 | 显示全部楼层
本帖最后由 linju9 于 2012-9-12 19:53 编辑
猎豹Topview 发表于 2012-9-12 19:29
你好,请你把量价突破,修改成选股公式:多头:STICKLINE((CLOSE > MA(CLOSE,60)),0,VOL,10,1),colorred;  
...

量价突破:=C>=HHV(C,6) AND V>=HHV(V,6);
粉柱信号:量价突破;

该源码可以直接在通达信里编辑成选股指标。

说下你要的这段的原理吧,其实很简单:收盘价大于或者等于6天内收盘价的最高值,并且成交量也大于等于6天内成交量的最高值,即出现信号。
使用这个条件选股,最好在强势市场中选择,而且最好当日收盘价能大于60日均线,最好!
回复 支持 反对

使用道具 举报

发表于 2012-9-12 22:29 | 显示全部楼层
先谢谢你.rong9889 老师.把BIAS36改预警功式。M;2    60     6            

BIAS36:MA(CLOSE,3)-MA(CLOSE,6);
BIAS612:MA(CLOSE,6)-MA(CLOSE,12);
MABIAS:MA(BIAS36,M);  金叉买:IF(CROSS(BIAS36,BIAS612) AND (BIAS36<01),0.5,0),COLOR0099FF,LINETHICK2;
回复 支持 反对

使用道具 举报

发表于 2012-9-12 22:29 | 显示全部楼层
先谢谢你.老师.把BIAS36改预警功式。M;2    60     6            

BIAS36:MA(CLOSE,3)-MA(CLOSE,6);
BIAS612:MA(CLOSE,6)-MA(CLOSE,12);
MABIAS:MA(BIAS36,M);  金叉买:IF(CROSS(BIAS36,BIAS612) AND (BIAS36<01),0.5,0),COLOR0099FF,LINETHICK2;
回复 支持 反对

使用道具 举报

 楼主| 发表于 2012-9-12 22:38 | 显示全部楼层
本帖最后由 linju9 于 2012-9-12 22:49 编辑
wx4304 发表于 2012-9-12 22:29
先谢谢你.老师.把BIAS36改预警功式。M;2    60     6            

BIAS36:MA(CLOSE,3)-MA(CLOSE,6);


是金叉的预警吗?
BIAS36:=MA(CLOSE,3)-MA(CLOSE,6);
BIAS612:=MA(CLOSE,6)-MA(CLOSE,12);
MABIAS:=MA(BIAS36,M);  
金叉买:CROSS(BIAS36,BIAS612) AND (BIAS36<01);
然后把代码添加到条件选股公式中即可!另外你这个和传统的bias不同,传统的bias是2条基准线之间的比值,你现在使用的是2天基准线的差。相对而言,传统的bias会更好用一点。
回复 支持 反对

使用道具 举报

发表于 2012-9-12 23:31 | 显示全部楼层
请版主帮助将此暴涨主图源码编写一个选股公式,非常感谢!
MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
起爆:=CROSS(AAA-REF(AAA,1),15),COLORRED,LINETHICK2;
DRAWTEXT(起爆,L*0.99,'↖暴涨'),COLORYELLOW,LINETHICK2;

点评

删除前面4行,后面改为: DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26); DEA:=EMA(DIF,9); AAA:=(DIF-DEA)*2*60; 起爆:=CROSS(AAA-REF(AAA,1),15),COLORRED,LINETHICK2; 选股:cross(aaa-ref(aaa,1),15); 有类zig未来,   发表于 2012-9-13 09:31
回复 支持 反对

使用道具 举报

发表于 2012-9-12 23:37 | 显示全部楼层
本帖最后由 阿狼8341 于 2012-9-13 09:46 编辑

请版主帮助,把此暴涨主图源码编写一个选股公式,谢谢您!

点评

楼上已经改了,该源码有类zig未来,要慎用!dclose会导致信号漂移!  发表于 2012-9-13 09:33
回复 支持 反对

使用道具 举报

发表于 2012-9-12 23:46 | 显示全部楼层
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00DD00;
支撑:L1+P1*0.5/8,COLOR00DD00;
现价:CLOSE,COLORWHITE,LINETHICK1;
STICKLINE(CROSS(支撑,现价),支撑,阻力,1,0),COLORYELLOW;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'买'),COLORRED;{吸}
DRAWTEXT(LONGCROSS(现价,阻力,2),现价,'★卖'),COLOR00DD00;{抛};

日时转换:=IF(PERIOD=5,120,240);
QZS:=(EMA(CLOSE,10)+EMA(CLOSE,32))/2;
VAR1:=(EMA(CLOSE,30)+EMA(CLOSE,72))/2;
VAR2:=(EMA(VOL,10)+EMA(VOL,32))/2;
VAR3:=(VAR1+VAR2)/2;
VAR4:=EMA(VAR3,30);
VAR5:=EMA(VAR3,60);
VAR6:=EVERY(VAR1>REF(VAR1,1),5) AND EVERY(VAR4>REF(VAR4,1),5);
DRAWBAND(VAR1,RGB(150,30,30),EMA(VAR1,60),RGB(0,110,30));
牵引线:VAR1,COLORYELLOW,LINETHICK3;
强弱线:EMA(VAR1,日时转换),COLORWHITE;
趋势关注:IF(CROSS(VAR1,EMA(VAR1,60)) AND VAR6,1,0),NODRAW,COLORRED;
量价关注:IF(CROSS(VAR3,VAR5) AND VAR6,1,0),NODRAW,COLORWHITE;
冲击量:IF(VAR3>VAR5 AND VAR6,1,0),NODRAW,COLORYELLOW;
强势区:IF(VAR1>强弱线,1,DRAWNULL),NODRAW,COLORRED;
止损区:IF(VAR1<强弱线,1,DRAWNULL),NODRAW,COLORGREEN;
STICKLINE(QZS>VAR1,QZS,VAR1,1,0),COLORFF00FF;
STICKLINE(冲击量=1,QZS,VAR1,1,0),COLORYELLOW;
DRAWICON(趋势关注=1,EMA(VAR1,60),13);
DRAWTEXT(趋势关注=1,EMA(VAR1,60),'转折'),COLORWHITE;
DRAWTEXT(量价关注=1,EMA(VAR1,60),'L0V'),COLORWHITE;

MA30:=EMA(CLOSE,30);
强弱:=EMA(CLOSE,900);
DRAWICON(CROSS(MA30,强弱),H,9);

请改选股公式出现钱袋选股谢谢
回复 支持 反对

使用道具 举报

发表于 2012-9-12 23:47 | 显示全部楼层
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00DD00;
支撑:L1+P1*0.5/8,COLOR00DD00;
现价:CLOSE,COLORWHITE,LINETHICK1;
STICKLINE(CROSS(支撑,现价),支撑,阻力,1,0),COLORYELLOW;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'买'),COLORRED;{吸}
DRAWTEXT(LONGCROSS(现价,阻力,2),现价,'★卖'),COLOR00DD00;{抛};

日时转换:=IF(PERIOD=5,120,240);
QZS:=(EMA(CLOSE,10)+EMA(CLOSE,32))/2;
VAR1:=(EMA(CLOSE,30)+EMA(CLOSE,72))/2;
VAR2:=(EMA(VOL,10)+EMA(VOL,32))/2;
VAR3:=(VAR1+VAR2)/2;
VAR4:=EMA(VAR3,30);
VAR5:=EMA(VAR3,60);
VAR6:=EVERY(VAR1>REF(VAR1,1),5) AND EVERY(VAR4>REF(VAR4,1),5);
DRAWBAND(VAR1,RGB(150,30,30),EMA(VAR1,60),RGB(0,110,30));
牵引线:VAR1,COLORYELLOW,LINETHICK3;
强弱线:EMA(VAR1,日时转换),COLORWHITE;
趋势关注:IF(CROSS(VAR1,EMA(VAR1,60)) AND VAR6,1,0),NODRAW,COLORRED;
量价关注:IF(CROSS(VAR3,VAR5) AND VAR6,1,0),NODRAW,COLORWHITE;
冲击量:IF(VAR3>VAR5 AND VAR6,1,0),NODRAW,COLORYELLOW;
强势区:IF(VAR1>强弱线,1,DRAWNULL),NODRAW,COLORRED;
止损区:IF(VAR1<强弱线,1,DRAWNULL),NODRAW,COLORGREEN;
STICKLINE(QZS>VAR1,QZS,VAR1,1,0),COLORFF00FF;
STICKLINE(冲击量=1,QZS,VAR1,1,0),COLORYELLOW;
DRAWICON(趋势关注=1,EMA(VAR1,60),13);
DRAWTEXT(趋势关注=1,EMA(VAR1,60),'转折'),COLORWHITE;
DRAWTEXT(量价关注=1,EMA(VAR1,60),'L0V'),COLORWHITE;

MA30:=EMA(CLOSE,30);
强弱:=EMA(CLOSE,900);
DRAWICON(CROSS(MA30,强弱),H,9);

请改选股公式,出现钱袋选股谢谢

点评

MA30:=EMA(CLOSE,30); 强弱:=EMA(CLOSE,900); 选股:CROSS(MA30,强弱); 说明:30日移动平均线上穿900日移动平均线,虽然简单,关键适用就行!  发表于 2012-9-13 09:35
回复 支持 反对

使用道具 举报

关闭

老钱庄消息上一条 /1 下一条

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-10-23 14:21 , Processed in 0.097179 second(s), 24 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表