老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

关闭
关闭
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 11640|回复: 9

[同花顺] 同花顺MACD+KDJ+RSI+DMI顶底背离指标公式

[复制链接]
发表于 2012-5-4 18:39 | 显示全部楼层 |阅读模式
同花顺MACD+KDJ+RSI+DMI顶底背离指标公式股票软件源码如下:



底:-50;
顶:50;
TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= PDM*100/TR;
MDI:= MDM*100/TR;
A1:=BARSLAST(ref(cross("macd.diff"(12,26,9),"macd.dea"(12,26,9)),1));
B1:=ref(c,A1+1)>c and ref("macd.diff"(12,26,9),A1+1)<"macd.diff"(12,26,9) and cross("macd.diff"(12,26,9),"macd.dea"(12,26,9));
A2:=BARSLAST(ref(cross("kdj.k"(9,3,3),"kdj.d"(9,3,3)),1));
B2:=ref(c,A2+1)>c and ref("kdj.k"(9,3,3),A2+1)<"kdj.k"(9,3,3) and cross("kdj.k"(9,3,3),"kdj.d"(9,3,3));
A3:=BARSLAST(ref(cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
//{老钱庄_同花顺股票指标公式}
B3:=ref(c,A3+1)>c and ref("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) and cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(ref(cross("macd.dea"(12,26,9),"macd.diff"(12,26,9)),1));
D1:=ref(c,C1+1)<c and ref("macd.diff"(12,26,9),C1+1)>"macd.diff"(12,26,9) and cross("macd.dea"(12,26,9),"macd.diff"(12,26,9));
C2:=BARSLAST(ref(cross("kdj.d"(9,3,3),"kdj.k"(9,3,3)),1));
D2:=ref(c,C2+1)<c and ref("kdj.k"(9,3,3),C2+1)>"kdj.k"(9,3,3) and cross("kdj.d"(9,3,3),"kdj.k"(9,3,3));
C3:=BARSLAST(ref(cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=ref(c,C3+1)<c and ref("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) and cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
C4:=BARSLAST(ref(cross(mdi,pdi),1));
D4:=ref(c,C+1)<c and ref(mdi,C4+1)>mdi and cross(mdi,pdi);
A4:=BARSLAST(ref(cross(PDI,MDI),1));
B4:=ref(c,A4+1)>c and ref(pdi,A4+1)<pdi and cross(pdi,mdi);
DMI底背:IF(B4>0,-50,0),COLOR0099FF,POINTDOT;
DRAWTEXT(DMI底背,-5,'DMI底背'),color0099FF;
DMI顶背:IF(D4>0,50,0),COLORBLUE,POINTDOT;
DRAWTEXT(DMI顶背,15,'DMI顶背'),COLORBLUE;
MACD底背:if(B1>0,-50,0),colorred,pointdot;
DRAWTEXT(MACD底背,-15,'MACD底背'),COLORred;
KDJ底背:if(B2>0,-50,0),colorff00ff,pointdot;
DRAWTEXT(KDJ底背,-25,'KDJ底背'),COLORff00ff;
RSI底背:if(B3>0,-50,0),coloryellow,pointdot;
DRAWTEXT(RSI底背,-35,'RSI底背'),COLORyellow;
MACD顶背:if(D1>0,50,0),color00ff00,pointdot;
DRAWTEXT(MACD顶背,25,'MACD顶背'),COLOR00ff00;
KDJ顶背:if(D2>0,50,0),colorffcc66,pointdot;
DRAWTEXT(KDJ顶背,35,'KDJ顶背'),COLORffcc66;
RSI顶背:if(D3>0,50,0),colorffffff,pointdot;
DRAWTEXT(RSI顶背,45,'RSI顶背'),COLORffffff;
STICKLINE(B1>0,-50,0,2,0),colorred;
STICKLINE(B2>0,-50,0,2,0),colorff00ff;
STICKLINE(B3>0,-50,0,2,0),coloryellow;
STICKLINE(d1>0,50,0,2,0),color00ff00;
STICKLINE(d2>0,50,0,2,0),colorffcc66;
STICKLINE(d3>0,50,0,2,0),colorwhite;
STICKLINE(B4>0,-50,0,2,0),color0099ff;
STICKLINE(D4>0,50,0,2,0),colorblue;



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x

评分

参与人数 1威望 +15 庄币 +15 收起 理由
mlc666 + 15 + 15 很给力!

查看全部评分

发表于 2012-5-5 21:11 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2012-5-7 09:24 | 显示全部楼层
钱庄有你而精彩
回复 支持 反对

使用道具 举报

发表于 2012-6-12 21:35 | 显示全部楼层
先回复最好!
回复 支持 反对

使用道具 举报

发表于 2012-8-18 16:55 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2015-8-31 15:07 | 显示全部楼层
非常感谢。不过,能给一下公式的使用说明吗?谢谢
回复 支持 反对

使用道具 举报

发表于 2015-8-31 17:09 | 显示全部楼层
可以有图看就最好了 可惜没有图
回复 支持 反对

使用道具 举报

发表于 2015-8-31 20:11 | 显示全部楼层
股票行情指标可惜没有图
回复 支持 反对

使用道具 举报

发表于 2018-6-12 21:52 | 显示全部楼层
学习中  
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 1239457655 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2018-8-15 07:04 , Processed in 0.119413 second(s), 27 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表