老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

关闭
关闭
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 9884|回复: 19

[同花顺] 宁俊明135战法之配合(同花顺,通达信源码)

[复制链接]
发表于 2012-3-11 23:20 | 显示全部楼层 |阅读模式
同花顺源码:
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,13);
MA3:=MA(CLOSE,21);
MA4:=MA(CLOSE,34);
MA5:=MA(CLOSE,55);
大盘6日:=(INDEXC-MA(INDEXC,6))/MA(INDEXC,6)*100;
大盘12日:=(INDEXC-MA(INDEXC,12))/MA(INDEXC,12)*100;
大盘24日:=(INDEXC-MA(INDEXC,24))/MA(INDEXC,24)*100;
大盘:(大盘6日 + 大盘12日 + 大盘24日)/3,colorwhite;
个股6日:=(C-MA(C,6))/MA(C,6)*100;
个股12日:=(C-MA(C,12))/MA(C,12)*100;
个股24日:=(C-MA(C,24))/MA(C,24)*100;
个股:(个股6日 + 个股12日 + 个股24日)/3,coloryellow;
强势出击:IF(大盘>REF(大盘,1) AND CROSS(个股,大盘),10,0 ),NODRAW;
STICKLINE(强势出击,0.1,6,3,0),COLORF00FF0;
出击:=IF(CROSS(个股,0),5,0);
穿大盘:=IF(CROSS(个股,大盘),10,0);
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=QJ0*(MIN(OPEN,CLOSE)-LOW);
QJ2:=QJ0*(JJ-MIN(CLOSE,OPEN));
QJ3:=QJ0*(HIGH-MAX(OPEN,CLOSE));
QJ4:=QJ0*(MAX(CLOSE,OPEN)-JJ);
DDX:=IF(HIGH=LOW,4*QJ0,((QJ1+QJ2)-(QJ3+QJ4)))/SUM(VOL,10)*100;
DDY:=((QJ2+QJ4)-(QJ1+QJ3))/SUM(VOL,10)*100;
DDZ:=((QJ1+QJ2)-(QJ3+QJ4))/((QJ1+QJ2)+(QJ3+QJ4))*100*17;
强势YJ:=DDX>2 AND DDZ>100 AND DDY>3 AND VOL/CAPITAL*100>3;
强势出击预警:个股24日>0 AND 出击>0 AND 穿大盘>0 AND 强势YJ>0 AND MA2>REF(MA2,1),colorred;
五强:=MA1>REF(MA1,1);
十三强:=MA2>REF(MA2,1);
二十一强:=MA3>REF(MA3,1);
三十四强:=MA4>REF(MA4,1),;
五十五强:=MA5>REF(MA5,1),;
小均强:=五强 AND 十三强,;
均强:=十三强 AND 二十一强 AND 三十四强;
大均强:=十三强 AND 二十一强 AND 三十四强 AND 五十五强;
JJD:=(H+L+C)/3;
强势线1:=HHV(MA((((LOW + HIGH) + CLOSE) / 3),8),60),colorred,LINETHICK2;
强势线2:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.18),8),20),colorwhite,LINETHICK2;
强势线3:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.258),8),10),coloryellow,LINETHICK2;
强势线4:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.08),80),13),COLORLIMAGENTA,LINETHICK2;

开始走强1:=强势线1>REF(强势线1,1);
开始走强2:=强势线2>REF(强势线2,1);
开始走强3:=强势线3>REF(强势线3,1);
开始走强4:=强势线4>REF(强势线3,1);
双强1:=开始走强1 AND 开始走强2;
双强2:=开始走强2 AND 开始走强3,;
双强3:=开始走强2 AND 开始走强3;
双强4:=开始走强3 AND 开始走强4;
三强:=开始走强1 AND 开始走强2 AND 开始走强3;
四强:=开始走强1 AND 开始走强2 AND 开始走强3 AND 开始走强4;
强势为王:双强1 OR 双强2 OR 双强3 OR 双强4 OR 三强 OR 四强,,COLORLIMAGENTA,LINETHICK2;

低位主升:=五强 AND 十三强 AND 五十五强;
主升浪:=五强 AND 十三强 AND 二十一强;
大主升浪:=十三强 AND 二十一强 AND 五十五强;
大主升浪2:=五强 AND 十三强 AND 二十一强 AND 五十五强;
总主升:=主升浪 AND 大主升浪 AND 大主升浪2;
总主升浪:低位主升 OR 主升浪 OR 大主升浪 OR 大主升浪2 OR 总主升;
VAR31:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:=IF(CLOSE>OPEN,VAR31*(HIGH-LOW),IF(CLOSE<OPEN,VAR31*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
大资金YJ主升浪:强势YJ>0 AND 主升浪>0 AND 主买>2700,colorgreen;
STICKLINE(大资金YJ主升浪,0.3,4,2,1),colorgreen;
N:=34;
TYP:=(2*C+H+L)/4;
HLNT:=(TYP-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;
HLN:=SMA(HLNT,20,1),colorred;
HLNS:=SMA(HLN,5,1),colorgreen;
主升买:CROSS(HLN,HLNS) AND HLNS<85,colormagenta,NODRAW;
主升阶段卖:=HLN<REF(HLN,1) AND REF(HLN,1)<REF(HLN,2) AND HLN>HLNS;
主升卖:=CROSS(HLNS,HLN);
卖:=IF(主升卖,20,100),colorgreen,NODRAW;
DRAWICON(主升买>0,1.1,1);
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
通达信源码:

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,13);
MA3:=MA(CLOSE,21);
MA4:=MA(CLOSE,34);
MA5:=MA(CLOSE,55);
大盘6日:=(INDEXC-MA(INDEXC,6))/MA(INDEXC,6)*100;
大盘12日:=(INDEXC-MA(INDEXC,12))/MA(INDEXC,12)*100;
大盘24日:=(INDEXC-MA(INDEXC,24))/MA(INDEXC,24)*100;
大盘:(大盘6日 + 大盘12日 + 大盘24日)/3,COLORWHITE;
个股6日:=(C-MA(C,6))/MA(C,6)*100;
个股12日:=(C-MA(C,12))/MA(C,12)*100;
个股24日:=(C-MA(C,24))/MA(C,24)*100;
个股:(个股6日 + 个股12日 + 个股24日)/3,COLORYELLOW;
强势出击:IF(大盘>REF(大盘,1) AND CROSS(个股,大盘),10,0 ),NODRAW;
STICKLINE(强势出击,0.1,6,3,0),COLORF00FF0;
出击:=IF(CROSS(个股,0),5,0);
穿大盘:=IF(CROSS(个股,大盘),10,0);
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=QJ0*(MIN(OPEN,CLOSE)-LOW);
QJ2:=QJ0*(JJ-MIN(CLOSE,OPEN));
QJ3:=QJ0*(HIGH-MAX(OPEN,CLOSE));
QJ4:=QJ0*(MAX(CLOSE,OPEN)-JJ);
DDX:=IF(HIGH=LOW,4*QJ0,((QJ1+QJ2)-(QJ3+QJ4)))/SUM(VOL,10)*100;
DDY:=((QJ2+QJ4)-(QJ1+QJ3))/SUM(VOL,10)*100;
DDZ:=((QJ1+QJ2)-(QJ3+QJ4))/((QJ1+QJ2)+(QJ3+QJ4))*100*17;
强势YJ:=DDX>2 AND DDZ>100 AND DDY>3 AND VOL/CAPITAL*100>3;
强势出击预警:个股24日>0 AND 出击>0 AND 穿大盘>0 AND 强势YJ>0 AND MA2>REF(MA2,1),COLORRED;
五强:=MA1>REF(MA1,1);
十三强:=MA2>REF(MA2,1);
二十一强:=MA3>REF(MA3,1);
三十四强:=MA4>REF(MA4,1),;
五十五强:=MA5>REF(MA5,1),;
小均强:=五强 AND 十三强,;
均强:=十三强 AND 二十一强 AND 三十四强;
大均强:=十三强 AND 二十一强 AND 三十四强 AND 五十五强;
JJD:=(H+L+C)/3;
强势线1:=HHV(MA((((LOW + HIGH) + CLOSE) / 3),8),60),COLORRED,LINETHICK2;
强势线2:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.18),8),20),COLORWHITE,LINETHICK2;
强势线3:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.258),8),10),COLORYELLOW,LINETHICK2;
强势线4:=HHV(MA((((LOW + HIGH) + CLOSE) / 3.08),80),13),COLORLIMAGENTA,LINETHICK2;

开始走强1:=强势线1>REF(强势线1,1);
开始走强2:=强势线2>REF(强势线2,1);
开始走强3:=强势线3>REF(强势线3,1);
开始走强4:=强势线4>REF(强势线3,1);
双强1:=开始走强1 AND 开始走强2;
双强2:=开始走强2 AND 开始走强3,;
双强3:=开始走强2 AND 开始走强3;
双强4:=开始走强3 AND 开始走强4;
三强:=开始走强1 AND 开始走强2 AND 开始走强3;
四强:=开始走强1 AND 开始走强2 AND 开始走强3 AND 开始走强4;
强势为王:双强1 OR 双强2 OR 双强3 OR 双强4 OR 三强 OR 四强,,COLORLIMAGENTA,LINETHICK2;

低位主升:=五强 AND 十三强 AND 五十五强;
主升浪:=五强 AND 十三强 AND 二十一强;
大主升浪:=十三强 AND 二十一强 AND 五十五强;
大主升浪2:=五强 AND 十三强 AND 二十一强 AND 五十五强;
总主升:=主升浪 AND 大主升浪 AND 大主升浪2;
总主升浪:低位主升 OR 主升浪 OR 大主升浪 OR 大主升浪2 OR 总主升;
VAR31:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:=IF(CLOSE>OPEN,VAR31*(HIGH-LOW),IF(CLOSE<OPEN,VAR31*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
大资金YJ主升浪:强势YJ>0 AND 主升浪>0 AND 主买>2700,COLORGREEN;
STICKLINE(大资金YJ主升浪,0.3,4,2,1),COLORGREEN;
{N=9,34,60分别代表短,中,长.默认60主升段,只做主升行情.大涨开始进入,下跌趋势开始时退出}
{公式}
N:=34;
TYP:=(2*C+H+L)/4;
HLNT:=(TYP-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;
HLN:=SMA(HLNT,20,1),COLORRED;
HLNS:=SMA(HLN,5,1),COLORGREEN;
{条件}
主升买:CROSS(HLN,HLNS) AND HLNS<85,COLORMAGENTA,NODRAW;
主升阶段卖:=HLN<REF(HLN,1) AND REF(HLN,1)<REF(HLN,2) AND HLN>HLNS;
主升卖:=CROSS(HLNS,HLN);
卖:=IF(主升卖,20,100),COLORGREEN,NODRAW;
DRAWICON(主升买>0,1.1,1);
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
B1万元:=DVOL*DCLOSE/100;
B1差:=B1万元-REF(B1万元,1);
B2万元:=DVOL*DCLOSE/100;
B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
密码:(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=密码/REF(密码,1);
选股:PMB AND 密码>REF(密码,1) AND 二日比>1,COLORRED,NODRAW;

DRAWNUMBER(选股=1 ,L,密码),COLORYELLOW;
DRAWICON(选股,L*0.975,26);

横盘放量:LAST((H-L)/REF(C,1)<0.1,20,0) AND VOL>REF(VOL,1)*2 AND C>REF(C,1)*1.03
AND "DMI.PDI">"DMI.MDI" AND CROSS("DMI.ADX","DMI.ADXR")
AND"DMI.ADXR">"DMI.MDI" AND "DMI.PDI">"DMI.ADX" AND"KDJ.D">REF("KDJ.D",1);
STICKLINE(横盘放量,0.1,8,1,0),COLOR000099;
发表于 2012-3-12 11:27 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2012-3-12 15:09 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2012-3-18 17:06 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2012-3-18 19:00 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2012-3-20 10:41 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2012-3-20 13:27 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2012-4-9 14:46 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2012-4-26 19:41 | 显示全部楼层
学习,学习。
回复 支持 反对

使用道具 举报

发表于 2012-4-28 16:25 | 显示全部楼层
是副图指标?
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2018-6-23 12:49 , Processed in 0.126988 second(s), 18 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表