老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

关闭
关闭
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 20269|回复: 87

[通达信] 黑马全套选股公式

  [复制链接]
发表于 2011-10-19 20:42 | 显示全部楼层 |阅读模式
选股公式
回贴是一种美德!
不回贴代码不全!




倍量选股
REF(V,1)/REF(V,2)>2 AND LOW>REF(HIGH,1);

前天跳跌
REF(HIGH,1)<REF(LOW,2);

强式高开
A :=MA(CLOSE,26);
UP:=A + 2*STD(CLOSE,26);
LOWER:=A - 2*STD(CLOSE,26);
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
       W3:=IF(W2>0,REF(C,W2),REF(C,W2));
       W4:=CROSS(C,REF(W3,1));
       IF(W4 AND COUNT(W4,5)=1,20,0) AND O>REF(H,1) AND  CAPITAL/700000<7;

强式选股
YS:=(C-L)/(H-L)*100;
X:=HHV(H,5)-REF(O,5);
Y:=C-LLV(L,5);
Z:=(HHV(H,5)-LLV(L,5))*2;
BD:=(X+Y)/Z*100;
CROSS(YS,BD) AND BD>REF(BD,1);



低位拐点
VAR1:=CLOSE/REF(LLV(LOW,35),5)< 1;
必买: IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,1,0);



埋伏修正
SHORT  2.00  200.00  12.00
LONG   2.00  200.00  26.00
MID    2.00  200.00  9.00

DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);

RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
短K:=SMA(RSV,3,1);
短D:=SMA(短K,3,1);
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
长K:=SMA(RSV1,5,1);
长D:=SMA(长K,10,1);
长K>长D OR DIF>DEA;





MACD双金
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);  
T:=BARSLAST(REF(CROSS(DIFF,DEA),1));
DEA1:=REF(DEA,T);
DEA1<0 AND CROSS(DIFF,DEA) AND DEA>DEA1 AND DEA<0 AND REF(L,T)>LLV(L,T) AND HHV(DEA,T)<0;



K叉长K
    RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
    短K:=SMA(RSV,3,1),COLORWHITE;
    短D:=SMA(短K,3,1),COLORYELLOW;
    RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
    长K:=SMA(RSV1,5,1),COLORRED;
    长D:=SMA(长K,10,1),COLOR66CC33;
    CROSS(长K,长D);


黑太阳涨停
A1:=REF(C,1)/REF(C,2)>1.098 AND REF(C,1)>REF(O,1) ;
A2:=L>REF(H,1) AND C<O AND V>REF(V,1) ;
XG:A1 AND A2 ;


黑马选股
COUNT(O>=REF(H,1),1)=1 AND HHV(C,60)=C AND C/REF(C,1)>1.051;


昨天三角
N1  0.00  99.00  1.00
VAR10:=IF(TROUGH(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
买点1:=VAR10;  
买点2:=(VAR11+VAR13+VAR15+VAR17);
REF(买点1 OR 买点2,N1);


筹线线选
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV1:=MA(OBV,10);


OBV>OBV1 AND OBV1>REF(OBV1,1);


小星体
阴实体:=REF(COUNT(H/REF(C,1)<1.03 ,5),1)>=3 AND REF(COUNT(H/REF(C,1)>0.97 ,5),1)<=3;
阴实体;



低量柱
AA:REF(V,0)=LLV(V,55);

扣停牌等
NOT(DYNAINFO(4)=0) ;

换手率
N  0.01  100.00   5.00
DYNAINFO(37)>=N/100;


突破
VVOL:=VOL*240/FROMOPEN;
盘虚万:=VVOL/10000;
量万:=VOL/10000;
HD:=FILTER(BACKSET(FILTER(REF(C,10)=HHV(C,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(C,10)=LLV(C,2*10+1),10),10+1),10);
波峰:=IF(BARSLAST(HD)<BARSLAST(LD) AND NOT(HD),REF(C,BARSLAST(HD)),REF(C,BARSLAST(HD)));
突破波峰:=CROSS(C,波峰) AND 盘虚万>MA(量万,25) AND C/REF(C,1)>1.043;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
强势:=80;
弱势:=20;
涨幅:=C/REF(C,1)>=1.043;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
CROSS(J,强势) AND 涨幅 AND 突破波峰;


突破走强
VVOL:=VOL*240/FROMOPEN;
盘虚万:=VVOL/10000;
量万:=VOL/10000;
HD:=FILTER(BACKSET(FILTER(REF(C,10)=HHV(C,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(C,10)=LLV(C,2*10+1),10),10+1),10);
波峰:=IF(BARSLAST(HD)<BARSLAST(LD) AND NOT(HD),REF(C,BARSLAST(HD)),REF(C,BARSLAST(HD)));
突破波峰:=CROSS(C,波峰) AND 盘虚万>MA(量万,25) AND C/REF(C,1)>1.043;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
强势:=80;
弱势:=20;
涨幅:=C/REF(C,1)>=1.043;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
CROSS(J,强势) AND 涨幅 AND 突破波峰;


买入信号
RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
VARR1:=(SUM(H,8)-SUM(L,8))/2;
RSVC:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
白马:=SMA(RSVC,3,1);
DC:=SMA(白马,3,1),LINETHICK1;
短J:=3*白马-2*DC,COLORYELLOW,LINETHICK1;
短K:=SMA(RSV,3,1),COLORBLUE;
短D:=SMA(短K,3,1),COLORMAGENTA,LINETHICK1;
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
长K:=SMA(RSV1,5,1),COLORRED,LINETHICK2;
长D:=SMA(长K,10,1),COLOR66CC33,LINETHICK1;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
强势区:=80,COLORYELLOW,LINETHICK1;
平衡:=50,COLORRED,LINETHICK1;
弱势区:=20,COLORGREEN,LINETHICK1;
主力线:=WINNER(C)*100,COLORRED,LINETHICK2;
HM:=SMA(RSV,3,1),COLORWHITE;
D1:=SMA(HM,3,1),COLORYELLOW;
K1:=SMA(RSV,10,1),COLORWHITE;
D:=SMA(K1,10,1),COLORRED;
TT:=3*HM-2*D1,COLORYELLOW;
压力线:=REF(HHV(HM,20),20),COLORYELLOW;
量能饱和:=(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26)*100;
AA:=CROSS(短J,强势区) AND CROSS(短J,平衡) AND C>EXPMA(C,12) AND C/REF(C,1)>1.04;
BB:=CROSS(短J,平衡) AND CROSS(短J,20);
CC:=短J-REF(短J,1)>30 AND C/REF(C,1)>1.05;
DD:=CROSS(TT,HM) AND TT>压力线 AND 短J>REF(短J,1) AND DYNAINFO(7)/REF(C,1)>=1.045;

工作线:=EXPMA(CLOSE,12);
生命线:=EXPMA(CLOSE,50);
走出短线强势区:=CROSS(78,"KDJ.J") AND 工作线>生命线 AND "MACD.DIF">"MACD.DEA" AND MA(C,5)>MA(C,30) AND 长K/长D<=1.09;
抬头:="KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)<REF("KDJ.J",2)
AND REF("KDJ.J",1)>REF("KDJ.D",1) AND "MACD.MACD">0;
金叉:=CROSS("KDJ.J","KDJ.D") AND MA(C,10)>MA(C,25)
AND MA(C,25)>REF(MA(C,25),1) AND "MACD.MACD">0;
DRAWTEXT(DD OR 量能饱和=100 AND CROSS(短J,82) AND DYNAINFO(7)/REF(C,1)>=1.043 OR CROSS(短J,82)
AND EXPMA(CLOSE,12)>EXPMA(CLOSE,50) AND 长K/长D>0.93 AND (MACD-REF(MACD,1))>0 AND 长K/长D>REF(长K,1)/REF(长D,1) AND (长K/长D)/(REF(长K,2)/REF(长D,2))>=0.975 AND DYNAINFO(7)/REF(C,1)>=1.043,45,'买 '),COLORRED;



低吸信号
RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
VARR1:=(SUM(H,8)-SUM(L,8))/2;
RSVC:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
白马:=SMA(RSVC,3,1);
DC:=SMA(白马,3,1),LINETHICK1;
短J:=3*白马-2*DC,COLORYELLOW,LINETHICK1;
短K:=SMA(RSV,3,1),COLORBLUE;
短D:=SMA(短K,3,1),COLORMAGENTA,LINETHICK1;
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
长K:=SMA(RSV1,5,1),COLORRED,LINETHICK2;
长D:=SMA(长K,10,1),COLOR66CC33,LINETHICK1;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
强势区:=80,COLORYELLOW,LINETHICK1;
平衡:=50,COLORRED,LINETHICK1;
主力线:=WINNER(C)*100,COLORRED,LINETHICK2;
HM:=SMA(RSV,3,1),COLORWHITE;
D1:=SMA(HM,3,1),COLORYELLOW;
K1:=SMA(RSV,10,1),COLORWHITE;
D:=SMA(K1,10,1),COLORRED;
TT:=3*HM-2*D1,COLORYELLOW;
压力线:=REF(HHV(HM,20),20),COLORYELLOW;
量能饱和:=(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26)*100;
AA:=CROSS(短J,强势区) AND CROSS(短J,平衡) AND C>EXPMA(C,12) AND C/REF(C,1)>1.04;
BB:=CROSS(短J,平衡) AND CROSS(短J,20);
CC:=短J-REF(短J,1)>30 AND C/REF(C,1)>1.05;
DD:=CROSS(TT,HM) AND TT>压力线 AND 短J>REF(短J,1) AND DYNAINFO(7)/REF(C,1)>=1.045;
工作线:=EXPMA(CLOSE,12);
生命线:=EXPMA(CLOSE,50);
强势低吸:=工作线>生命线 AND CROSS("KDJ.J",20) AND 长K>=长D AND 长K/长D>REF(长K,1)/REF(长D,1)  AND (长K/长D)/(REF(长K,2)/REF(长D,2))>=0.99;
抬头:="KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)<REF("KDJ.J",2)
AND REF("KDJ.J",1)>REF("KDJ.D",1) AND "MACD.MACD">0;
金叉:=CROSS("KDJ.J","KDJ.D") AND MA(C,10)>MA(C,25)
AND MA(C,25)>REF(MA(C,25),1) AND "MACD.MACD">0;
DRAWTEXT(强势低吸,15,'低吸'),COLORRED;


红箭头选股
RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
短K:=SMA(RSV,3,1),COLORWHITE;
短D:=SMA(短K,3,1),COLORYELLOW;
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
长K:=SMA(RSV1,5,1),COLORRED;
长D:=SMA(长K,10,1),COLOR66CC33;
CROSS(MA(CLOSE,5),MA(CLOSE,24)) AND REF(COUNT(C/REF(C,1)<=1.04 ,1 ),0)>0 AND 长K>长D AND NOT(DYNAINFO(4)=0);


人头选股
RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
短K:=SMA(RSV,3,1),COLORWHITE;
短D:=SMA(短K,3,1),COLORYELLOW;
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
长K:=SMA(RSV1,5,1),COLORRED;
长D:=SMA(长K,10,1),COLOR66CC33;
A1:=MA(CLOSE,10);
A2:=MA(CLOSE,20);
A3:=MA(CLOSE,30);
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV1:=MA(OBV,10);
A :=MA(CLOSE,26);
UP:=A + 2*STD(CLOSE,26);
LOWER:=A - 2*STD(CLOSE,26);
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
       W3:=IF(W2>0,REF(C,W2),REF(C,W2));
       W4:=CROSS(C,REF(W3,1));
     IF(W4 AND COUNT(W4,5)=1,20,0)  AND OBV>OBV1 AND OBV1>REF(OBV1,1) AND 长K/长D>1;



吻选股
A1:=MA(CLOSE,5);
A2:=MA(CLOSE,20);
A3:=MA(CLOSE,30);
A偏离度:=(CLOSE-HHV(HIGH,250))/HHV(HIGH,250)*100;
B偏离度:=(CLOSE-HHV(HIGH,120))/HHV(HIGH,120)*100;
C偏离度:=(LOW-MA(CLOSE,13))/MA(CLOSE,13)*100;
N日内13日线走向:=(MA(CLOSE,13)-REF(MA(CLOSE,13),5))/REF(MA(CLOSE,13),5)*100;
DRAWTEXT("KDJ.D">REF("KDJ.D",1) AND A偏离度= B偏离度 AND COUNT(A1>A2 AND A2>A3 ,2)=2 AND "KDJ.J">20 AND "MACD.MACD">0 AND C偏离度>-12  AND B偏离度-REF(B偏离度,1)>1 AND N日内13日线走向-C偏离度<12 AND B偏离度>(C偏离度-1.3),-5,'买 ');

评分

参与人数 1威望 +2 庄币 +2 收起 理由
191139993 + 2 + 2 很给力!

查看全部评分

头像被屏蔽
发表于 2011-10-19 20:44 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-10-19 21:03 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-10-19 21:13 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-10-19 22:36 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-10-19 22:37 | 显示全部楼层
感谢分享!
回复 支持 反对

使用道具 举报

发表于 2011-10-20 11:34 | 显示全部楼层
学习学习
回复 支持 反对

使用道具 举报

发表于 2011-10-20 11:35 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-10-20 23:06 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-10-20 23:08 | 显示全部楼层
感谢分享!

评分

参与人数 1威望 +2 庄币 +2 收起 理由
~Judy + 2 + 2 good

查看全部评分

回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2018-6-23 12:48 , Processed in 0.134066 second(s), 19 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表