老钱庄股票论坛

 找回密码
 5秒快速注册
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 10819|回复: 40

[通达信] 黑马全套指标下载.

  [复制链接]
发表于 2011-10-19 20:41 | 显示全部楼层 |阅读模式
回贴是一种美德,
不回贴源码不全!


黑马邦主图一
攻击线:MA(CLOSE,5),LINETHICK1;
操盘线:MA(CLOSE,10),LINETHICK1;
魔鬼线:MA(CLOSE,20),LINETHICK1;
生命线:MA(CLOSE,30),LINETHICK2;
决策线:MA(CLOSE,60),LINETHICK1;
趋势线:MA(CLOSE,120),LINETHICK2;
牛熊线:MA(CLOSE,250),LINETHICK3;
STICKLINE(C/REF(C,1)>1.07,O,C,2,0),COLORRED;
STICKLINE(REF(C,1)/C>1.07,O,C,2,0),COLOR00FF00;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,-1,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,-1,0),COLORBLUE;
STICKLINE(跌停,H,L,0,1),COLORBLUE;
大阳线:=IF((C-C2)*100/C2>=5,1,0)&&IF((C-C2)*100/C2<(10-0.01*100/C2),1,0) OR IF((C-O)*100/O>=5,1,0)&&IF((C-C2)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阳线,OPEN,CLOSE,-1,0),COLORRED;
STICKLINE(大阳线,H,L,0,1),COLORRED;
大阴线:=IF((C2-C)*100/C2>=5,1,0)&&IF((C2-C)*100/C2<(10-0.01*100/C2),1,0) OR IF((O-C)*100/O>=5,1,0)&&IF((C2-C)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阴线,OPEN,CLOSE,-1,0),COLORGREEN;
STICKLINE(大阴线,H,L,0,1),COLORGREEN;

TY:=C;
AA1:=REF(TY,10)=HHV(TY,2*10+1); BB1:=FILTER(AA1,10); C1:=BACKSET(BB1,10+1); HD:=FILTER(C1,10);
AA2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(AA2,10); CC2:=BACKSET(B2,10+1); LD:=FILTER(CC2,10);
前期高位:REF(H,BARSLAST(HD)),COLOR00FF00,POINTDOT,LINETHICK3;
前期低位:REF(L,BARSLAST(LD)),COLORFF00FF,POINTDOT,LINETHICK3;
DRAWICON(CROSS(MA(C,5),MA(C,24)) ,MA(C,5),1);

W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
DRAWICON(W4 AND COUNT(W4,5)=1,LOW,3);


BB:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:=IF(MA(CLOSE,17)<BB,BB,MA(CLOSE,17));
操作线:=分水岭-(EMA(C,3)-分水岭);
DRAWTEXT(CROSS(分水岭,操作线),分水岭-0.5,'B');

MAJ2:=EMA(C,3);
MAJ5:=EMA(C,7);
MAJ13:=EMA(C,13);
MAJ34:=EMA(C,34);
MAJ55:=EMA(C,55);
YCXJ:=MAJ5>=REF(MAJ5,1);
H1:=MAX(MAX(MAJ5,MAJ13),MAJ34);
L1:=MIN(MIN(MAJ5,MAJ13),MAJ34);  
DRAWTEXT(H1<C AND O<L1 AND YCXJ AND MAJ2>REF(MAJ2,1),LOW*0.96,'◇');

{回归卖出图标}
RSV回归:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;
K回归:=SMA(RSV回归,3,1);
D回归:=SMA(K回归,3,1);
J回归:=3*K回归-2*D回归;
VAR回归3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}
VAR回归4:=EMA(EMA(EMA(VAR回归3,4),4),4);{可将3该为4,信号少点}
E回归:=(VAR回归4-REF(VAR回归4,1))/REF(VAR回归4,1)*100;
F回归:=MA(E回归,3)+0.03;
G回归:=MA(E回归,1);
DRAWICON(CROSS(F回归,G回归) AND J回归>65,HIGH*1.02,15),COLORGREEN;

{双底买入部分}
VAR10A:=IF(TROUGH(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11B:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR13C:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR15D:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR17E:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
买点1A:=VAR10A;  
买点2A:=(VAR11B+VAR13C+VAR15D+VAR17E);
买入:=COUNT(买点1A OR 买点2A,15)=2 AND (买点1A OR 买点2A) AND COUNT(C/REF(C,1)>1.07,15)>=1;
DRAWICON(买入,LOW*0.97,18);





黑马邦主图二
M1  2  1000  5
M2  2  1000  10
M3  2  1000  24
M4  2  1000  72
M5  2  1000  200

MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
MA5:MA(CLOSE,M5);

TY:=C;
HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);
A:=REF(C,BARSLAST(HD));
B:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波浪顶:IF(T1,A,A),COLORFF00FF,POINTDOT,LINETHICK2;
STICKLINE(T1,A,A,9,0),COLORFF00FF;
波浪底:IF(T2,B,B),COLOR80FF00,POINTDOT,LINETHICK2;
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=MA(HHV(CLOSE-REF(CLOSE,1),0),34)/MA(ABS(CLOSE-REF(CLOSE,1)),7)*100;
VAR9:=MA(HHV(CLOSE-REF(CLOSE,1),0),13)/MA(ABS(CLOSE-REF(CLOSE,1)),13)*100;
VARA:=BARSCOUNT(CLOSE);
VARB:=VAR8<20 AND VAR9<23 AND VARA>35;
VARC:=VARB AND COUNT(VARB,1)=1;
VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);
VARE:=EMA(VARD,5);
VARF:=TROUGH(3,6,1)<4 AND CROSS(VARD,VARE);
VAR10:=IF(TROUGH(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR1A:=EMA(VAR19,100);
VAR1B:=2*(VAR19-VAR1A);
VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);
VAR1D:=SQRT(SQRT(LOW*HIGH*O*CLOSE));
VAR1E:=EMA(VAR1D*0.97,3);
VAR1F:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));
VAR21:=CROSS(VAR1E,LOW);
买点1:=VAR10;
买点2:=(VAR11+VAR13+VAR15+VAR17);
卖点1:=(VAR12+VAR14+VAR16+VAR18),LINETHICK2;
VAR22:=买点1 AND VARF AND VARC AND VAR21 AND VAR4<0 AND VAR5=0 AND VAR6=0 AND VAR20<(-110);
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR31:=MA(CLOSE,30);
VARB1:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VARC1:=INTPART(VARB1*100)/100;
VARD1:=EMA(CLOSE,5)-EMA(CLOSE,10);
VARE1:=EMA(VARD1,9);
VAR131:=REF(VARE1,1);
VAR141:=VARE1;
VAR151:=VAR141-VAR131;
VAR161:=REF(VARD1,1);
VAR171:=VARD1;
VAR181:=VAR171-VAR161;
VAR191:=O;
VAR1A1:=CLOSE;
DRAWTEXT(买点1>0,L-0.01,'▲'),COLORRED;
DRAWTEXT(买点2>0,L-0.01,'▲'),COLORFF00FF;
DRAWTEXT(卖点1>0,H+0.1,'▼'), COLOR33FF33;
STICKLINE(C/REF(C,1)>1.07,O,C,2,0),COLORRED;
STICKLINE(REF(C,1)/C>1.07,O,C,2,0),COLOR00FF00;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,-1,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,-1,0),COLORBLUE;
STICKLINE(跌停,H,L,0,1),COLORBLUE;
大阳线:=IF((C-C2)*100/C2>=5,1,0)&&IF((C-C2)*100/C2<(10-0.01*100/C2),1,0) OR IF((C-O)*100/O>=5,1,0)&&IF((C-C2)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阳线,OPEN,CLOSE,-1,0),COLORRED;
STICKLINE(大阳线,H,L,0,1),COLORRED;
大阴线:=IF((C2-C)*100/C2>=5,1,0)&&IF((C2-C)*100/C2<(10-0.01*100/C2),1,0) OR IF((O-C)*100/O>=5,1,0)&&IF((C2-C)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阴线,OPEN,CLOSE,-1,0),COLORGREEN;
STICKLINE(大阴线,H,L,0,1),COLORGREEN;

DRAWICON(CROSS(MA(C,5),MA(C,24)) ,MA(C,5),1);

W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
DRAWICON(W4 AND COUNT(W4,5)=1,LOW,3);

BB:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:=IF(MA(CLOSE,17)<BB,BB,MA(CLOSE,17));
操作线:=分水岭-(EMA(C,3)-分水岭);
DRAWTEXT(CROSS(分水岭,操作线),分水岭-0.5,'B');

MAJ2:=EMA(C,3);
MAJ5:=EMA(C,7);
MAJ13:=EMA(C,13);
MAJ34:=EMA(C,34);
MAJ55:=EMA(C,55);
YCXJ:=MAJ5>=REF(MAJ5,1);
H1:=MAX(MAX(MAJ5,MAJ13),MAJ34);
L1:=MIN(MIN(MAJ5,MAJ13),MAJ34);  
DRAWTEXT(H1<C AND O<L1 AND YCXJ AND MAJ2>REF(MAJ2,1),LOW*0.96,'◇');

{回归卖出图标}
RSV回归:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;
K回归:=SMA(RSV回归,3,1);
D回归:=SMA(K回归,3,1);
J回归:=3*K回归-2*D回归;
VAR回归3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}
VAR回归4:=EMA(EMA(EMA(VAR回归3,4),4),4);{可将3该为4,信号少点}
E回归:=(VAR回归4-REF(VAR回归4,1))/REF(VAR回归4,1)*100;
F回归:=MA(E回归,3)+0.03;
G回归:=MA(E回归,1);
DRAWICON(CROSS(F回归,G回归) AND J回归>65,HIGH*1.02,15),COLORGREEN;

{双底买入部分}
VAR10A:=IF(TROUGH(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11B:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR13C:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR15D:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR17E:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
买点1A:=VAR10A;  
买点2A:=(VAR11B+VAR13C+VAR15D+VAR17E);
买入:=COUNT(买点1A OR 买点2A,15)=2 AND (买点1A OR 买点2A) AND COUNT(C/REF(C,1)>1.07,15)>=1;
DRAWICON(买入,LOW*0.97,18);






黑马邦量
VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
AA:=VOL>=REF(V,1)*1.91 && C>REF(C,1);
AA1:=VOL<REF(LLV(VOL,21),1);
AA2:=VOL<REF(LLV(VOL,55),1);
AA3:=ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.05;
STICKLINE(AA,0,V,1,0),COLORYELLOW;
STICKLINE(AA1,0,V,1,0),COLORGREEN;
STICKLINE(AA2,0,V,1,0),COLORMAGENTA;
STICKLINE(AA3,0,V,1,0),COLORWHITE;
MV1:MA(VOL,5);
MV2:MA(VOL,10);
MV3:MA(VOL,60);
DRAWICON(CROSS(MV1,MV3) ,MV1,1);
DRAWICON(CROSS(MV3,MV1) ,MV1,3);


色彩MACD
SHORT  2.00  200.00  12.00
LONG   2.00  200.00  26.00
MID    2.00  200.00  9.00
DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD : 2*(DIFF-DEA), COLORSTICK;  
STICKLINE(ABS((MACD-REF(MACD,1)))/ABS(REF(MACD,1))<=0.01 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORMAGENTA;
STICKLINE((MACD-REF(MACD,1))/ABS(REF(MACD,1))>0.01,0,MACD,1,0),COLORRED;
STICKLINE(MACD<REF(MACD,1),0,MACD,1,0),COLOR00FF00;
DRAWICON(CROSS(DIFF,DEA) ,DEA,1);
QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
QM:=LLVBARS(MACD,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);
QF:=LLVBARS(DIFF,QZQ+20);
DQDZ:=IF(QF>QZQ,REF(DIFF,QF),0);
XG1:=MACD<0 AND MACD>MQDZ AND DIFF<0 AND DIFF>DQDZ
AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0 AND DQDZ<0;
XG2:=REF(XG1,1)=1 AND MACD>REF(MACD,1);

XG3:=MACD<0 AND MACD>MQDZ
AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0;
XG4:=REF(XG3,1)=1 AND MACD>REF(MACD,1);

DRAWICON(XG2,DEA*1.1,18);
DRAWICON(XG4,DEA*1.1,17);



操盘主图
回归斜率线A:=EMA(SLOPE(C,4)*20+C,42);
      
       经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
       经典K:=SMA(经典RL,3,1); 经典D:=SMA(经典K,3,1); 经典J:=3*经典K-2*经典D;
       MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20)))  /(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));
       MAHL2:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}
       MAHL3:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}
      
       回归斜率带:DRAWBAND(回归斜率线A,RGB(235,0,230),REF(回归斜率线A,2),RGB(0,104,154));
      
       上线:=SMA(C,6.5,1);
       一号支撑线:SMA(C,14.5,1);
       上线1:=SMA(C,3,1);
       一号支撑线1:=SMA(C,8,1);
       上线2:=SMA(C,3.5,1);
       DRAWTEXT(CROSS(一号支撑线1,上线1),H*1.08,'压力'),COLOR00FF00;
       BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;
       UPR:=BBI+3*STD(BBI,13),LINETHICK2;
       DWN:=BBI-3*STD(BBI,13);
       安全:=MA(CLOSE,55),LINETHICK2;
       LC:=REF(CLOSE,1);
       RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
       DRAWTEXT( CROSS(82,RSI) AND CLOSE<上线1 , HIGH*1.04,'压力线') ,COLORFF9966,LINETHICK2;
       A7:=(2*C+H+L)/4;
       操作:MA(A7,5),COLORBLUE,LINETHICK2;
       操作1:=MA(A7,5)*1.03,LINETHICK2;
       操作2:=MA(A7,5)*0.97,LINETHICK2;
      
       DRAWTEXT( CROSS(上线1,上线) AND 上线1>操作,LOW *0.92,'买进' ),COLORYELLOW;
       VAR1:LLV(A7,21);
       VAR2:HHV(A7,30);
       DRAWTEXT( CROSS(上线1,操作) AND 上线1<一号支撑线 AND 上线1<一号支撑线1 AND 上线1<上线 AND CLOSE>VAR1,LOW *0.98,'见底' ),COLORYELLOW;
       YCX:=操作>=REF(操作,1);
       H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);
       L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);
       DRAWTEXT(CROSS(上线1,一号支撑线1) AND 上线1>操作 ,LOW *0.98,'全仓' ),COLORYELLOW;
       SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
       SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
       M1:=1000*操作/一号支撑线<=1015 AND 1000*操作/一号支撑线>=975;
       M2:=1000*一号支撑线1/一号支撑线<=1020 AND 一号支撑线1/一号支撑线>=980;
       M3:=1000*上线/一号支撑线<=1015 AND 上线/一号支撑线>=985;
       DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
       COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
       REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
       OPEN>REF(CLOSE,1),1,0),LOW*0.94,'买进') ,COLORYELLOW;
       D:=MA(CLOSE,89)-MA(CLOSE,10)/3;
       DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
       AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.88,'抄底'),COLORBROWN;
       RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;
       K:=SMA(RSV,3,1);
       D1:=SMA(K,3,1);
       J:=3*K-2*D1;
       VAR3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}
       VAR4:=EMA(EMA(EMA(VAR3,4),4),4);{可将3该为4,信号少点}
       E:=(VAR4-REF(VAR4,1))/REF(VAR4,1)*100;
       F:=MA(E,3)+0.03;
       G:=MA(E,1);
      
       DRAWICON(CROSS(F,G) AND J>65,HIGH*1.02,15),COLORGREEN;
       DRAWICON(CROSS(G,F),LOW *0.9,9),COLORYELLOW;
      
       DRAWTEXT(CLOSE>OPEN AND H1<C AND O<L1 AND YCX AND CROSS(上线1,操作) AND LOW>VAR1 AND 上线1>一号支撑线 AND J<90,LOW *0.9,'主升' ),COLORRED;
      
       DRAWTEXT( CROSS(上线1,操作) AND M1 AND M2 AND M3,LOW *0.94,'买进' ),COLORYELLOW;
       DRAWTEXT(CLOSE>OPEN AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CLOSE>MA(CLOSE,一号支撑线) AND 操作>=REF(CLOSE,操作) AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.9,'主升' ),COLORRED;
       DRAWTEXT(CLOSE>OPEN AND 操作>上线 AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),COLORRED;
       DRAWTEXT(CLOSE>OPEN AND CROSS(上线,一号支撑线) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),COLORRED;
      
       STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORRED;
       STICKLINE(C<O AND C>REF(C,1),C,O,3,0),COLORFFCC00;
       STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,3,0 ),COLOR000055;{红K};
       STICKLINE(CLOSE> REF(CLOSE,1) AND C>O  ,OPEN,CLOSE,2.7,0 ),COLOR000077;{红K};
       STICKLINE(CLOSE> REF(CLOSE,1) AND C>O  ,OPEN,CLOSE,2.1,0 ),COLOR000099;
       STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
       STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
       STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
       STICKLINE(CLOSE= REF(CLOSE,1) ,H,L,3,1 ),COLOR999999;
       STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORWHITE;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
       STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
       STICKLINE(C<REF(C,1) AND C>O,C,O,3,0),COLORFFCC00;
       STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,3,0 ),COLOR990000;
       STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
       STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
       STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
       STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,3.2,0),COLORBB00FF;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.7,0),COLORFF33FF;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.1,0), COLORFF66FF;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,1.5,0),COLORFF99FF;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.9,0),COLORFFBBFF;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.3,0),COLORFFDDFF;


操盘副图
回归斜率线A:=EMA(SLOPE(C,4)*20+C,42);
      
       经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
       经典K:=SMA(经典RL,3,1); 经典D:=SMA(经典K,3,1); 经典J:=3*经典K-2*经典D;
       MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20)))  /(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));
       MAHL2:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}
       MAHL3:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}
      
       回归斜率带:DRAWBAND(回归斜率线A,RGB(235,0,230),REF(回归斜率线A,2),RGB(0,104,154));
      
       上线:=SMA(C,6.5,1);
       一号支撑线:SMA(C,14.5,1);
       上线1:=SMA(C,3,1);
       一号支撑线1:=SMA(C,8,1);
       上线2:=SMA(C,3.5,1);
       DRAWTEXT(CROSS(一号支撑线1,上线1),H*1.08,'压力'),COLOR00FF00;
       BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;
       UPR:=BBI+3*STD(BBI,13),LINETHICK2;
       DWN:=BBI-3*STD(BBI,13);
       安全:=MA(CLOSE,55),LINETHICK2;
       LC:=REF(CLOSE,1);
       RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
       DRAWTEXT( CROSS(82,RSI) AND CLOSE<上线1 , HIGH*1.04,'压力线') ,COLORFF9966,LINETHICK2;
       A7:=(2*C+H+L)/4;
       操作:MA(A7,5),COLORBLUE,LINETHICK2;
       操作1:=MA(A7,5)*1.03,LINETHICK2;
       操作2:=MA(A7,5)*0.97,LINETHICK2;
      
       DRAWTEXT( CROSS(上线1,上线) AND 上线1>操作,LOW *0.92,'买进' ),COLORYELLOW;
       VAR1:LLV(A7,21);
       VAR2:HHV(A7,30);
       DRAWTEXT( CROSS(上线1,操作) AND 上线1<一号支撑线 AND 上线1<一号支撑线1 AND 上线1<上线 AND CLOSE>VAR1,LOW *0.98,'见底' ),COLORYELLOW;
       YCX:=操作>=REF(操作,1);
       H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);
       L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);
       DRAWTEXT(CROSS(上线1,一号支撑线1) AND 上线1>操作 ,LOW *0.98,'全仓' ),COLORYELLOW;
       SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
       SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
       M1:=1000*操作/一号支撑线<=1015 AND 1000*操作/一号支撑线>=975;
       M2:=1000*一号支撑线1/一号支撑线<=1020 AND 一号支撑线1/一号支撑线>=980;
       M3:=1000*上线/一号支撑线<=1015 AND 上线/一号支撑线>=985;
       DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
       COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
       REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
       OPEN>REF(CLOSE,1),1,0),LOW*0.94,'买进') ,COLORYELLOW;
       D:=MA(CLOSE,89)-MA(CLOSE,10)/3;
       DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
       AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.88,'抄底'),COLORBROWN;
       RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;
       K:=SMA(RSV,3,1);
       D1:=SMA(K,3,1);
       J:=3*K-2*D1;
       VAR3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}
       VAR4:=EMA(EMA(EMA(VAR3,4),4),4);{可将3该为4,信号少点}
       E:=(VAR4-REF(VAR4,1))/REF(VAR4,1)*100;
       F:=MA(E,3)+0.03;
       G:=MA(E,1);
      
       DRAWICON(CROSS(F,G) AND J>65,HIGH*1.02,15),COLORGREEN;
       DRAWICON(CROSS(G,F),LOW *0.9,9),COLORYELLOW;
      
       DRAWTEXT(CLOSE>OPEN AND H1<C AND O<L1 AND YCX AND CROSS(上线1,操作) AND LOW>VAR1 AND 上线1>一号支撑线 AND J<90,LOW *0.9,'主升' ),COLORRED;
      
       DRAWTEXT( CROSS(上线1,操作) AND M1 AND M2 AND M3,LOW *0.94,'买进' ),COLORYELLOW;
       DRAWTEXT(CLOSE>OPEN AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CLOSE>MA(CLOSE,一号支撑线) AND 操作>=REF(CLOSE,操作) AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.9,'主升' ),COLORRED;
       DRAWTEXT(CLOSE>OPEN AND 操作>上线 AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),COLORRED;
       DRAWTEXT(CLOSE>OPEN AND CROSS(上线,一号支撑线) AND LOW>VAR1 AND J<90,LOW *0.86,'回踩买进' ),COLORRED;
      
       STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORRED;
       STICKLINE(C<O AND C>REF(C,1),C,O,3,0),COLORFFCC00;
       STICKLINE(CLOSE> REF(CLOSE,1) AND C>O ,OPEN,CLOSE,3,0 ),COLOR000055;{红K};
       STICKLINE(CLOSE> REF(CLOSE,1) AND C>O  ,OPEN,CLOSE,2.7,0 ),COLOR000077;{红K};
       STICKLINE(CLOSE> REF(CLOSE,1) AND C>O  ,OPEN,CLOSE,2.1,0 ),COLOR000099;
       STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
       STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
       STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
       STICKLINE(CLOSE= REF(CLOSE,1) ,H,L,3,1 ),COLOR999999;
       STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,0 ),COLORWHITE;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
       STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
       STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
       STICKLINE(C<REF(C,1) AND C>O,C,O,3,0),COLORFFCC00;
       STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,3,0 ),COLOR990000;
       STICKLINE(C<REF(C,1) AND C<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
       STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
       STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
       STICKLINE(CLOSE< REF(C,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,3.2,0),COLORBB00FF;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.7,0),COLORFF33FF;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,2.1,0), COLORFF66FF;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,1.5,0),COLORFF99FF;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.9,0),COLORFFBBFF;
       STICKLINE(CROSS(J,D1) AND J<70,CLOSE,OPEN,0.3,0),COLORFFDDFF;


KDJ优化

VARR1:=(SUM(H,8)-SUM(L,8))/2;
RSVC:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
白马:=SMA(RSVC,3,1);
DC:=SMA(白马,3,1),LINETHICK1;
黑马:3*白马-2*DC,COLORMAGENTA,LINETHICK2;
强势区:80,COLORMAGENTA,LINETHICK1;
平衡:=50,COLORRED,LINETHICK1;
弱势区:20,COLORGREEN,LINETHICK1;
主力线:WINNER(C)*100,COLORRED,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,40))/(HHV(HIGH,40)-LLV(LOW,40))*100;
HM:=SMA(RSV,3,1),COLORWHITE;
D1:=SMA(HM,3,1),COLORYELLOW;
K1:=SMA(RSV,10,1),COLORWHITE;
D:=SMA(K1,10,1),COLORRED;
TT:=3*HM-2*D1,COLORYELLOW;
压力线:REF(HHV(HM,20),20),COLORYELLOW;
量能饱和:=(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26)*100,COLORLIMAGENTA,NODRAW;
AA:=CROSS(黑马,强势区) AND CROSS(黑马,平衡) AND C>EXPMA(C,12) AND C/REF(C,1)>1.04;
BB:=CROSS(黑马,平衡) AND CROSS(黑马,20);
CC:=黑马-REF(黑马,1)>30 AND C/REF(C,1)>1.05;
DD:=CROSS(TT,HM) AND TT>压力线 AND 黑马>REF(黑马,1) AND DYNAINFO(7)/REF(C,1)>=1.045;
DRAWICON(CROSS(黑马,强势区) AND C>EXPMA(CLOSE,12) AND CC OR AA{ OR DD}
OR 量能饱和=100 AND CROSS(黑马,强势区) OR CROSS(黑马,强势区)
AND EXPMA(CLOSE,12)>EXPMA(CLOSE,50) AND "MACD.MACD">REF("MACD.MACD",1),75,1);
DRAWICON(BB,40,1);
工作线:=EXPMA(CLOSE,12);
生命线:=EXPMA(CLOSE,50);
走出短线强势区:=CROSS(78,"KDJ.J") AND 工作线>生命线 AND "MACD.DIF">"MACD.DEA" AND MA(C,5)>MA(C,30);
强势低吸:=工作线>生命线 AND CROSS("KDJ.J",20);
DRAWICON(走出短线强势区,85,2);
抬头:="KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)<REF("KDJ.J",2)
AND REF("KDJ.J",1)>REF("KDJ.D",1) AND "MACD.MACD">0;
金叉:=CROSS("KDJ.J","KDJ.D") AND MA(C,10)>MA(C,25)
AND MA(C,25)>REF(MA(C,25),1) AND "MACD.MACD">0;
DRAWICON( 强势低吸,15,1);
{DRAWICON(AA OR BB,50,1);}
DRAWICON(CC OR AA,25,1);
DRAWTEXT(强势低吸,15,'低吸'),COLORF00FF0;
DRAWTEXT(走出短线强势区,95,'高抛'),COLORGREEN;
DRAWTEXT(DD OR 量能饱和=100 AND CROSS(黑马,82) AND DYNAINFO(7)/REF(C,1)>=1.043 OR CROSS(黑马,82)
AND EXPMA(CLOSE,12)>EXPMA(CLOSE,50) AND DYNAINFO(7)/REF(C,1)>=1.043,55,'买'),COLORF00FF0;
STICKLINE(黑马>=80,80,(黑马*0.98),1,1),COLORMAGENTA;
STICKLINE(黑马<20,20,黑马+1,1,1),COLORBLUE;




筹码线
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV1:MA(OBV,10);

IF(OBV>REF(OBV,1),OBV,DRAWNULL), COLORRED, LINETHICK2;
IF(OBV<=REF(OBV,1),OBV,DRAWNULL), COLORGREEN, LINETHICK2;
IF(OBV1>REF(OBV1,1),OBV1,DRAWNULL), COLORRED, LINETHICK3;
IF(OBV1<=REF(OBV1,1),OBV1,DRAWNULL), COLORGREEN, LINETHICK3;


动向流
N  2.00  20.00  4.00
动向流:(MA(CLOSE,2)-REF(MA(CLOSE,2),N))/REF(MA(CLOSE,2),N),COLORFFFF00;
PLOYLINE(1,MA(动向流,2)),COLORFFFF00;
PLOYLINE(1,MA(动向流,4)),COLORFFD800;
PLOYLINE(1,MA(动向流,6)),COLORFFA600;
PLOYLINE(1,MA(动向流,8)),COLORFF6800;
PLOYLINE(1,MA(动向流,10)),COLORFF3800;
PLOYLINE(1,MA(动向流,12)),COLORD1FF00;
PLOYLINE(1,MA(动向流,14)),COLORABFF00;
PLOYLINE(1,MA(动向流,16)),COLOR68FF00;
PLOYLINE(1,MA(动向流,18)),COLOR3EFF00;
PLOYLINE(1,MA(动向流,20)),COLORFF8CFF;
PLOYLINE(1,MA(动向流,22)),COLORC88CFF;
PLOYLINE(1,MA(动向流,24)),COLORC854FF;
PLOYLINE(1,MA(动向流,26)),COLOR7354FF;
PLOYLINE(1,MA(动向流,28)),COLOR7F00FF;
PLOYLINE(1,MA(动向流,30)),COLOR0000FF;


布过昨高
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:=IF(MA(CLOSE,17)<B,B,MA(CLOSE,17));
操作线:=分水岭-(EMA(C,3)-分水岭);
CROSS(分水岭,操作线) AND C>REF(H,1);


高开二点
O/REF(C,1)*100-100>2;


波段精典
VAR1:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;
套牢筹码:SMA(VAR1,3,1)/28.57,COLORFF00FF,LINETHICK2;
VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)/28.57;
股:EMA(VAR3,5),COLORFFCCCC,POINTDOT;
操盘:3*VAR3-2*股,COLORRED,POINTDOT;
强弱分界:1.75,COLORFFCC66,POINTDOT;
底:0,COLORWHITE,POINTDOT;
顶预警:3.2,COLOR00DD00,POINTDOT;
底预警:0.3,COLOR0099FF,POINTDOT;
顶:3.5,COLORRED,POINTDOT;
STICKLINE(操盘>股,操盘,股,1,1),COLORRED;
STICKLINE(操盘<股,股,操盘,1,1),COLOR00DD00;
STICKLINE(操盘>顶预警,操盘,顶预警,1,1),COLORYELLOW;
STICKLINE(操盘>顶,操盘,顶,1,1),COLOR00DD00;
STICKLINE(操盘<底预警,操盘,底预警,1,1),COLORFF00FF;
STICKLINE(操盘<底,操盘,底,1,1),COLORFFCC66;
A1:=CROSS(操盘,VAR3) AND VAR3<2.1 AND C>O;
STICKLINE(A1,0,0.90,1,1),COLORYELLOW;
A2:=CROSS(操盘,VAR3) AND VAR3>2.2;
DRAWICON(A2,VAR3,1);


股市黑火药
一硝:(HHV(HIGH,9)+LLV(LOW,9))/2,COLORRED;
二黄:(HHV(HIGH,26)+LLV(LOW,26))/2,COLORYELLOW;
硝酸钾:=MA(C,3);
硫磺:=MA(硝酸钾,5);
木炭:=MA(硝酸钾,60);
三木炭:=3*木炭-2*硫磺;
AA:=CROSS(二黄,三木炭);
BB:=CROSS(一硝,二黄);
DRAWTEXT(BB,二黄,'火'),COLORRED;
DRAWTEXT(AA,二黄,'黑火药'),COLORWHITE;



强式指标
YS:=(C-L)/(H-L)*100;
X:=HHV(H,5)-REF(O,5);
Y:=C-LLV(L,5);
Z:=(HHV(H,5)-LLV(L,5))*2;
BD:=(X+Y)/Z*100;
CROSS(YS,BD) AND BD>REF(BD,1);

动态高低点
来势线: EMA(CLOSE,7)-EMA(CLOSE,21),COLORYELLOW;
福星: EMA(来势线,7), COLORSTICK,COLORRED;
VAR1:=CLOSE/REF(LLV(LOW,35),5)< 1;
决策: IF(VAR1,0.5,0), STICK,COLORBLUE;
必买: IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,1,-1),COLORYELLOW ,LINETHICK1 ;
必卖: IF(PEAKBARS(3,15,1)=1,1,2),COLORWHITE,LINETHICK1;
趋势线: (EMA(WINNER(CLOSE),7)-EMA(WINNER(CLOSE),35))*5,COLORRED;
逃顶线: EMA(CLOSE/REF(HHV(CLOSE,7),50),1),COLOR007000 ,LINETHICK1 ;
AA:0,COLORBROWN;

操盘线   主图

MA5:MA(CLOSE,5),LINETHICK1,COLORFFFFFF;MA10:MA(CLOSE,10),LINETHICK1,COLOR00FFFF;
MA30:MA(CLOSE,30),LINETHICK1,COLORFF00FF;MA60:MA(CLOSE,60),LINETHICK1,COLOR0000FF;
MA120:MA(CLOSE,120),LINETHICK1,COLORFFFF00;
DRAWTEXT(CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),(LOW
*
0.99),'Ψ'),LINETHICK3,COLORF00FF0;
DRAWTEXT(CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2)),(HIGH
* 1.01),'◎'),LINETHICK3,COLORFFFFFF;
STICKLINE((EMA(CLOSE,2) >=
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),LOW,HIGH,0.1,0),COLOR0000FF;
STICKLINE((EMA(CLOSE,2)
>=
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,3,0),COLOR0000AA;
STICKLINE((EMA(CLOSE,2)
>=
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,2,0),COLOR0000CC;
STICKLINE((EMA(CLOSE,2)
<
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,2,0),COLORCCCC00;
STICKLINE((EMA(CLOSE,2)
<
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,3,0),COLORAAAA00;
STICKLINE((EMA(CLOSE,2)
<
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),LOW,HIGH,0.1,0),COLORFFFF00;
STICKLINE((CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42))
OR
CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2))),LOW,HIGH,0.1,0),COLOR00FFFF;
STICKLINE((CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42))
OR
CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2))),OPEN,CLOSE,3,0),COLOR00AAAA;
STICKLINE((CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42))
OR
CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2))),OPEN,CLOSE,2,0),COLOR00CCCC;


波段AA
A4:=MA(CLOSE,20);A5:=(CLOSE>MA(CLOSE,5));A6:=(MA(CLOSE,5)>MA(CLOSE,10));
A7:=(CLOSE>MA(CLOSE,10));A8:=(MA(CLOSE,5)>MA(CLOSE,20));A9:=(CLOSE>MA
(CLOSE,20));A10:=REF(A4,1);A11:=(A4
> A10);AVX:(((((IF(A5,10,(0 - 10)) + IF
(A6,10,(0 - 10))) + IF(A7,10,(0 -
10))) + IF(A8,10,(0 - 10))) + IF(A9,10,
(0 - 10))) + IF(A11,10,(0 -
10))),COLOR0000FF;AVX零轴:0,COLOR00FFFF;



能量信号
PW:=((VOL*(CLOSE-OPEN))/(CLOSE+OPEN));PW1:=EMA(((VOL*(CLOSE-OPEN))/(CLOSE+OPEN)),38);
ME:EMA(PW1,8),COLORSTICK;ME1:MA(ME,3),COLORYELLOW;ME2:MA(ME,10),COLORMAGENTA;

和谐一号
VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=LLV(LOW,34);
VAR3:=HHV(HIGH,34);
运钞专列: EMA((VAR1-VAR2)/(VAR3-VAR2)*100,13);
和谐一号:= EMA(0.667*REF(运钞专列,1)+0.333*运钞专列,2);
众赢一号:和谐一号;
X1:STICKLINE(CROSS(运钞专列,20) AND 和谐一号<运钞专列,运钞专列+19,运钞专列-10,4,1),COLORRED;
X2:DRAWTEXT(CROSS(运钞专列,20) AND 和谐一号<运钞专列,运钞专列-5,'众赢贵宾建仓 '),
LINETHICK3, COLORMAGENTA ;
金砖:STICKLINE(和谐一号<运钞专列,运钞专列,和谐一号,2.5,1),COLORRED;
瓦砾:STICKLINE(和谐一号>运钞专列,运钞专列,和谐一号,2.5,1),COLORBLUE;
选股:=CROSS(运钞专列,30) AND 和谐一号<运钞专列;
一叉:DRAWICON(CROSS(运钞专列,和谐一号),和谐一号,5);
二叉:DRAWICON(CROSS(和谐一号,运钞专列),和谐一号,15);



涨停操盘线
MA5:MA(CLOSE,5),LINETHICK1,COLORFFFFFF;MA10:MA(CLOSE,10),LINETHICK1,COLOR00FFFF;
MA30:MA(CLOSE,30),LINETHICK1,COLORFF00FF;MA60:MA(CLOSE,60),LINETHICK1,COLOR0000FF;
MA120:MA(CLOSE,120),LINETHICK1,COLORFFFF00;
DRAWTEXT(CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),(LOW
*
0.99),'Ψ'),LINETHICK3,COLORF00FF0;
DRAWTEXT(CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2)),(HIGH
* 1.01),'◎'),LINETHICK3,COLORFFFFFF;
STICKLINE((EMA(CLOSE,2) >=
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),LOW,HIGH,0.1,0),COLOR0000FF;
STICKLINE((EMA(CLOSE,2)
>=
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,3,0),COLOR0000AA;
STICKLINE((EMA(CLOSE,2)
>=
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,2,0),COLOR0000CC;
STICKLINE((EMA(CLOSE,2)
<
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,2,0),COLORCCCC00;
STICKLINE((EMA(CLOSE,2)
<
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),CLOSE,OPEN,3,0),COLORAAAA00;
STICKLINE((EMA(CLOSE,2)
<
EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),LOW,HIGH,0.1,0),COLORFFFF00;
STICKLINE((CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42))
OR
CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2))),LOW,HIGH,0.1,0),COLOR00FFFF;
STICKLINE((CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42))
OR
CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2))),OPEN,CLOSE,3,0),COLOR00AAAA;
STICKLINE((CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42))
OR
CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2))),OPEN,CLOSE,2,0),COLOR00CCCC;


涨停波段
A4:=MA(CLOSE,20);A5:=(CLOSE>MA(CLOSE,5));A6:=(MA(CLOSE,5)>MA(CLOSE,10));
A7:=(CLOSE>MA(CLOSE,10));A8:=(MA(CLOSE,5)>MA(CLOSE,20));A9:=(CLOSE>MA
(CLOSE,20));A10:=REF(A4,1);A11:=(A4
> A10);AVX:(((((IF(A5,10,(0 - 10)) + IF
(A6,10,(0 - 10))) + IF(A7,10,(0 -
10))) + IF(A8,10,(0 - 10))) + IF(A9,10,
(0 - 10))) + IF(A11,10,(0 -
10))),COLOR0000FF;AVX零轴:0,COLOR00FFFF;



涨停能量
PW:=((VOL*(CLOSE-OPEN))/(CLOSE+OPEN));PW1:=EMA(((VOL*(CLOSE-OPEN))/(CLOSE+OPEN)),38);
ME:EMA(PW1,8),COLORSTICK;ME1:MA(ME,3),COLORYELLOW;ME2:MA(ME,10),COLORMAGENTA;


起爆
VARR1:=(SUM(H,8)-SUM(L,8))/2;
RSVC:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KC:=SMA(RSVC,3,1);
DC:=SMA(KC,3,1);
JC:=3*KC-2*DC,COLORRED,LINETHICK1;
强势:=80,COLORMAGENTA,LINETHICK1;
平衡:=50,COLORRED,LINETHICK1;
弱势:=20,COLORBLUE,LINETHICK1;
RSV:=(CLOSE-LLV(LOW,40))/(HHV(HIGH,40)-LLV(LOW,40))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D1:=SMA(K,3,1),COLORYELLOW;
K1:=SMA(RSV,10,1),COLORWHITE;
D:=SMA(K1,10,1),COLORRED;
J:=3*K-2*D1,COLORFF00FF;
压力线:=REF(HHV(K,20),20),COLORYELLOW;

AA:=CROSS(JC,强势) AND CROSS(JC,平衡){ AND J>压力线} AND C/REF(C,1)>1.05;
BB:=CROSS(JC,平衡) AND CROSS(JC,20){ AND J>压力线} AND C/REF(C,1)>1.05;
起跳1:=CROSS(JC,强势) AND C>EXPMA(CLOSE,12) AND JC-REF(JC,1)>30 OR AA;
起跳2:=CROSS(JC,20) AND MA(C,5)>MA(C,30) AND C/REF(C,1)>1.014 OR BB;
起跳3:=CROSS(JC,平衡) AND C>EXPMA(C,12) AND C/REF(C,1)>1.014;
起跳4:=AA AND C>EXPMA(C,12) AND C/REF(C,1)>1.014;
起跳5:=BB AND C/REF(C,1)>1.014;
起跳6:=JC-REF(JC,1)>30 AND C/REF(C,1)>1.05{ AND J>压力线};
{红三兵:=CROSS(JC,80) AND REF(CROSS(JC,50),1) AND REF(CROSS(JC,20),2) AND C/REF(C,1)>1.014;}
AA OR BB OR 起跳6{ OR 红三兵};








黑马邦主图三

攻击线:MA(CLOSE,5),LINETHICK1;
操盘线:MA(CLOSE,10),LINETHICK1;
魔鬼线:MA(CLOSE,20),LINETHICK1;
生命线:MA(CLOSE,30),LINETHICK2;
决策线:MA(CLOSE,60),LINETHICK1;
趋势线:MA(CLOSE,120),LINETHICK2;
牛熊线:MA(CLOSE,250),LINETHICK3;
STICKLINE(C/REF(C,1)>1.07,O,C,2,0),COLORRED;
STICKLINE(REF(C,1)/C>1.07,O,C,2,0),COLOR00FF00;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,-1,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,-1,0),COLORBLUE;
STICKLINE(跌停,H,L,0,1),COLORBLUE;
大阳线:=IF((C-C2)*100/C2>=5,1,0)&&IF((C-C2)*100/C2<(10-0.01*100/C2),1,0) OR IF((C-O)*100/O>=5,1,0)&&IF((C-C2)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阳线,OPEN,CLOSE,-1,0),COLORRED;
STICKLINE(大阳线,H,L,0,1),COLORRED;
大阴线:=IF((C2-C)*100/C2>=5,1,0)&&IF((C2-C)*100/C2<(10-0.01*100/C2),1,0) OR IF((O-C)*100/O>=5,1,0)&&IF((C2-C)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阴线,OPEN,CLOSE,-1,0),COLORGREEN;
STICKLINE(大阴线,H,L,0,1),COLORGREEN;
TY:=C;
AA1:=REF(TY,10)=HHV(TY,2*10+1); BB1:=FILTER(AA1,10); C1:=BACKSET(BB1,10+1); HD:=FILTER(C1,10);
AA2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(AA2,10); CC2:=BACKSET(B2,10+1); LD:=FILTER(CC2,10);
前期高位:REF(H,BARSLAST(HD)),COLOR00FF00,POINTDOT,LINETHICK3;
前期低位:REF(L,BARSLAST(LD)),COLORFF00FF,POINTDOT,LINETHICK3;
DRAWICON(CROSS(MA(C,5),MA(C,24)) ,MA(C,5),1);
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
DRAWICON(W4 AND COUNT(W4,5)=1,LOW,3);
BB:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:=IF(MA(CLOSE,17)<BB,BB,MA(CLOSE,17));
操作线:=分水岭-(EMA(C,3)-分水岭);
DRAWTEXT(CROSS(分水岭,操作线),分水岭-0.5,'B');
MAJ2:=EMA(C,3);
MAJ5:=EMA(C,7);
MAJ13:=EMA(C,13);
MAJ34:=EMA(C,34);
MAJ55:=EMA(C,55);
YCXJ:=MAJ5>=REF(MAJ5,1);
H1:=MAX(MAX(MAJ5,MAJ13),MAJ34);
L1:=MIN(MIN(MAJ5,MAJ13),MAJ34);  
DRAWTEXT(H1<C AND O<L1 AND YCXJ AND MAJ2>REF(MAJ2,1),LOW*0.96,'◇');
{回归卖出图标}
RSV回归:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;
K回归:=SMA(RSV回归,3,1);
D回归:=SMA(K回归,3,1);
J回归:=3*K回归-2*D回归;
VAR回归3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}
VAR回归4:=EMA(EMA(EMA(VAR回归3,4),4),4);{可将3该为4,信号少点}
E回归:=(VAR回归4-REF(VAR回归4,1))/REF(VAR回归4,1)*100;
F回归:=MA(E回归,3)+0.03;
G回归:=MA(E回归,1);
DRAWICON(CROSS(F回归,G回归) AND J回归>65,HIGH*1.02,15),COLORGREEN;
{双底买入部分}
VAR10A:=IF(TROUGH(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11B:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR13C:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR15D:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR17E:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
买点1A:=VAR10A;  
买点2A:=(VAR11B+VAR13C+VAR15D+VAR17E);
买入:=COUNT(买点1A OR 买点2A,15)=2 AND (买点1A OR 买点2A) AND COUNT(C/REF(C,1)>1.07,15)>=1;
DRAWICON(买入,LOW*0.97,18);
{猎豹出击智能选股指标源码} VARR1:=(SUM(H,8)-SUM(L,8))/2;
RSVC:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KC:=SMA(RSVC,3,1);
DC:=SMA(KC,3,1);
JC:=3*KC-2*DC,COLORRED,LINETHICK1;
强势:=80,COLORMAGENTA,LINETHICK1;
平衡:=50,COLORRED,LINETHICK1;
弱势:=20,COLORBLUE,LINETHICK1;
RSV:=(CLOSE-LLV(LOW,40))/(HHV(HIGH,40)-LLV(LOW,40))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D1:=SMA(K,3,1),COLORYELLOW;
K1:=SMA(RSV,10,1),COLORWHITE;
D:=SMA(K1,10,1),COLORRED;
J:=3*K-2*D1,COLORFF00FF;
压力线:=REF(HHV(K,20),20),COLORYELLOW;
  AA:=CROSS(JC,强势) AND CROSS(JC,平衡){ AND J>压力线} AND C/REF(C,1)>1.05 AND REF(C,1)/REF(C,2)<1.059;
BB0412:=CROSS(JC,平衡) AND CROSS(JC,20){ AND J>压力线} AND C/REF(C,1)>1.05 AND REF(C,1)/REF(C,2)<1.059;
起跳1:=CROSS(JC,强势) AND C>EXPMA(CLOSE,12) AND JC-REF(JC,1)>30 OR AA;
起跳2:=CROSS(JC,20) AND MA(C,5)>MA(C,30) AND C/REF(C,1)>1.014 OR BB;
起跳3:=CROSS(JC,平衡) AND C>EXPMA(C,12) AND C/REF(C,1)>1.014;
起跳4:=AA AND C>EXPMA(C,12) AND C/REF(C,1)>1.014;
起跳5:=BB AND C/REF(C,1)>1.014;
起跳6:=JC-REF(JC,1)>30 AND C/REF(C,1)>1.05{ AND J>压力线} AND REF(C,1)/REF(C,2)<1.059; {红三兵:=CROSS(JC,80) AND REF(CROSS(JC,50),1) AND REF(CROSS(JC,20),2) AND C/REF(C,1)>1.014;}
DRAWICON(AA OR BB0412 OR 起跳6,L*0.98,11){ OR 红三兵};
AAA1:=MA(CLOSE,5);
AAA2:=MA(CLOSE,20);
AAA3:=MA(CLOSE,30);
A偏离度:=(CLOSE-HHV(HIGH,250))/HHV(HIGH,250)*100;
B偏离度:=(CLOSE-HHV(HIGH,120))/HHV(HIGH,120)*100;
C偏离度:=(LOW-MA(CLOSE,13))/MA(CLOSE,13)*100;
N日内13日线走向:=(MA(CLOSE,13)-REF(MA(CLOSE,13),5))/REF(MA(CLOSE,13),5)*100;
DRAWTEXT("KDJ.D">(REF("KDJ.D",1)+1) AND A偏离度= B偏离度 AND COUNT(AAA1>AAA2 AND AAA2>AAA3 ,2)=2 AND "KDJ.J">20 AND "MACD.MACD">0 AND C偏离度>-12  AND B偏离度-REF(B偏离度,1)>1 AND N日内13日线走向-C偏离度<12 AND B偏离度>(C偏离度-1.3),LOW*0.97,'吻'),COLORRED;
DRAWTEXT("KDJ.D">(REF("KDJ.D",1)+1) AND B偏离度>A偏离度 AND B偏离度>C偏离度,LOW*0.95,'飞吻'),COLORRED;



突破走强
VVOL:=VOL*240/FROMOPEN;
盘虚万:=VVOL/10000;
量万:=VOL/10000;
HD:=FILTER(BACKSET(FILTER(REF(C,10)=HHV(C,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(C,10)=LLV(C,2*10+1),10),10+1),10);
波峰:=IF(BARSLAST(HD)<BARSLAST(LD) AND NOT(HD),REF(C,BARSLAST(HD)),REF(C,BARSLAST(HD)));
突破波峰:=CROSS(C,波峰) AND 盘虚万>MA(量万,25) AND C/REF(C,1)>1.043;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
强势:=80;
弱势:=20;
涨幅:=C/REF(C,1)>=1.043;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
CROSS(J,强势) AND 涨幅 AND 突破波峰;



妞妞主图
DRAWBAND(MA(CLOSE,60),RGB(55,0,0),MA(CLOSE,120),RGB(0,91,0));
DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA;
MA60:MA(CLOSE,60),COLORGREEN,LINETHICK1;
MA120:MA(CLOSE,120),COLORLIRED,LINETHICK1;
MA240:MA(CLOSE,240),COLORBLUE;

DRAWICON(CROSS(MA10,MA20),MA20,1); {10日上穿20日做记号}
DRAWICON(CROSS(MA20,MA60),MA60,1); {20日上穿60日做记号}
DRAWICON(CROSS(MA20,MA120),MA120,1); {20日上穿60日做记号}
DRAWICON(CROSS(MA20,MA240),MA240,1);{20日上穿120日做记号}
DRAWICON(CROSS(MA60,MA120),MA60,1); {60日上穿120日做记号}
DRAWICON(CROSS(MA60,MA240),MA240,1); {60日上穿240日做记号}
DRAWICON(CROSS(MA120,MA240),MA240,1);{120日上穿240日做记号}

DRAWICON(CROSS(MA20,MA10),MA20,2); {10日下穿20日做记号}
DRAWICON(CROSS(MA60,MA20),MA60,2); {20日下穿60日做记号}
DRAWICON(CROSS(MA120,MA60),MA120,2); {60日下穿120日做记号};
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,'★抄底') ,LINETHICK2,COLORRED;

STICKLINE(C<0.905*REF(C,1),C,O,5,0),COLORWHITE;
STICKLINE(C>1.095*REF(C,1),C,O,5,0),COLORYELLOW;
DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.978,'★抄底') ,LINETHICK2,COLORRED;
GX:HHV(C,100),LINETHICK2;





妞妞副图
VAR1:=REF(CLOSE,2);
会员专用: SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100,COLORFFAA66;
VAR2:=REF(CLOSE,1);
VAR3:=SMA(MAX(CLOSE-VAR2,0),7,1)/SMA(ABS(CLOSE-VAR2),7,1)*100;
极品逃亡: IF(会员专用< REF(会员专用,1) AND 会员专用>79,会员专用,0);
DRAWTEXT(极品逃亡 ,70 ,'★<-极品逃亡'),COLORYELLOW,LINETHICK1;
DRAWTEXT(88>0 AND REF(O,1)/REF(C,1)>1.04 AND REF(L,1)<=688 AND O>REF(C,1)AND C<REF(O,1)AND C/O>=1.01,L-L*0.02,'★<--极品绝底初现'),LINETHICK1;
DRAWTEXT(C-O>=0 AND O/L>1.05 AND L<=LLV(L,20),L,'★<--极品绝底'),COLORBLUE, LINETHICK1;

Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
特殊会员专用:3*Q3-2*Q4,COLORWHITE,LINETHICK2;
Q8:=HHVBARS(HIGH, 50);  
Q10:=(CLOSE-REF(OPEN, Q8))/REF(OPEN, Q8)*100;
跨越:EMA(Q3, 3),COLORRED;
DRAWTEXT(CROSS(特殊会员专用, 8) AND Q10<-13,20,'*大底来'),COLORYELLOW,LINETHICK5;


VAR12:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
机构做空能量线: SMA(VAR12,3,1),COLORGREEN,LINETHICK2;
大底来: 0,POINTDOT;
大底: 0,POINTDOT;
DRAWTEXT(CROSS(跨越,机构做空能量线) ,大底+40,'进入强势区域'),COLORYELLOW,LINETHICK1;
DRAWTEXT(CROSS(特殊会员专用,跨越) ,大底+20,'进入拉升区域'),LINETHICK1;
DRAWTEXT(CROSS(跨越,特殊会员专用) ,大底+70,'注意调整'),COLORFFAA66,LINETHICK1;
●注意买入点: DRAWTEXT(REF(CROSS(机构做空能量线,跨越),25) AND 机构做空能量线>1.005*跨越,跨越,'●<-注意买入点'),COLORBLUE,LINETHICK1;
★逢低买入: DRAWTEXT(REF(CROSS(跨越,特殊会员专用),82) AND 跨越>1.3*特殊会员专用,特殊会员专用,'★<<-逢低买入'),LINETHICK1;


超级短线
VAR1:=(CLOSE*2+HIGH+LOW)/4;
SK:EMA(VAR1,13)-EMA(VAR1,21);
SD:EMA(SK,2);
K1:=SK>REF(SK,1);K12:=BACKSET(K1,2);
K2:=SK<REF(SK,1);K22:=BACKSET(K2,2);
DRAWLINE(K12,SK,K1,SK,0),COLORRED, LINETHICK1;
DRAWLINE(K22,SK,K2,SK,0),COLOR00FF00,LINETHICK1;
{K11:=SD>REF(SD,1);K121:=BACKSET(K11,2);
K21:=SD<REF(SD,1);K221:=BACKSET(K21,2);
DRAWLINE(K121,SD,K11,SD,0),COLORRED, LINETHICK1;
DRAWLINE(K221,SD,K21,SD,0),COLOR00FF00,LINETHICK1;}
能量1:IF(2*(SK-SD)*3.8>=0,2*(SK-SD)*3.8,0),COLORRED,LINESTICK;
STICKLINE(能量1>REF(能量1,1) AND 能量1>=0,能量1,0,1,0),COLORRED;
STICKLINE(能量1<REF(能量1,1) AND 能量1>=0,能量1,0,1,0),COLORYELLOW;
能量2:IF(2*(SK-SD)*3.8<0,2*(SK-SD)*3.8,0),COLOR00FF00,LINESTICK;
STICKLINE(能量2>REF(能量2,1),能量2,0,1,0),COLORYELLOW;
STICKLINE(能量2<REF(能量2,1),能量2,0,1,0),COLOR00FF00;
强弱分界:0;
DRAWICON(CROSS(SK,SD),SD*1.2,1);
DRAWICON(CROSS(SD,SK),SD*0.7,2);
能量:=2*(SK-SD)*3.8,COLORRED,LINESTICK;
{STICKLINE(能量>REF(能量,1) AND 能量>0,能量,0,2,0),COLORRED;
STICKLINE(能量<REF(能量,1) AND 能量>=0,能量,0,1,0),COLORYELLOW;
STICKLINE(能量>REF(能量,1) AND 能量<0,能量,0,1,0),COLORB00FF1;
STICKLINE(能量<REF(能量,1) AND 能量<0,能量,0,2,0),COLOR00FF00;};



短线出击
M1  1.00  1000.00  5.00
M2  1.00  1000.00  10.00
M3  1.00  1000.00  25
M4  1.00  1000.00  50
{猎豹出击二号主图}
STICKLINE(CLOSE>=REF(HHV(C,5),1) AND C>=O,C,O,3,1),COLORMAGENTA;
STICKLINE(CLOSE<=REF(LLV(O,5),1) AND C<REF(C,1),C,O,1,0),COLORBLUE;
加速:=IF(100*WINNER(CLOSE*0.95)>50 AND COST(85)<CLOSE AND
(EMA(EMA(CLOSE,9),9)-REF(EMA(EMA(CLOSE,9),9),1))/REF(EMA(EMA(CLOSE,9),9),1)*1000>0,
(EMA(EMA(CLOSE,9),9)-REF(EMA(EMA(CLOSE,9),9),1))/REF(EMA(EMA(CLOSE,9),9),1)*1000,0),COLORFF00FF,NODRAW;
STICKLINE(加速 AND C>O AND MA(CLOSE,3)>REF(MA(CLOSE,3),1),C,O,1,0),COLORMAGENTA;
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10),COLORRED, LINETHICK2;
跌:IF(MA(CLOSE,10)<=REF(MA(CLOSE,10),1),MA(CLOSE,10),DRAWNULL),COLORGREEN,LINETHICK2;
MA3:MA(CLOSE,25),COLORMAGENTA, LINETHICK2;
跌2:IF(MA(CLOSE,25)<=REF(MA(CLOSE,25),1),MA(CLOSE,25),DRAWNULL),COLORBLUE,LINETHICK2;
MA4:MA(CLOSE,50),COLORYELLOW;

买进价:=((C-REF(MA(C,6),1))/6+MA(C,6))*1.004;  
买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,1);   
STICKLINE(买进条件,O,C,0.5,0),COLORYELLOW;  
加码价:=((C-REF(MA(C,21),1))/21+MA(C,21))*1.004;  
加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);      
STICKLINE(加码条件,O,C,1.5,0),COLORYELLOW;
波峰:=HHVBARS(C,25);
进入短线强势区:=CROSS("KDJ".J,80) AND "MACD.DIF">"MACD.DEA" AND MA(C,5)>MA(C,30);
突破波峰:=CROSS(C,波峰) AND VOL>MA(VOL,25) AND C/REF(C,1)>1.0143;
DRAWICON(进入短线强势区 OR 突破波峰,O*0.95,1);
DRAWTEXT(突破波峰,L*0.870,'突破'),COLORMAGENTA;
TJ强于大盘:=C/REF(C,1)>INDEXC/REF(INDEXC,1);
DRAWICON("KDJ.J"-REF("KDJ.J",1)>30  AND C/REF(C,1)>1.043,L*0.90,5);
DRAWTEXT(突破波峰 AND TJ强于大盘,L*0.870,'突破'),COLORMAGENTA;
DRAWTEXT(CROSS("KDJ".J,"KDJ".D) AND MA(CLOSE,10)>MA(CLOSE,25),H*0.98,'金'),COLORYELLOW;

DRAWTEXT(C>MA(C,5) AND C>MA(C,10) AND MA(C,10)>REF(MA(C,10),1)
AND MA(C,10)>MA(C,24) AND REF(C,1)<REF(O,1) AND REF(C,1)>REF(C,2)
AND C>REF(H,1),REF(O,1),'黑阳'),COLORRED;
DRAWTEXT("KDJ.J"-REF("KDJ.J",1)>30  AND C/REF(C,1)>1.043 AND
"MACD.DEA">0,L*0.95,'起爆'),COLORRED;
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
ZHENCANG1:=BARSLAST(CROSS(GJTJ4,GJTJ1))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
ZHENCANG2:=BARSLAST(CROSS(GJTJ4,GJTJ2));
ZHENCANG3:=GJTJ3<GJTJ4 AND GJTJ2<GJTJ4;
ZHENCANG4:=BARSLAST(CROSS(GJTJ4,GJTJ3))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
ZHENCANG5:=GJTJ2<GJTJ3 AND GJTJ2<GJTJ4 AND GJTJ2<GJTJ1 AND GJTJ1=100;
ZCB1:=ZHENCANG1>0 AND REF(ZHENCANG1,1)=0 AND REF(ZHENCANG1,2)>0;
DRAWTEXT(ZHENCANG1 AND ZHENCANG2 AND ZHENCANG3 AND ZHENCANG4 AND ZHENCANG5,L-0.05,'震');

主图均线
MA5:MA(C,5),COLORYELLOW;
MA10:MA(CLOSE,10),COLORFF00FF;
MA30:MA(C,30),COLORRED,LINETHICK2;
跌:IF(MA(CLOSE,30)<=REF(MA(CLOSE,30),1),MA(CLOSE,30),DRAWNULL),COLORGREEN,LINETHICK2;
MA60:MA(CLOSE,60),COLORFFCC66;
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
BAIJIN1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
BAIJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
BAIJIN3:=GJTJ1>60 AND GJTJ4>70;
DRAWTEXT(BAIJIN1 AND BAIJIN2 AND BAIJIN3,L-0.02,'白金'),COLORWHITE;
HUANGJIN1:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;
HUANGJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
DRAWTEXT(HUANGJIN1 AND HUANGJIN2,L-0.03,'黄金'),COLORYELLOW;
XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5  AND GJTJ1>GJTJ4;
DRAWTEXT(COUNT(XG,3)=1 AND XG AND C>MA(C,20),L-0.02,'金三角'),COLORRED;
ZHENCANG1:=BARSLAST(CROSS(GJTJ4,GJTJ1))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
ZHENCANG2:=BARSLAST(CROSS(GJTJ4,GJTJ2));
ZHENCANG3:=GJTJ3<GJTJ4 AND GJTJ2<GJTJ4;
ZHENCANG4:=BARSLAST(CROSS(GJTJ4,GJTJ3))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
ZHENCANG5:=GJTJ2<GJTJ3 AND GJTJ2<GJTJ4 AND GJTJ2<GJTJ1 AND GJTJ1=100;
ZCB1:=ZHENCANG1>0 AND REF(ZHENCANG1,1)=0 AND REF(ZHENCANG1,2)>0;
DRAWTEXT(ZHENCANG1 AND ZHENCANG2 AND ZHENCANG3 AND ZHENCANG4 AND ZHENCANG5,L-0.05,'震仓启动');
AA:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BB:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA1:=AA AND BB;
AAA:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAA:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA2:=AA AND BB ;
AAAA:=BARSLAST(CROSS(97,GJTJ1))<=3 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAAA:=BARSLAST(CROSS(97,GJTJ2))<=3 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA3:=AAAA AND BAAA ;
BB1:=REF(AA1,1);
BB2:=REF(AA2,1);
BB3:=REF(AA3,1);
DD1:=GJTJ1=100 AND GJTJ2=100  AND AA1 ;
DD2:=GJTJ1=100 AND GJTJ2=100  AND AA2 ;
DD3:=GJTJ1=100 AND GJTJ2=100  AND AA3 ;
DRAWTEXT(DD1 OR DD2 OR DD3,L-0.02,'追涨'),COLORFF00FF;
AW:=BARSLAST(CROSS(95,GJTJ1))<=2;
BW:=BARSLAST(CROSS(95,GJTJ2))<=2;
EW:= GJTJ4<GJTJ1 AND GJTJ1<GJTJ2 AND GJTJ1<GJTJ3;
FW:=GJTJ2>50 AND GJTJ3>50;
GW:=GJTJ1=100 AND GJTJ2=100;
TXW:=COUNT(GW,2)=1;
DRAWTEXT(AW AND BW AND EW AND FW AND TXW,L-0.03,'起涨');
AQ:=GJTJ3=100;

BQ:=GJTJ4<90;
DRAWTEXT(COUNT(AQ,2) = 2 AND BQ,L-0.02,'波段前兆');



MACD色彩
获利盘:=WINNER(C)*100;
满盘获利:=获利盘>82;
DIF:EMA(CLOSE,12)-EMA(CLOSE,26),LINETHICK2;
DEA:EMA(DIF,9),COLORYELLOW,LINETHICK2;
MACD:(DIF-DEA)*2,COLORSTICK;
A1:=MACD<REF(MACD,1) AND MACD>0;
A2:=MACD<REF(MACD,1)/2 AND MACD<0;
STICKLINE(MACD>=0,MACD,0,1,1),COLORRED;
STICKLINE(满盘获利,MACD,0,1,1),COLORMAGENTA;
STICKLINE(A1,0,MACD,1,0),COLORGREEN;
STICKLINE(A2,0,MACD,1,0),COLORLIBLUE;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1,1),COLORLIRED;
STICKLINE(满盘获利 AND MACD>REF(MACD,1),0,MACD,1,1),COLORMAGENTA;



宝塔变异线
{成本:MAXCYC,COLORFF9900;}
趋势:MA(C,90),COLORRED;
MA14:MA(CLOSE,14);
码:COST(50),COLORYELLOW;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
多头:STICKLINE(DIFF>DEA,C,O,5,0),COLORRED;
STICKLINE(DIFF>DEA,H,L,0,0),COLORRED;
空头:STICKLINE(DIFF<=DEA,C,O,5,0),COLORGRAY;
STICKLINE(DIFF<=DEA,H,L,0,0),COLORGRAY;
DRAWTEXT(CROSS(DIFF,DEA),L-0.2,'买入'),COLORWHITE;                  

DIFF1:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA1:=EMA(DIFF1,9);
多头1:STICKLINE(DIFF1>DEA1,C,O,5,0),COLORRED;
STICKLINE(DIFF>DEA1,H,L,0,0),COLORRED;
空头1:STICKLINE(DIFF1<=DEA1,C,O,5,0),COLORGRAY;
STICKLINE(DIFF1<=DEA1,H,L,0,0),COLORGRAY;
DRAWTEXT(CROSS(DIFF1,DEA1),L-0.2,'买入'),COLORWHITE;


主力能量线
换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:(主力-均量),NODRAW;
大户能量:(大户-均量),NODRAW;
中户能量:(中户-均量),NODRAW;
散户能量:(散户-均量),NODRAW;

回:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),6,6+主力能量,1,0),COLORRED;
复:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),6,6+主力能量,1,0),COLORYELLOW;
者:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),6,6+主力能量,1,0),COLORGREEN;
用:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),6,6+主力能量,1,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,6,6),'主力'),COLORRED;

主力线:6,COLORRED;
需:STICKLINE(大户能量>=0 AND 大户能量>=REF(大户能量,1),4,4+大户能量,1,0),COLORRED;
要:STICKLINE(大户能量>=0 AND 大户能量< REF(大户能量,1),4,4+大户能量,1,0),COLORYELLOW;
回1:STICKLINE(大户能量<0 AND 大户能量>=REF(大户能量,1),4,4+大户能量,1,0),COLORGREEN;
复1:STICKLINE(大户能量<0 AND 大户能量< REF(大户能量,1),4,4+大户能量,1,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(大户能量>=0,4,4),'大户'),COLORYELLOW;
大户线:4,COLORYELLOW;

加1:STICKLINE(中户能量>=0 AND 中户能量>=REF(中户能量,1),2,2+中户能量,1,0),COLORRED;
分1:STICKLINE(中户能量>=0 AND 中户能量< REF(中户能量,1),2,2+中户能量,1,0),COLORYELLOW;
者1:STICKLINE(中户能量<0 AND 中户能量>=REF(中户能量,1),2,2+中户能量,1,0),COLORGREEN;
好:STICKLINE(中户能量<0 AND 中户能量< REF(中户能量,1),2,2+中户能量,1,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(中户能量>=0,2,2),'中户'),COLORMAGENTA;
中户线:2,COLORMAGENTA;

{加2:STICKLINE(散户能量>=0 AND 散户能量>=REF(散户能量,1),0,散户能量,1,0),COLORRED;
分2:STICKLINE(散户能量>=0 AND 散户能量< REF(散户能量,1),0,散户能量,1,0),COLORYELLOW;
欢:STICKLINE(散户能量<0 AND 散户能量>=REF(散户能量,1),0,散户能量,1,0),COLORGREEN;
迎:STICKLINE(散户能量<0 AND 散户能量< REF(散户能量,1),0,散户能量,1,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(散户能量>=0,0.3,0.3),'散户'),COLORWHITE;}
散户线:0,COLORWHITE;

B:=ZIG(3,50/5)*1;
G:=MA(B,2);
D:=CROSS(B,G)*10;
W:=CROSS(G,B)*10;
DRAWTEXT(W=10,4,'卖' ),COLORWHITE;
DRAWTEXT(D=10,8,'买'),COLOR00FFAA,LINETHICK3,STICK;




起爆点
VARR1:=(SUM(H,8)-SUM(L,8))/2;
RSVC:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KC:=SMA(RSVC,3,1);
DC:=SMA(KC,3,1);
JC:=3*KC-2*DC,COLORRED,LINETHICK1;
强势:=80,COLORMAGENTA,LINETHICK1;
平衡:=50,COLORRED,LINETHICK1;
弱势:=20,COLORBLUE,LINETHICK1;
RSV:=(CLOSE-LLV(LOW,40))/(HHV(HIGH,40)-LLV(LOW,40))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D1:=SMA(K,3,1),COLORYELLOW;
K1:=SMA(RSV,10,1),COLORWHITE;
D:=SMA(K1,10,1),COLORRED;
J:=3*K-2*D1,COLORFF00FF;
压力线:=REF(HHV(K,20),20),COLORYELLOW;

AA:=CROSS(JC,强势) AND CROSS(JC,平衡){ AND J>压力线} AND C/REF(C,1)>1.05;
BB:=CROSS(JC,平衡) AND CROSS(JC,20){ AND J>压力线} AND C/REF(C,1)>1.05;
起跳1:=CROSS(JC,强势) AND C>EXPMA(CLOSE,12) AND JC-REF(JC,1)>30 OR AA;
起跳2:=CROSS(JC,20) AND MA(C,5)>MA(C,30) AND C/REF(C,1)>1.014 OR BB;
起跳3:=CROSS(JC,平衡) AND C>EXPMA(C,12) AND C/REF(C,1)>1.014;
起跳4:=AA AND C>EXPMA(C,12) AND C/REF(C,1)>1.014;
起跳5:=BB AND C/REF(C,1)>1.014;
起跳6:=JC-REF(JC,1)>30 AND C/REF(C,1)>1.05{ AND J>压力线};
{红三兵:=CROSS(JC,80) AND REF(CROSS(JC,50),1) AND REF(CROSS(JC,20),2) AND C/REF(C,1)>1.014;}
AA OR BB OR 起跳6{ OR 红三兵};




黄金柱主图
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA;
MA60:=MA(CLOSE,60),COLORGREEN;
MA120:=MA(CLOSE,120),COLORLIMAGENTA;
MA240:=MA(CLOSE,240),COLORBLUE,NODRAW;
VOL5:=MA(VOL,5),COLORWHITE;
VOL10:=MA(VOL,10),COLORYELLOW;
VOL40:=MA(VOL,40),COLORFF00FF ;
量托:=VOL5>=VOL40 AND CROSS(VOL10,VOL40) AND REF(VOL10,1)<REF(VOL40,1);
DRAWTEXT(量托,L-0.012,'量托'),COLORWHITE;
AA1:=BARSLAST(MA60>MA20 AND (MA20=MA10 OR MA20>MA10));
BB1:=REF(COUNT(C<MA60,AA1)=AA1,1);
CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB AND CC1,COLOR00FF00;
DRAWTEXT(芙蓉出水,H+0.12,'芙蓉出水'),COLORFF00FF;
STICKLINE(芙蓉出水,H,L,0.5,1),COLORFF00FF;
STICKLINE(芙蓉出水,O,C,3,1),LINETHICK2,COLORFF00FF;
MA1:=MA(CLOSE,14);
MA2:=MA(CLOSE,25);
MA3:=MA(CLOSE,99);
ZJ:=AMOUNT/10000;{资金}
TM:=V-MA(V,10);{量填满}
一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ;
DRAWTEXT(一穿三,L-0.012,'穿'),COLORFF00FF;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
前期高位:REF(C,BARSLAST(HD)),COLOR00FF00,POINTDOT;
STICKLINE(C,前期高位,前期高位,8,0),COLORRED;
高点:(C/REF(C,BARSLAST(HD))-1)*100,NODRAW;
STICKLINE((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667,H,C,0.8,0),COLORBLUE;
三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));
三日价涨A:=C>=REF(C,1);
三日价涨B:=C<REF(C,1);
三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);
TIM:=IF(DATE<1140214,1,0);
缩倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;
百日低量:=(VOL=LLV(VOL,100))*TIM;
倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;
四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;
四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;
前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;
倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
黄金柱:=倍量黄金柱 OR 高量黄金柱;
次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;


准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;
准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;
准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;
倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
将军柱:=倍量将军柱 OR 高量将军柱;
次倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次将军柱:=次倍量将军柱 OR 次高量将军柱;
准倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立;
准高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立;
准将军柱:=准倍量将军柱 OR 准高量将军柱;
BACKSET100:=BACKSET(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱 OR 准将军柱,4);
FILTER100:=FILTER(BACKSET100,3),NODRAW;
BACKSET101:=BACKSET(黄金柱,4);
FILTER101:=FILTER(BACKSET101,3);
BACKSET102:=BACKSET(次黄金柱,4);
FILTER102:=FILTER(BACKSET102,3);
BACKSET103:=BACKSET(准黄金柱,4);
FILTER103:=FILTER(BACKSET103,3);
BACKSET104:=BACKSET(将军柱,4);
FILTER104:=FILTER(BACKSET104,3);
BACKSET105:=BACKSET(次将军柱,4);
FILTER105:=FILTER(BACKSET105,3);
BACKSET106:=BACKSET(准将军柱,4);
FILTER106:=FILTER(BACKSET106,3);
黄金线下影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=REF(L,3);
黄金线实体下端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=MIN(REF(C,3),REF(O,3)) AND MIN(MIN(L,REF(L,1)),REF(L,2))>REF(L,3),LINETHICK0;
黄金线上影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(H,3);
黄金线实体上端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<REF(H,3);
黄金线实体中间:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3));
黄金线实体中间1:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,2)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间2:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,1)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间3:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND L=MIN(MIN(L,REF(L,1)),REF(L,2));
BACKSET201:=BACKSET(黄金线下影线,4);

FILTER201:=FILTER(BACKSET201,3),NODRAW;
BACKSET202:=BACKSET(黄金线实体下端,4);
FILTER202:=FILTER(BACKSET202,3),NODRAW;
BACKSET203:=BACKSET(黄金线上影线,4);
FILTER203:=FILTER(BACKSET203,3),NODRAW;
BACKSET204:=BACKSET(黄金线实体上端,4);
FILTER204:=FILTER(BACKSET204,3),NODRAW;
BACKSET205:=BACKSET(黄金线实体中间,4);
FILTER205:=FILTER(BACKSET205,3),NODRAW;
BACKSET2051:=BACKSET(黄金线实体中间1,4);
FILTER2051:=FILTER(BACKSET2051,3),NODRAW;
BACKSET2052:=BACKSET(黄金线实体中间2,4);
FILTER2052:=FILTER(BACKSET2052,3),NODRAW;
BACKSET2053:=BACKSET(黄金线实体中间3,4);
FILTER2053:=FILTER(BACKSET2053,3),NODRAW;
BT201:=IF(BARSLAST(FILTER201)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER201));
BT202:=IF(BARSLAST(FILTER202)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER202));
BT203:=IF(BARSLAST(FILTER203)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER203));
BT204:=IF(BARSLAST(FILTER204)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER204));
BT205:=IF(BARSLAST(FILTER205)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER205));
BT2051:=IF(BARSLAST(FILTER2051)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2051));
BT2052:=IF(BARSLAST(FILTER2052)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2052));
BT2053:=IF(BARSLAST(FILTER2053)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2053));
最近黄金线:=MIN(MIN(MIN(MIN(MIN(MIN(BT201,BT202),BT203),BT204),BT2051),BT2052),BT2053);
DAY1:=SUMBARS(FILTER100,1),NODRAW;
HJX1_1:=IF(SUMBARS(FILTER201,1)=DAY1,IF(DAY1=1,LOW,REF(LOW,DAY1-1)),0),NODRAW;
HJX1_2:=IF(SUMBARS(FILTER202,1)=DAY1,IF(DAY1=1,MIN(C,O),MIN(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_3:=IF(SUMBARS(FILTER203,1)=DAY1,IF(DAY1=1,HIGH,REF(HIGH,DAY1-1)),0),NODRAW;
HJX1_4:=IF(SUMBARS(FILTER204,1)=DAY1,IF(DAY1=1,MAX(C,O),MAX(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_51:=IF(SUMBARS(FILTER2051,1)=DAY1,IF(DAY1=2,LOW,IF(DAY1<2,DRAWNULL,REF(LOW,DAY1-2))),0),NODRAW;
HJX1_52:=IF(SUMBARS(FILTER2052,1)=DAY1,IF(DAY1=3,LOW,IF(DAY1<3,DRAWNULL,REF(LOW,DAY1-3))),0),NODRAW;
HJX1_53:=IF(SUMBARS(FILTER2053,1)=DAY1,IF(DAY1=4,LOW,IF(DAY1<4,DRAWNULL,REF(LOW,DAY1-4))),0),NODRAW;
黄金线:HJX1_1+HJX1_2+HJX1_3+HJX1_4+HJX1_51+HJX1_52+HJX1_53,COLORYELLOW,NODRAW;
立桩量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);
立桩量三日突破:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
立桩量三日不破:=BARSLAST(立桩量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));
BACKSET300:=BACKSET(立桩量三日不破,4);
BACKSET301:=BACKSET(立桩量三日突破,4);
立桩量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立桩量;
DRAWTEXT(立桩量成立,HIGH*1.01,'↙立桩量'),COLORRED;
DRAWTEXT(FILTER101,LOW*0.986,'↖黄金柱'),COLORYELLOW;
DRAWTEXT(FILTER102,LOW*0.986,'↖次黄金柱'),COLORYELLOW;
DRAWTEXT(FILTER104,LOW*0.986,'↖将军柱'),COLORYELLOW;



超赢决策
RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
VARR1:=(SUM(H,8)-SUM(L,8))/2;
RSVC:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
白马:=SMA(RSVC,3,1);
DC:=SMA(白马,3,1),LINETHICK1;
主升线:3*白马-2*DC,COLORYELLOW,LINETHICK1;
短K:=SMA(RSV,3,1),COLORBLUE;
支撑线:SMA(短K,3,1),COLORMAGENTA,LINETHICK1;
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
多方趋势线:SMA(RSV1,5,1),COLORRED,LINETHICK2;
空方趋势线:SMA(多方趋势线,10,1),COLOR66CC33,LINETHICK1;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:= 2*(DIFF-DEA), COLORSTICK;
STICKLINE(多方趋势线>空方趋势线,多方趋势线,空方趋势线,1,1),COLORRED;
STICKLINE(多方趋势线<=空方趋势线,多方趋势线,空方趋势线,1,1),COLOR669933;
强势区:80,COLORYELLOW,LINETHICK1;
平衡:=50,COLORRED,LINETHICK1;
弱势区:20,COLORGREEN,LINETHICK1;
STICKLINE(主升线>=80,80,(主升线*0.98),1,1),COLORYELLOW;
STICKLINE(主升线<20,20,主升线+1,1,1),COLORGREEN;
主力线:=WINNER(C)*100,COLORRED,LINETHICK2;
HM:=SMA(RSV,3,1),COLORWHITE;
D1:=SMA(HM,3,1),COLORYELLOW;
K1:=SMA(RSV,10,1),COLORWHITE;
D:=SMA(K1,10,1),COLORRED;
TT:=3*HM-2*D1,COLORYELLOW;
压力线:=REF(HHV(HM,20),20),COLORYELLOW;
量能饱和:=(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26)*100,COLORLIMAGENTA,NODRAW;
AA:=CROSS(主升线,强势区) AND CROSS(主升线,平衡) AND C>EXPMA(C,12) AND C/REF(C,1)>1.04;
BB:=CROSS(主升线,平衡) AND CROSS(主升线,20);
CC:=主升线-REF(主升线,1)>30 AND C/REF(C,1)>1.05;
DD:=CROSS(TT,HM) AND TT>压力线 AND 主升线>REF(主升线,1) AND DYNAINFO(7)/REF(C,1)>=1.045;
DRAWICON(CROSS(主升线,强势区) AND C>EXPMA(CLOSE,12) AND CC OR AA{ OR DD}
OR 量能饱和=100 AND CROSS(主升线,强势区) OR CROSS(主升线,强势区)
AND EXPMA(CLOSE,12)>EXPMA(CLOSE,50) AND "MACD.MACD">REF("MACD.MACD",1),75,1);
DRAWICON(BB,40,1);
工作线:=EXPMA(CLOSE,12);
生命线:=EXPMA(CLOSE,50);
走出短线强势区:=CROSS(78,"KDJ.J") AND 工作线>生命线 AND "MACD.DIF">"MACD.DEA" AND MA(C,5)>MA(C,30) AND 多方趋势线/空方趋势线<=1.09;
强势低吸:=工作线>生命线 AND CROSS("KDJ.J",20) AND 多方趋势线>=空方趋势线 AND 多方趋势线/空方趋势线>REF(多方趋势线,1)/REF(空方趋势线,1)  AND (多方趋势线/空方趋势线)/(REF(多方趋势线,2)/REF(空方趋势线,2))>=0.995;
DRAWICON(走出短线强势区,85,2);
抬头:="KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)<REF("KDJ.J",2)
AND REF("KDJ.J",1)>REF("KDJ.D",1) AND "MACD.MACD">0;
金叉:=CROSS("KDJ.J","KDJ.D") AND MA(C,10)>MA(C,25)
AND MA(C,25)>REF(MA(C,25),1) AND "MACD.MACD">0;
DRAWICON( 强势低吸,15,1);
{DRAWICON(AA OR BB,50,1);}
DRAWICON(CC OR AA,25,1);
DRAWTEXT(强势低吸,15,'低吸'),COLORRED;
DRAWTEXT(走出短线强势区,95,'  抛'),COLORGREEN;
DRAWTEXT(DD AND 多方趋势线/空方趋势线>0.93 AND (MACD-REF(MACD,1))>0 AND 多方趋势线/空方趋势线>REF(多方趋势线,1)/REF(空方趋势线,1) AND (多方趋势线/空方趋势线)/(REF(多方趋势线,2)/REF(空方趋势线,2))>=0.975 OR 量能饱和=100 AND CROSS(主升线,82)  AND 多方趋势线/空方趋势线>0.93 AND (MACD-REF(MACD,1))>0 AND 多方趋势线/空方趋势线>REF(多方趋势线,1)/REF(空方趋势线,1) AND (多方趋势线/空方趋势线)/(REF(多方趋势线,2)/REF(空方趋势线,2))>=0.975 AND DYNAINFO(7)/REF(C,1)>=1.043 OR CROSS(主升线,82)
AND EXPMA(CLOSE,12)>EXPMA(CLOSE,50) AND 多方趋势线/空方趋势线>0.93 AND (MACD-REF(MACD,1))>0 AND 多方趋势线/空方趋势线>REF(多方趋势线,1)/REF(空方趋势线,1) AND (多方趋势线/空方趋势线)/(REF(多方趋势线,2)/REF(空方趋势线,2))>=0.975 AND DYNAINFO(7)/REF(C,1)>=1.043,45,'买 '),COLORRED;



亲吻指标
A1:=MA(CLOSE,5);
A2:=MA(CLOSE,20);
A3:=MA(CLOSE,30);
第一吻线:(LOW-MA(CLOSE,13))/MA(CLOSE,13)*100,COLORMAGENTA,LINETHICK2;
第二吻线:(CLOSE-HHV(HIGH,120))/HHV(HIGH,120)*100,LINETHICK2;
第三吻线:(CLOSE-HHV(HIGH,250))/HHV(HIGH,250)*100,COLORWHITE;
持股线:=(MA(CLOSE,13)-REF(MA(CLOSE,13),5))/REF(MA(CLOSE,13),5)*100,LINETHICK2;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV1:=MA(OBV,10);
DRAWICON("KDJ.D">(REF("KDJ.D",1)+0.5) AND 持股线+第一吻线<5.6 AND  持股线-第一吻线<5.6 AND OBV>OBV1 AND OBV1>REF(OBV1,1) AND (CROSS(第二吻线+3.05,第一吻线)),L,9);
DRAWICON("KDJ.D">(REF("KDJ.D",1)+1) AND 持股线+第一吻线<5.6 AND  持股线-第一吻线<5.6 AND OBV>OBV1 AND OBV1>REF(OBV1,1) AND (CROSS(第二吻线+1,第一吻线)),L,9);
DRAWTEXT("KDJ.D">(REF("KDJ.D",1)+1) AND 第三吻线= 第二吻线 AND COUNT(A1>A2 AND A2>A3 ,2)=2 AND "KDJ.J">20 AND "MACD.MACD">0 AND 第一吻线>-9  AND 第二吻线-REF(第二吻线,1)>1 AND 持股线-第一吻线<13 AND 第二吻线>(第一吻线-1.3),-5,'买 '),COLORRED;
发表于 2011-11-27 09:58 | 显示全部楼层

评分

参与人数 2威望 +4 庄币 +2 收起 理由
凤凰九 + 2 + 2 好马,我也来牵一匹
ヽoo飛魚ツ + 2 很给力!

查看全部评分

回复 支持 1 反对 0

使用道具 举报

发表于 2011-10-20 00:45 | 显示全部楼层
我来支持你一个楼主多多赚RMB
回复 支持 反对

使用道具 举报

发表于 2011-10-20 06:53 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-10-20 07:56 | 显示全部楼层
ddddddddddddddddddddddddddddddd
回复 支持 反对

使用道具 举报

发表于 2011-10-22 22:28 | 显示全部楼层
谢谢分享!!!
回复 支持 反对

使用道具 举报

发表于 2011-10-22 23:34 | 显示全部楼层
我晕,这么多匹马呀,楼主真太厉害了
回复 支持 反对

使用道具 举报

发表于 2011-10-23 21:33 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-10-24 15:26 | 显示全部楼层
谢谢分享!!!
回复 支持 反对

使用道具 举报

发表于 2011-10-24 17:15 | 显示全部楼层
RR:=(HHV(EMA(EMA(C,5)-EMA(C,13),1),3)+ABS(LLV(EMA(EMA(C,5)-EMA(C,13),1),3)))/2;
RR/4*4,COLOR0000FF;
RR/4*3,COLORAAAA00;
RR/4*2,COLOR00AA00;
RR/4*1,COLOR00AAAA;
0000,POINTDOT,COLORAAAAAA;
-RR/4*1,COLOR00AAAA;
-RR/4*2,COLOR00AA00;
-RR/4*3,COLORAAAA00;
-RR/4*4,COLOR0000FF;
R:=(HHV(EMA(EMA(C,5)-EMA(C,13),1),100)+ABS(LLV(EMA(EMA(C,5)-EMA(C,13),1),100)))/2;
R/4*4,COLOR0000AA;
R/4*3,COLORAAAA00;
R/4*2,POINTDOT,COLOR00AA00;
R/4*1,POINTDOT,COLOR00AAAA;
0000,POINTDOT,COLORAAAAAA;
-R/4*1,POINTDOT,COLOR00AAAA;
-R/4*2,POINTDOT,COLOR00AA00;
-R/4*3,COLORAAAA00;
-R/4*4,COLOR0000AA;
OOOOO:EMA(EMA(C,5)-EMA(C,13),1),LINETHICK2,COLORYELLOW;
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-11-20 13:48 , Processed in 0.101503 second(s), 17 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表