老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

关闭
关闭
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 11374|回复: 20

[飞狐] 缠论辅助指标-MACD面积

[复制链接]
发表于 2011-4-13 08:23 | 显示全部楼层 |阅读模式
//参数N:=10
DRAWGBK(c>0,colorrgb(0,0,0),colorrgb(0,0,0),1);
cs:=0.01;
macd:1.5*N/10*slOPE(c,N),colorstick;
//柱线//
STICKLINE(MACD<=REF(MACD,1)AND MACD>0,0,MACD,3,0 ),COLOR00AAFF;
STICKLINE(macd<=REF(macd,1)AND macd>0,0,macd,1.8,0 ),COLOR00BBFF;
STICKLINE(macd<=REF(macd,1)AND macd>0,0,macd,1.3,0 ),COLOR00CCFF;
STICKLINE(macd<=REF(macd,1)AND macd>0,0,macd,1.2,0 ),COLOR00DDFF;
STICKLINE(macd<=REF(macd,1)AND macd>0,0,macd,1,0 ),COLOR00EEFF;
STICKLINE(macd<=REF(macd,1)AND macd>0,0,macd,0.5,0 ),COLOR00FFFF;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,3.4,0 ),COLOR0000AA;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,3.2,0),COLOR0011BB;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,3,0),COLOR0022CC;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,2,0),COLOR0033DD;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,1,0),COLOR0044EE;
STICKLINE(macd>REF(macd,1)AND macd>0,0,macd,0.5,0),COLOR0055FF;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,3.4,0),COLORAA00BB;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,3.2,0),COLORBB11BB;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,3,0),COLORCC22BB;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,2,0 ),COLORDD33BB;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,1,0),COLOREE44BB;
STICKLINE(macd>REF(macd,1)AND macd<=0,0,macd,0.5,0 ),COLORFF55BB;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,3,0 ),COLORFF7700;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,1.5 ,0 ),COLORFF8811;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,1.2,0 ),COLORFFAA22;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,1.0 ,0 ),COLORFFBB33;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,0.8 ,0 ),COLORFFDD44;
STICKLINE(macd<=REF(macd,1)AND macd<=0,0,macd,0.5 ,0 ),COLORFFFF55;
BV:=SUM(MACD/cs,0);
BA:=IF(MAX(BV,REF(BV,2))<REF(BV,1) OR MIN(BV,REF(BV,2))>REF(BV,1),1,0);
BC:=BARSLAST(BA)+1;
SMACD:=BV-REF(BV,BC);
var3:=if(macd>0,HHV(abs(macd),bc),LLV(macd,bc));
var4:=(macd)/20;{图形比例缩小1/20,可修改}
var5:=SMACD;
//背离线//
DIFF : EMA(CLOSE,N*12/10) - EMA(CLOSE,N*26/10);
DEA :  EMA(DIFF,N*9/10);
drawnumber(ref(var4,1)>0 and var4<=0 ,ref(var3,1),ref(var5,1),0);
drawnumber(ref(var4,1)<0 and var4>=0 ,ref(var3,1),ref(abs(var5),1),0),coloryellow;
drawnumber(islastbar and var4<0,ref(var3,1),abs(var5),0),align2,colorred{,pxup40};
drawnumber(islastbar and var4>0,ref(var3,1),var5,0),align2,colorgreen{,pxdn100};

评分

参与人数 1威望 +3 收起 理由
mlc666 + 3 无图无真相

查看全部评分

发表于 2011-4-13 08:24 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-4-13 09:43 | 显示全部楼层
钱庄有你而精彩
回复 支持 反对

使用道具 举报

发表于 2011-4-13 09:46 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-4-13 09:59 | 显示全部楼层
我也来顶起来,发啊
回复 支持 反对

使用道具 举报

发表于 2011-4-13 10:56 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-4-13 12:10 | 显示全部楼层
谢谢分享
回复 支持 反对

使用道具 举报

发表于 2011-4-13 12:52 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-4-16 10:36 | 显示全部楼层
谢谢楼主分享
回复 支持 反对

使用道具 举报

发表于 2011-4-23 20:54 | 显示全部楼层
有图才精彩
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 1239457655 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2018-8-15 00:11 , Processed in 0.088144 second(s), 20 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表