老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 155868|回复: 1082

[通达信] MACD KDJ RSI 背离狙击买卖点 (有图,有源码)

  [复制链接]
发表于 2011-3-28 15:53 | 显示全部楼层 |阅读模式
本帖最后由 kikaku 于 2011-3-28 15:56 编辑

网上看见的通达信公式,分享给大家研究下,部分地方有待优化。

源码:
DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA),COLORSTICK;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
游客,如果您要查看本帖隐藏内容请回复
STICKLINE(D1>0,0.1,0,2,0),COLOR00FF00;
STICKLINE(D2>0,0.1,0,2,0),COLORFFCC66;
STICKLINE(D3>0,0.1,0,2,0),COLORWHITE;




本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x

评分

参与人数 3威望 +8 收起 理由
mlc666 + 5 有图有真相
jjyywolf + 1 hao
wwycf + 2 不错,呵呵

查看全部评分

发表于 2011-3-28 15:55 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-3-28 15:56 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-3-28 16:24 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-3-28 16:36 | 显示全部楼层
支持楼主分享,谢谢,辛苦了
回复 支持 反对

使用道具 举报

发表于 2011-3-28 19:29 | 显示全部楼层
谢谢啦,我下载来验证一下
回复 支持 反对

使用道具 举报

发表于 2011-3-28 19:31 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-3-28 19:38 | 显示全部楼层
学习一下

回复 支持 反对

使用道具 举报

发表于 2011-3-28 19:39 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2011-3-28 19:40 | 显示全部楼层
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2018-1-16 17:28 , Processed in 0.157166 second(s), 20 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表