老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
楼主: 短线精英

[通达信] KDJ、MACD金叉共振(两合一指标 附带选股)

  [复制链接]
发表于 2011-3-17 18:47 | 显示全部楼层
kanknazaishuo
回复 支持 反对

使用道具 举报

发表于 2011-3-17 20:39 | 显示全部楼层
支持,支持
回复 支持 反对

使用道具 举报

发表于 2011-3-17 21:36 | 显示全部楼层
A:=(3*C+H+L+O)/6;
XJ:=(A+0.618*REF(A,1)+0.382*REF(A,2)+0.236*REF(A,3)+0.146*REF(A,4))/2.382;
YCZXH:=(MA(HHV(A,2),5)+MA(HHV(A,2),13)+MA(HHV(A,2),21)+MA(HHV(A,2),32))/4;
YCZXL:=(MA(LLV(A,2),5)+MA(LLV(A,2),13)+MA(LLV(A,2),21)+MA(LLV(A,2),32))/4;
SMH:EMA(YCZXH,21),COLOR004000;
SML:EMA(YCZXL,21),COLOR004000;
SMJ:(SML+SMH)/2,COLOR004000;

PJ:=(10*A+9*REF(A,1)+8*REF(A,2)+7*REF(A,3)+6*REF(A,4)+5*REF(A,5)+4*REF(A,6)+3*REF(A,7)+2*REF(A,8)+REF(A,9))/55;
A1:=EMA(PJ,3),COLOR004000;A2:=EMA(PJ,5),COLOR004000;
A3:=EMA(PJ,7),COLOR004000;A4:=EMA(PJ,9),COLOR004000;
A5:=EMA(PJ,11),COLOR004000;

LX:=REF(XJ,1);
ZD:=(SMA(MAX(XJ-LX,0),5,1)/SMA(ABS(XJ-LX),5,1))*100;
KX1:=(CLOSE>=OPEN) AND ZD>=50;
KX2:=(CLOSE<OPEN) AND ZD>=50;
KX3:=(CLOSE>=OPEN) AND ZD<50;
KX4:=(CLOSE<OPEN) AND ZD<50;


IF(A5<REF(A5,1),A5,DRAWNULL),COLOR820000,LINETHICK2;
IF(A5>REF(A5,1),A5,DRAWNULL),COLOR00005B,LINETHICK2;
IF(A4<REF(A4,1),A4,DRAWNULL),COLOR8C0000,LINETHICK1;
IF(A4>REF(A4,1),A4,DRAWNULL),COLOR000055,LINETHICK1;
IF(A3<REF(A3,1),A3,DRAWNULL),COLOR9B0000,LINETHICK1;
IF(A3>REF(A3,1),A3,DRAWNULL),COLOR00006C,LINETHICK1;
IF(A2<REF(A2,1),A2,DRAWNULL),COLORBB0000,LINETHICK1;
IF(A2>REF(A2,1),A2,DRAWNULL),COLOR00007D,LINETHICK1;
IF(A1<REF(A1,1),A1,DRAWNULL),COLORCC0000,LINETHICK1;
IF(A1>REF(A1,1),A1,DRAWNULL),COLOR00009B,LINETHICK1;


本帖隐藏的内容
STICKLINE(KX1,C,O,4,1),COLOR4440FF;
STICKLINE(KX1,C,H,0.5,1),COLOR4440FF;
STICKLINE(KX1,O,L,0.5,1),COLOR4440FF;
STICKLINE(KX2,C,O,4,0),COLOR4440FF;
STICKLINE(KX2,O,H,0.5,0),COLOR4440FF;
STICKLINE(KX2,C,L,0.5,0),COLOR4440FF;
STICKLINE(KX3,C,O,4,1),COLORFFFF33;
STICKLINE(KX3,C,H,0.5,1),COLORFFFF33;
STICKLINE(KX3,O,L,0.5,1),COLORFFFF33;
STICKLINE(KX4,C,O,4,0),COLORFFFF33;
STICKLINE(KX4,O,H,0.5,0),COLORFFFF33;
STICKLINE(KX4,C,L,0.5,0),COLORFFFF33;
回复 支持 反对

使用道具 举报

发表于 2011-3-18 00:26 | 显示全部楼层
好公式 顶一下
回复 支持 反对

使用道具 举报

发表于 2011-3-18 00:34 | 显示全部楼层
谢谢分享
回复 支持 反对

使用道具 举报

发表于 2011-3-18 01:10 | 显示全部楼层
看下,有用没
回复 支持 反对

使用道具 举报

发表于 2011-3-18 01:16 | 显示全部楼层
Var1:=MA(CLOSE,5);Var2:=MA(CLOSE,10);Var3:=MA(CLOSE,20);Var4:=MA(CLOSE,30);Var5:=(Var1+Var2+Var3+Var4)/4;Var6:=(Var5-REF(Var5,15))/REF(Var5,15)*100;Var7:=(Var5-REF(Var5,15))/REF(Var5,15)*100;Var8:=EMA(Var6,8);=红色持股=: STICKLINE(Var6>1*REF(Var6,1),Var6,Var8,5,0),colorred , ;=绿色持币=: STICKLINE(Var6<1*REF(Var6,1),Var6,Var8,5,1),colorccff66 , ;Var9:=(CLOSE-MA(CLOSE,58))/MA(CLOSE,58)*100;VarA:=(Var9>1*REF(Var9,1) AND Var9<-26 AND Var9>-40)*1.5;VarB:=VOL/CAPITAL*100;VarC:=LLVBARS(LOW,50);VarD:=SUM(VOL,VarC);VarE:=HHVBARS(HIGH,50);VarF:=SUM(VOL,VarE);Var10:=(CLOSE-REF(OPEN,VarE))/REF(OPEN,VarE)*100;Var11:=VarF/CAPITAL*100;Var12:=(CLOSE-REF(OPEN,VarC))/REF(OPEN,VarC)*100;Var13:=VarD/CAPITAL*100;Var14:=MA(CLOSE,3);Var15:=REF(CLOSE,2)*0.865;Var16:=REF(CLOSE,13)*0.772;Var17:=MIN(Var15,Var16);Var18:=MA(CLOSE,13);Var19:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;Var1A:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;Var1B:=EMA(Var1A,9);Var1C:=2*(Var1A-Var1B);☆出手必赢☆:IF((CLOSE-Var17)/CLOSE<0.03 AND Var10<-35 AND SUM(VarB,5)/5<1.8,1,0)*10,coloryellow ,;DRAWTEXT(Var1A<-50 AND Var19>7 AND Var1A<VAR1B,-15,'短期见底'),COLORYELLOW AND Var19 ;DRAWTEXT(Var1A7 AND Var1A>=Var1B,Var6,'短线出击'), , ;
回复 支持 反对

使用道具 举报

发表于 2011-3-18 02:13 | 显示全部楼层
好指标,感谢啦!!!!
回复 支持 反对

使用道具 举报

发表于 2011-3-18 08:21 | 显示全部楼层
MACD和KDJ共振图
回复 支持 反对

使用道具 举报

发表于 2011-3-18 13:37 | 显示全部楼层
谢谢楼主
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2018-1-18 17:50 , Processed in 0.096131 second(s), 16 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表