老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 4282|回复: 15

[通达信] 分时跟庄--(优化MACD 源码)

[复制链接]
发表于 2010-5-8 15:23 | 显示全部楼层 |阅读模式
DIFF:=((EMA(CLOSE,12)-EMA(CLOSE,26))*20)*100;
DEA:=EMA(DIFF,9);
DRAWBAND(DIFF,RGB(255,168,0),DEA,RGB(0,168,168));
KKK:=60;
DRAWTEXT(ISLASTBAR,95,'   ■ 姜黄--筹码量'),COLOR0A40FC;
DRAWTEXT(ISLASTBAR,84,'   ■ 粉柱--高度控盘'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,73,'   ■ 红柱--主力控盘'),COLOR0000FF;
DRAWTEXT(ISLASTBAR,62,'   ■ 白柱--无庄控盘'),COLORFFFFFF;
DRAWTEXT(ISLASTBAR,51,'   ■ 绿柱--主力出货'),COLOR00FF00;
DRAWTEXT(ISLASTBAR,40,'   ■ 黄尖--开始控盘'),COLOR00FFFF;
DRAWTEXT(ISLASTBAR,29,'   ■ 淡红--渐强走势'),COLOR4B50F8;
DRAWTEXT(ISLASTBAR,18,'   ■ 深红--超强走势'),COLOR4F06C8;
DRAWTEXT(ISLASTBAR,7,'   ■ 青柱--开始变盘'),COLORFFFF00;
VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,KKK*控盘,0,1,0),COLORWHITE;
A10:=CROSS(控盘,0);
无庄:=IF(控盘<0,控盘,0);
开始控盘:IF(A10,100,0),LINETHICK1,COLORYELLOW;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,KKK*控盘,0,1,0),COLORRED;
有庄:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0);
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,KKK*控盘,0,1,0),COLORFF00FF;
高控:=IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0);
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,KKK*控盘,0,1,0),COLOR00FF00;
出货:=IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0);
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(CROSS(L1,L2));
L4:=REF(L3,L3+1);
L5:=L2;
变盘:=CROSS(L1,L2) AND L5;
STICKLINE(变盘,-8,0,2,0),COLORFFFF00;
DIFL:=EMA(V,12)-EMA(V,26);
DIF:=EMA(C,12)-EMA(C,26);
BL:=DIFL>REF(DIFL,1) AND DIF<REF(DIF,1);
四天:=REF(BL,3)=1 AND REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
三天:=REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
强势:=KKK*IF(DIFF>DEA,DIFF,0);
STICKLINE(强势,-8,0,2,0),COLOR4F06C8;
渐强:=KKK*IF(DIFF>DEA AND DIFF<0,DIFF,0);
STICKLINE(渐强,-8,0,2,0),COLOR4B50F8;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DRAWICON(FILTER(CROSS(K,D) AND D<26,6),2,1);
AZ5:=SMA(ABS(LOW-REF(LOW,1)),3,1)/SMA(MAX(LOW-REF(LOW,1),0),3,1)*100;
AZ6:=EMA(IF(CLOSE*1.3,AZ5*10,AZ5/10),3);
AZ10:=EMA(IF(LOW<=LLV(LOW,29),(AZ6+HHV(AZ6,37)*2)/2,0),3)/8888*IF(MA(CLOSE,90),1,0);
筹码:IF(AZ10>100,100,AZ10*0.1),COLOR0A40FC,LINETHICK2;
STICKLINE(KKK*筹码,0,30*筹码,6,0)*DATE<=1070615,COLOR00EEFF;
STICKLINE(KKK*筹码,0,25*筹码,6,0)*DATE<=1070615,COLOR00BBFF;
STICKLINE(KKK*筹码,0,20*筹码,6,0)*DATE<=1070615,COLOR0099FF;
STICKLINE(KKK*筹码,0,15*筹码,6,0)*DATE<=1070615,COLOR0066FF;
STICKLINE(KKK*筹码,0,10*筹码,6,0)*DATE<=1070615,COLOR0000FF;
fenshigenzhuang.jpg (36.51 KB)
发表于 2010-5-8 16:05 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2010-5-8 16:08 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2010-5-8 16:27 | 显示全部楼层
怎么用的??怎样才能和分时图结合?
回复 支持 反对

使用道具 举报

发表于 2010-5-10 17:11 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2010-5-10 17:14 | 显示全部楼层
无图无真相
回复 支持 反对

使用道具 举报

发表于 2010-5-11 11:09 | 显示全部楼层
回复 支持 反对

使用道具 举报

头像被屏蔽
发表于 2010-5-11 15:25 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
回复 支持 反对

使用道具 举报

发表于 2010-5-11 21:22 | 显示全部楼层
么用的??怎样才能和分时图结合?
回复 支持 反对

使用道具 举报

发表于 2010-5-11 22:38 | 显示全部楼层
有未来,我还是不用了。但还是要顶一下
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-12-17 14:19 , Processed in 0.112400 second(s), 17 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表