老钱庄股票论坛

 找回密码
 5秒快速注册
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
楼主: nmsxb

[通达信] 免费为大家改写选股指标

    [复制链接]
发表于 2010-4-20 00:09 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2010-4-20 00:42 | 显示全部楼层
麻烦老师在出现红柱买入做个通达信用的预警选股公式
VAR886:=IF((YEAR >= 2050) AND (MONTH >= 1),0,1);
准:4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-  
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1)
*VAR886,COLORYELLOW,STICK,LINETHICK2;  
赢:8,COLORRED,LINETHICK2;  
准备→资金进场: IF(准<=8,25,0),STICK,COLORWHITE,LINETHICK2;
买入→北狼买点: IF(CROSS(准,赢),80,0),COLORRED,STICK,LINETHICK2;  

DRAWTEXT(CROSS(准,赢),80,'☆←买入');  
换手率:VOL/CAPITAL*100,NODRAW;
每股收益:FINANCE(33),NODRAW;
上市日期:FINANCE(42)/100, NODRAW ;
流通盘:CAPITAL/1000000,NODRAW;

市盈率:DYNAINFO(39),NODRAW;

VARO5:=LLV(LOW,27);  
VARO6:=HHV(HIGH,34);  
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;  
建仓区: IF((VARO7<10),80,100) ,0,COLORLIMAGENTA,LINETHICK1;

请老师把通达信的副图指标在OBV指标上叠加ASI指标(需要改一下ASI的颜色,因为OBV,ASI线的颜色都是一样的,不好区分),通达信不能2个副图叠加,望老师想办法,谢谢了
回复 支持 反对

使用道具 举报

发表于 2010-4-20 01:02 | 显示全部楼层
老师您好:有一公式请老师改成选股公式.先谢谢了..出现红箭头的选股公式!

CV:=CLOSE;

BBIBOLL:=(MA(CV,3)+MA(CV,6)+MA(CV,12)+MA(CV,24))/4;

UPR:=BBIBOLL+6*STD(BBIBOLL,11);

DWN:=BBIBOLL-6*STD(BBIBOLL,11);

QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));

HSL:=(XVL/20)/1.15;

攻击:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));

LLJX:=EMA(攻击,3);0,POINTDOT,COLORWHITE;

B1:SUM(LLJX,1),COLORCYAN;

B2:SUM(LLJX,2),COLORCYAN;

B3:SUM(LLJX,3),COLORCYAN;

B4:SUM(LLJX,4),COLORCYAN;

B5:SUM(LLJX,5),COLORCYAN;

B6:SUM(LLJX,6),COLORCYAN;

B7:SUM(LLJX,7),COLORCYAN;

B8:SUM(LLJX,8),COLORCYAN;

B9:SUM(LLJX,9),COLORCYAN;

B10:SUM(LLJX,10),COLORCYAN;

A1:IF(B1>REF(B1,1),B1,DRAWNULL),COLORRED;

A2:IF(B2>REF(B2,1),B2,DRAWNULL),COLORRED;

A3:IF(B3>REF(B3,1),B3,DRAWNULL),COLORRED;

A4:IF(B4>REF(B4,1),B4,DRAWNULL),COLORRED;

A5:IF(B5>REF(B5,1),B5,DRAWNULL),COLORRED;

A6:IF(B6>REF(B6,1),B6,DRAWNULL),COLORRED;

A7:IF(B7>REF(B7,1),B7,DRAWNULL),COLORRED;

A8:IF(B8>REF(B8,1),B8,DRAWNULL),COLORRED;

A9:IF(B9>REF(B9,1),B9,DRAWNULL),COLORRED;

A10:IF(B10>REF(B10,1),B10,DRAWNULL),COLORRED;

XG:=B1 AND B2 AND B3 AND B4 AND B5 AND B6 AND B7 AND B8 AND B9 AND B10 AND (CLOSE-OPEN)>=(UPR-BBIBOLL) AND V/REF(V,1)>=1.9;

DRAWICON(XG,-100,1);
改一个选股公式.出现红箭头的选股公式!
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-20 10:49 | 显示全部楼层
回48楼,呵呵,这就是多空对比嘛,现回复你如下,请验证:
短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
中期:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
中长期:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
长期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
长期>80 AND REF(短期,1)<40 AND REF(短期,1)<短期 AND 中期>REF(中期,1) AND 中长期>REF(中长期,1);
我验证通过了~~
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-20 11:08 | 显示全部楼层
42楼的改写如下,信号过多,需要优化:
N1:=7;
LC:=REF(CLOSE,1);
X:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
魔鬼:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1);
TJ1:=X=魔鬼;
TJ2:=X<REF(X,1);
TJ1 AND TJ2;
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-20 11:19 | 显示全部楼层
51楼再次修改,呵呵,没关系,我们一起交流提高:
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
cross(趋势,0);
通过了,但是却没选出股票来,呵呵,这样的行情,估计就是没有合格的~~
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-20 11:42 | 显示全部楼层
53楼,你发的公式缺少参数N,软件不能通过,希望你能把参数发来,才能修改的。叠加的我试了一下,现回复与你:
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV:SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:MA(OBV,30);
LC:=REF(CLOSE,1);
AA:=ABS(HIGH-LC);
BB:=ABS(LOW-LC);
CC:=ABS(HIGH-REF(LOW,1));
DD:=ABS(LC-REF(OPEN,1));
R:=IF(AA>BB AND AA>CC,AA+BB/2+DD/4,IF(BB>CC AND BB>AA,BB+AA/2+DD/4,CC+DD/4));
X:=(CLOSE-LC+(CLOSE-OPEN)/2+LC-REF(OPEN,1));
SI1:=16*X/R*MAX(AA,BB);
ASI1:SUM(SI1,0)*10000;
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-20 11:47 | 显示全部楼层
54楼的就非常简单了,都不用试,因为作者已经给你做好了,把最后一句去掉就是了。还有,53楼发的公式里暗含时间限制,用到2050年就不能用了,解决的办法是去掉第一句,然后把所有的var886以及前面的运算符去掉即可,呵呵,作者还很调皮,var886,到期了就告诉你,该拜拜了。希望大家踊跃跟帖,我只要一有时间就会马上来回帖的。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-20 11:48 | 显示全部楼层
54楼的就非常简单了,都不用试,因为作者已经给你做好了,把最后一句去掉就是了。还有,53楼发的公式里暗含时间限制,用到2050年就不能用了,解决的办法是去掉第一句,然后把所有的var886以及前面的运算符去掉即可,呵呵,作者还很调皮,var886,到期了就告诉你,该拜拜了。希望大家踊跃跟帖,我只要一有时间就会马上来回帖的。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-20 11:48 | 显示全部楼层
54楼的就非常简单了,都不用试,因为作者已经给你做好了,把最后一句去掉就是了。还有,53楼发的公式里暗含时间限制,用到2050年就不能用了,解决的办法是去掉第一句,然后把所有的var886以及前面的运算符去掉即可,呵呵,作者还很调皮,var886,到期了就告诉你,该拜拜了。希望大家踊跃跟帖,我只要一有时间就会马上来回帖的。
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-11-20 23:39 , Processed in 0.116820 second(s), 14 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表