老钱庄股票论坛

 找回密码
 5秒快速注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

关闭
关闭
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
楼主: nmsxb

[通达信] 免费为大家改写选股指标

    [复制链接]
 楼主| 发表于 2017-6-28 15:04 | 显示全部楼层
股友顾 发表于 2017-6-26 20:16
请老师帮忙把下面的黄蓝带指标公式改成当“蓝变黄的第一天”选股公式,谢谢了!

{主图}

JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,5);
B:=REF(A,1);
A>B ANF REF(A,1)<=REF(B,1);
回复 支持 反对

使用道具 举报

 楼主| 发表于 2017-7-21 11:01 | 显示全部楼层
秀秀近期交割单~~~~~~

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x
回复 支持 反对

使用道具 举报

 楼主| 发表于 2017-7-21 11:09 | 显示全部楼层
这条线 是卖出线 个人觉得 还算准确

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x
回复 支持 反对

使用道具 举报

 楼主| 发表于 2017-7-21 11:09 | 显示全部楼层
由此看来 近期大盘 必有一跌

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x
回复 支持 反对

使用道具 举报

发表于 2017-8-21 16:31 | 显示全部楼层
请老师写个选股公式:选出出现“必买”黄柱线时的个股,谢谢!码源如下:

实价线:=(C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100,colorwhite;
a1:=(2*C+H+L)/4;
a2:=LLV(L,34);
a3:=HHV(H,34);
a4:=SMA((HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100-70,9,1)+100;
a5:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
a6:=SMA(SMA(a5,3,1),3,1)+100;
a7:=a6-a4;
底部区域:IF(a7>60,a7-60,0),coloryellow;
持有:STICKLINE(REF(底部区域,1)<底部区域,底部区域,REF(底部区域,1),5,0),color00ffff;
出货:STICKLINE(REF(底部区域,1)>底部区域,底部区域,REF(底部区域,1),5,0),color00ff00;
中线介入:EMA((a1-a2)/(a3-a2)*100,13),color0000cc;
中线出货:EMA(0.667*REF(中线介入,1)+0.333*中线介入,2),colorffcc66;
STICKLINE(中线介入-中线出货>0,中线介入,中线出货,8,0),color0000cc;
STICKLINE(中线介入-中线出货<0,中线介入,中线出货,8,0),colorffcc66;
var13:=LLV(LOW,30);
var18:=HHV(HIGH,30);
趋势线:EMA((CLOSE-var13)/(var18-var13)*100,5)/8*10,colorf00ff0,linethick2;
必买: IF(TROUGHBARS(3,5,1)=0 AND HIGH>LOW+0.01,70,0),coloryellow ,linethick3,STICK ;
必卖: IF(PEAKBARS(3,5,1)=1,70,0),colorwhite,linethick3,STICK;
0;25,COLOR208fff ;
0;100,COLORffddc6


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?5秒快速注册

x
回复 支持 反对

使用道具 举报

 楼主| 发表于 2017-8-28 21:13 | 显示全部楼层
cailin 发表于 2017-8-21 16:31
请老师写个选股公式:选出出现“必买”黄柱线时的个股,谢谢!码源如下:

实价线:=(C-LLV(L,60))/(HHV(H ...

TROUGHBARS(3,5,1)=0 AND HIGH>LOW+0.01;
回复 支持 反对

使用道具 举报

发表于 2017-8-30 16:09 | 显示全部楼层
老师好!感谢你的无私奉献,还要恳请你为我做个选股公式,就是在出现(K线图底色在红色时候)黄金K线的时候预警!万分感谢!
通达信源码如下:
DRAWRECTREL(76,1000,0,930,RGB(255,255,0));
多止损:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*3.5,LINETHICK0,COLORYELLOW;
多止盈:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK0,COLORWHITE;
空止损:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*3.5+XMA(XMA(H,25),25),LINETHICK0,COLORYELLOW;
空止盈:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK0,COLORWHITE;
短高H:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
短低L:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90H:=EMA(短高H,90),COLORRED,LINETHICK1;
D90L:=EMA(短低L,90),COLORRED,LINETHICK1;
D90差:=D90H-D90L;
D90顶:=D90H+D90差*2,COLORRED,LINETHICK1;
D90底:=D90L-D90差*2,COLORRED,LINETHICK1;
高0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK1,COLORWHITE;
低0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK1,COLORWHITE;
多头定位:=低0>=D90底 AND 高0>=D90顶;
空头定位:=高0<=D90顶 AND 低0<=D90底;
震荡定位:=低0>=D90底 AND 高0<=D90顶;
短顶:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2+XMA(XMA(H,25),25),LINETHICK2,COLORGREEN;
短底:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*2,LINETHICK2,COLORGREEN;
短线收盘:=(C-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
短线开盘:=(O-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
短线高盘:=(H-短底)/(短顶-短底)*100000,LINETHICK2,COLORRED;
短线低盘:=(L-短底)/(短顶-短底)*100000,LINETHICK0,COLORRED;
顶1:=110000,COLORYELLOW,LINETHICK0;
底1:=-10000,COLORYELLOW,LINETHICK0;
STICKLINE(多头定位=1,顶1,底1,5,0),COLOR000066;
STICKLINE(空头定位=1,顶1,底1,5,0),COLOR003300;
STICKLINE(震荡定位=1,顶1,底1,5,0),COLOR555555;
震荡顶:=(XMA(XMA(短线高盘,25),25)-XMA(XMA(短线低盘,25),25))*1+XMA(XMA(短线高盘,25),25),DOTLINE,COLORWHITE;
震荡底:=XMA(XMA(短线低盘,25),25)-(XMA(XMA(短线高盘,25),25)-XMA(XMA(短线低盘,25),25))*1,DOTLINE,COLORWHITE;
做空:80000,COLORWHITE,LINETHICK1;
做多:20000,COLORWHITE,LINETHICK1;
中线:50000,COLORYELLOW,DOTLINE;
空损:110000,COLORMAGENTA,LINETHICK2;
多损:-10000,COLORMAGENTA,LINETHICK2;
DRAWTEXT(ISLASTBAR,108000,'-顶'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,80000,'-卖'),COLORGREEN;
DRAWTEXT(ISLASTBAR,20000,'-买'),COLORRED;
DRAWTEXT(ISLASTBAR,-9000,'-底'),COLORMAGENTA;
DEA3:=EMA((EMA(CLOSE,3) - EMA(CLOSE,6)),9),COLORGREEN,LINETHICK2;
DEA3B:=REF(DEA3,1),COLORWHITE,LINETHICK0;
DEA33B:=EMA((EMA(EMA(CLOSE,3) - EMA(CLOSE,9),3) - EMA(EMA(CLOSE,3) - EMA(CLOSE,9),9)),9),COLORWHITE,LINETHICK0;
DEA333B:=REF(DEA33B,1),COLORWHITE,LINETHICK0;
STICKLINE(DEA3B<DEA3 OR DEA333B<DEA33B,短线低盘,短线高盘,0.0,0),COLORRED;
STICKLINE(DEA3B<DEA3 OR DEA333B<DEA33B,短线收盘,短线开盘,3,1),COLORRED;
STICKLINE(DEA3<DEA3B,短线低盘,短线高盘,0.0,0),COLORGREEN;
STICKLINE(DEA3<DEA3B,短线收盘,短线开盘,3,1),COLORGREEN;
白色点多定位1:=短线低盘<做多 AND 短线高盘>做多;
白色点空定位1:=短线高盘>做空 AND 短线低盘<做空;
STICKLINE(白色点多定位1=1,短线低盘,做多,3.2,0),COLOR000077;
STICKLINE(白色点多定位1=1,短线低盘,做多,2.7,0),COLOR000099;
STICKLINE(白色点多定位1=1,短线低盘,做多,2.1,0),COLOR0000BB;
STICKLINE(白色点多定位1=1,短线低盘,做多,1.5,0),COLOR0000DD;
STICKLINE(白色点多定位1=1,短线低盘,做多,0.9,0),COLOR0000FF;
STICKLINE(白色点多定位1=1,短线低盘,做多,0.2,0),COLOR5555FF;
STICKLINE(白色点空定位1=1,短线高盘,做空,3.2,0),COLOR770077;
STICKLINE(白色点空定位1=1,短线高盘,做空,2.7,0),COLOR990099;
STICKLINE(白色点空定位1=1,短线高盘,做空,2.1,0),COLORBB00BB;
STICKLINE(白色点空定位1=1,短线高盘,做空,1.5,0),COLORDD00DD;
STICKLINE(白色点空定位1=1,短线高盘,做空,0.9,0),COLORFF00FF;
STICKLINE(白色点空定位1=1,短线高盘,做空,0.2,0),COLORFF66FF;
白色点多定位2:=短线高盘<做多;
白色点空定位2:=短线低盘>做空;
STICKLINE(白色点多定位2=1,短线低盘,短线高盘,0.0,0),COLOR00FFFF;
STICKLINE(白色点多定位2=1,短线收盘,短线开盘,3.2,0),COLOR0044FF;
STICKLINE(白色点多定位2=1,短线收盘,短线开盘,2.7,0),COLOR0066FF;
STICKLINE(白色点多定位2=1,短线收盘,短线开盘,2.1,0),COLOR0088FF;
STICKLINE(白色点多定位2=1,短线收盘,短线开盘,1.5,0),COLOR00AAFF;
STICKLINE(白色点多定位2=1,短线收盘,短线开盘,0.9,0),COLOR00CCFF;
STICKLINE(白色点多定位2=1,短线收盘,短线开盘,0.2,0),COLOR00FFFF;
STICKLINE(白色点空定位2=1,短线低盘,短线高盘,0.0,0),COLORFF0000;
STICKLINE(白色点空定位2=1,短线收盘,短线开盘,3.2,0),COLORFF0000;
STICKLINE(白色点空定位2=1,短线收盘,短线开盘,2.7,0),COLORFF2200;
STICKLINE(白色点空定位2=1,短线收盘,短线开盘,2.1,0),COLORFF4400;
STICKLINE(白色点空定位2=1,短线收盘,短线开盘,1.5,0),COLORFF6600;
STICKLINE(白色点空定位2=1,短线收盘,短线开盘,0.9,0),COLORFF8800;
STICKLINE(白色点空定位2=1,短线收盘,短线开盘,0.2,0),COLORFFCC00;
多头多定位:=CROSS(做多,短线低盘) AND 多头定位=1;
多头平定位:=CROSS(短线高盘,做空) AND 多头定位=1 AND 震荡定位=0;
空头空定位:=CROSS(短线高盘,做空) AND 空头定位=1;
空头平定位:=CROSS(做多,短线低盘) AND 空头定位=1 AND 震荡定位=0;
震荡多定位:=CROSS(做多,短线低盘) AND 震荡定位=1;
震荡空定位:=CROSS(短线高盘,做空) AND 震荡定位=1;
DRAWICON(空头平定位=1,短线低盘,11);
DRAWICON(多头平定位=1,短线高盘,15);
DRAWICON(多头多定位=1 OR 震荡多定位=1,短线低盘,11);
DRAWICON(空头空定位=1 OR 震荡空定位=1,短线高盘,15);
DRAWICON(CROSS(20000,短线高盘),短线低盘,1);
辛苦老师了!万分感谢!
回复 支持 反对

使用道具 举报

发表于 2017-8-31 16:36 | 显示全部楼层
真的太好了,也想学学怎么编辑指标公式
回复 支持 反对

使用道具 举报

发表于 2017-8-31 21:56 | 显示全部楼层
老师好!好久不见老师了,希望老师能继续帮我们解决难题,在此真心的谢谢老师!麻烦老师吧下面指标做个预警选股公式,要求出现”准备“信号时进行选股,谢谢老师!

{快慢线}
底线:0,COLOREEEEEE,LINETHICK1;
高位:80,COLOR99FF33,POINTDOT;
低位:20,COLORFFFFFF,POINTDOT;
VARR1:=LLV(LOW,P1);
VARR2:=HHV(HIGH,P1);
K: EMA((CLOSE-VARR1)/(VARR2-VARR1)*100,P2),COLORRED,LINETHICK2;
D: EMA(0.667*REF(K,1)+0.333*K,2),COLORFF0000,LINETHICK2;
{洗盘再买}
RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
VARB2:=(RSVV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH);
准备:=IF(黄金 AND RSVV<VARB2-2,10,0), COLORYELLOW,NODRAW;
STICKLINE(准备,0,10,1,0), COLORRED;
DRAWTEXT(准备>0,20.6,'准备 '), COLORYELLOW;
准备1:=REF(准备,1) OR REF(准备,2) OR REF(准备,3) OR 准备;
买:=CROSS(K,D) AND 准备1,COLORRED,NODRAW;
STICKLINE(买,0,10,1,0.0),COLOR00FFFF;
DRAWTEXT(买>0,8.6,'买 '),COLORFF00FF;

{短买}
AR1:=3*SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1),3,1);
短买:=CROSS(AR1,REF(AR1+0.01,1)) AND LLV(AR1,2)=LLV(AR1,8) AND AR1<20;
STICKLINE(短买,20,30,1,0),COLORCYAN;
DRAWTEXT(短买>0,33.6,'T'),COLORCYAN;
回复 支持 反对

使用道具 举报

发表于 2017-9-2 13:47 | 显示全部楼层
nmsxb 发表于 2017-7-21 11:01
秀秀近期交割单~~~~~~

老师您的指标可不可以分享一两个呀?谢谢
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2018-7-20 04:53 , Processed in 0.104515 second(s), 16 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表