老钱庄股票论坛

 找回密码
 5秒快速注册
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
楼主: nmsxb

[通达信] 免费为大家改写选股指标

    [复制链接]
发表于 2010-4-18 19:34 | 显示全部楼层
VAR1:=LLV(LOW,13);
VAR2:=HHV(HIGH,13);
VAR3:=SMA((CLOSE-VAR1)/(VAR2-VAR1)*100,5,1);
VAR4:=SMA((VAR2-CLOSE)/(VAR2-VAR1)*100,5,1);
DRAWBAND(VAR3,RGB(155,50,50),50,RGB(0,100,50));
主力:VAR3,COLORRED;
散户:VAR4,COLORGREEN;
VAR5:=SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),5,1)*100;
操作:=EMA(VAR5,3),COLORYELLOW;
STICKLINE(C,90,90,1,0),COLOR3C3CFF;
STICKLINE(C,50,50,1,0),COLORYELLOW;
STICKLINE(C,10,10,1,0),COLORCYAN;
N1:=7;
界:=38,COLORFF3311;  
加仓线:=51,COLORFF1155;
LC:=REF(CLOSE,1);
X:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORFFFFFF;
魔鬼:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1),COLOR00FF00;
TJ1:=X=魔鬼;
TJ2:=X<REF(X,1);
DRAWICON(TJ1 AND TJ2,X,1);
VAR2M:=(HIGH+LOW+CLOSE*2)/4;
VAR3M:=EMA(VAR2M,21);
VAR4M:=STD(VAR2M,21);
VAR5M:=((VAR2M-VAR3M)/VAR4M*100+200)/4;
VAR6:=(EMA(VAR5M,5)-25)*1.56;
AK:=EMA(VAR6,2)*1.22;
AD1:=EMA(AK,2);
注意:=CROSS(AD1,AK);
DRAWTEXT(注意,散户,'变');


请问老师这个指标含有未来函数吗?
回复 支持 反对

使用道具 举报

发表于 2010-4-18 23:11 | 显示全部楼层
dddddddddd
回复 支持 反对

使用道具 举报

发表于 2010-4-18 23:37 | 显示全部楼层
楼主,好人,祝你一生平安、恭喜发财。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-19 09:28 | 显示全部楼层
42楼,未发现有未来函数
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-19 09:40 | 显示全部楼层
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
J1:=REVERSE(J);
AA:=REF(MA(C,1),10)<REF(MA(C,60),10);
卖点:CROSS(J1,J) AND AA;
STICKLINE(卖点,0,30,12,0),COLOR0000FF;
STICKLINE(卖点,30,60,10,0),COLORWHITE;
STICKLINE(卖点,60,80,6,0),COLORYELLOW;
DRAWTEXT(卖点,40,'庄家逃跑!'),COLORFF00FF;-------反其道而行之,虽然可以被软件所通过,效果却不一定好~~

评分

参与人数 1威望 +2 收起 理由
hiinen + 2 老师高人

查看全部评分

回复 支持 反对

使用道具 举报

发表于 2010-4-19 15:42 | 显示全部楼层
24# nmsxb nmsx老师你好,照你的方法我试了几次,有错通不过。不好意思,请你帮我优化一下,谢谢!!
回复 支持 反对

使用道具 举报

头像被屏蔽
发表于 2010-4-19 16:22 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
回复 支持 反对

使用道具 举报

发表于 2010-4-19 16:24 | 显示全部楼层
谢谢老师修改公式,辛苦了,好人一定会有好报的。
回复 支持 反对

使用道具 举报

发表于 2010-4-19 17:33 | 显示全部楼层
老师您好,谢谢。能不能把42楼的指标中的那个箭头改成选股指标?42楼会赞成吧,也谢谢42楼。
回复 支持 反对

使用道具 举报

发表于 2010-4-19 23:36 | 显示全部楼层
老师辛苦了!谢谢您为学生改的选股公式!上次可能学生没说明白!谅解!我想让老师帮助改的是趋势线下到零位线,当趋势线上穿零数线时出现1号图标(红箭头)这个箭头有些不明显!再次求老师帮助学生改个选股公式和预警!学生在此深表歉意!谢谢!

A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
DRAWICON(CROSS(
趋势,0),0,1);
{
机构建仓区:0,LINETHICK0,COLORFFFF00; 这是句故弄玄虚的代码}
VAR4:=(
趋势-REF(趋势,1))/REF(趋势,1)*100;
STICKLINE(
趋势<=13,0,20,5,0),COLORCC9900;
DRAWTEXT(FILTER(
趋势<=13,15),30,'准备现金'),COLORCC9900;
STICKLINE(
趋势<=13 AND VAR4>13,0,50,5,0),COLOR0099FF;
VAR5:=FILTER((
趋势<=13 AND VAR4>13),10);
DRAWTEXT(VAR5,60,'
买入'),COLOR0099FF;
STICKLINE(
趋势>=90 AND VAR4,0,30,5,0),COLORGRAY;
VAR6:=FILTER((
趋势>=90 AND VAR4),10);
DRAWTEXT(VAR6,40,'
清仓'),COLORGRAY;
VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;
STICKLINE(VAR9>90,100,105,10,2),COLORRED;
VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
火焰山:EMA(IF(LOW<=VAR7 AND 趋势<40,(VAR11+VAR12),0),3)/618,COLORRED,LINETHICK2;
STICKLINE(
火焰山>0,0 ,火焰山*1.2,8,0 ),COLORRED;
VAR13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
VAR14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趋势线: 趋势,COLORFF0000,LINETHICK2;
VAR16:=MAX(EMA(VAR13,2)-EMA(VAR14,5),0)*200;
VAR17:=EMA(VAR16,5);
波浪峰:VAR17,STICK,COLORFF00FF;
STICKLINE(VAR17<REF(VAR17,1),0,VAR17,1,0),COLOR00FF00;
VAR18:=MA(
趋势线,8);
IF(CROSS(VAR2,VAR18) AND VAR2<15,50,0),COLORRED;
DRAWTEXT(CROSS(
趋势线,VAR2)AND 趋势线>REF(趋势线,1)AND 趋势线<50,50,'追涨'),COLORFF0000;
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-11-18 18:10 , Processed in 0.093761 second(s), 15 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表