老钱庄股票论坛

 找回密码
 5秒快速注册
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
楼主: nmsxb

[通达信] 免费为大家改写选股指标

    [复制链接]
发表于 2010-4-18 10:39 | 显示全部楼层
17# nmsxb 谢谢指教。知道预警了。信号太多,选出的股也太多。我不知道该怎样处理。请赐教。拜托!
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-18 10:43 | 显示全部楼层
设置预警请先添加选股公式,然后点击右下角的小三角形,再点击设置、公式设置、添加公式,找到要添加的公式,确定即可。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-18 10:48 | 显示全部楼层
优化选股公式我通常是这样做的,如果发现信号过多的话,那就根据自己的操作习惯,比如说资金小,做不了中高价股又不喜欢超低价股,那就添加上5<股价<20,不想做ST就可以选择每股收益>0,再要求高一些的可以让每股收益>0.1,或者流通盘等等...这些条件一添加,信号自然就少了,具体代码可参考通达信公式编辑器里的“添加函数”功能,然后在每个条件之间加上“and”连接一下即可。

评分

参与人数 1威望 +2 收起 理由
sinnoxue + 2 您的文章很棒,精品文章

查看全部评分

回复 支持 反对

使用道具 举报

发表于 2010-4-18 10:58 | 显示全部楼层
dddddddddddddddddddd
回复 支持 反对

使用道具 举报

发表于 2010-4-18 11:04 | 显示全部楼层
为人民服务!楼主精神不错!
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-18 11:08 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2010-4-18 11:11 | 显示全部楼层
老师你好.首先祝合家安康.财源广进.能把你的条件选股指标发给我们吗.万分感谢你.
回复 支持 反对

使用道具 举报

发表于 2010-4-18 11:16 | 显示全部楼层
老师感谢你..发1个也行
回复 支持 反对

使用道具 举报

发表于 2010-4-18 11:16 | 显示全部楼层
N1:=21;
LC:=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORFF0000;
IF(RSI1>53,RSI1,DRAWNULL),COLORRED,LINETHICK1;
DRAWICON(CROSS(RSI1,53),53-1,11);
TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/TR,COLORFFFFFF;
MDI: DMM*100/TR,COLOR00FFFF;
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M),COLOR0000FF,LINETHICK2;
ADXR:EXPMEMA(ADX,M),COLOR00FF00,LINETHICK2;
{一,MDI必须在下方,PDI在下方无效,二、PDI趋势向上。三、必须在PDI及MDI中间金叉 }
T1:=CROSS(ADX,ADXR) AND PDI>MDI AND PDI>REF(PDI,1)
AND  BETWEEN(ADXR,MDI,PDI) AND ADX>REF(ADX,1) AND ADXR>REF(ADXR,1);
DRAWICON(T1,ADXR,1);
{ADX  ADXI同时上穿MDI }
T2:=CROSS(ADX,MDI) AND CROSS(ADXR,MDI) AND PDI>MDI;
DRAWICON(T2,MDI,17);

我的通达信不能通过,请老师修改一下,谢谢
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-18 11:26 | 显示全部楼层
回楼上,这个是缺少参数N设置,属于代码不全,建议你在哪里看到的到哪里去再找一下,把N后面的数字找来就可以了
我比较常用的一个选股:
VA6:=(2*CLOSE+HIGH+LOW)/4;
VA8:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
生命线:=EMA(VARD,1);
BIAS3:=MA((CLOSE-MA(CLOSE,27))/MA(CLOSE,27),3)*100;
开始拉升:CROSS(VARC,生命线) AND VARC>VARD AND VARC<55 AND C>O AND CLOSE<15 AND BIAS3>0 AND REF(BIAS3,1)<0;
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-11-24 11:43 , Processed in 0.090596 second(s), 15 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表