老钱庄股票论坛

 找回密码
 5秒快速注册
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
楼主: nmsxb

[通达信] 免费为大家改写选股指标

    [复制链接]
发表于 2010-4-17 20:02 | 显示全部楼层
支持楼主
回复 支持 反对

使用道具 举报

发表于 2010-4-17 21:05 | 显示全部楼层
回复 支持 反对

使用道具 举报

发表于 2010-4-17 22:06 | 显示全部楼层
1# nmsxb
请老大帮忙把AA升>0第一天时做个选股公式,先谢谢了!
HL10:=WINNER(CLOSE/1.1)*1.5,STICK,COLORFF00FF;
HL20:=WINNER(CLOSE/1.2)*1.5,STICK,COLOR00FFFF;
HL30:=WINNER(CLOSE/1.3)*1.5,STICK,COLOR0000FF;
{STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.8,1)}
STICKLINE(HL10>0,-1.2,-1.2+HL10,2,0)COLORFF00FF;
STICKLINE(HL20>0,-1.2,-1.2+HL20,2,0)COLOR00FFFF;
STICKLINE(HL30>0,-1.2,-1.2+HL30,2,0)COLOR0000FF;
AAA:-1.2,COLORYELLOW;
DIFF:EMA(CLOSE,10)-EMA(CLOSE,22);
DEA:EMA(DIFF,9);
MACD:(DIFF-DEA)*2,COLORSTICK;
AA:DIFF,COLORBLUE,LINETHICK2;
AA升:IF(AA>REF(AA,1),AA,DRAWNULL),COLORRED,LINETHICK2;
AA降:IF(AA<REF(AA,1),AA,DRAWNULL),COLORGREEN,LINETHICK2;
回复 支持 反对

使用道具 举报

发表于 2010-4-18 00:33 | 显示全部楼层
VAR11:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR11*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR11*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR11*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
AA3:=( EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10) ;
BB:=AA3>REF(HHV(AA3,60),1);
CC:=HHV(AA3,60);
大底:=FILTER(AA3>10 ,1) ;
VA1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买1:=IF(CLOSE>OPEN,VA1*(HIGH-LOW),IF(CLOSE<OPEN,VA1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主卖1:=IF(CLOSE>OPEN,0-VA1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VA1*(HIGH-LOW),0-VOL/2));

AA6:=(主买1-(-主卖1))/主买1;
STICKLINE(大底>0  AND C<O  ,0,CC,4,0),COLORYELLOW;
谢谢楼主无私的奉献,请帮我把上面“提前买入”指标改成选股指标。
回复 支持 反对

使用道具 举报

发表于 2010-4-18 07:27 | 显示全部楼层
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-18 08:08 | 显示全部楼层
回11楼,呵呵,信号太多了,有待优化,比如可以按自己的资金量添加上股价、流通盘、业绩等条件限制,那效果就明显了,现回如下:
N1:=7;
LC:=REF(CLOSE,1);
X:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
魔鬼:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1);
TJ1:=X=魔鬼;
TJ2:=X<REF(X,1);
TJ1 AND TJ2;
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-18 09:22 | 显示全部楼层
回14楼,不错,只是上面的几条线应用的是WINNER函数,属于未来函数,但是他并没有对买卖进行直接的决定,所以不影响效果,现回复如下:
DIFF:=EMA(CLOSE,10)-EMA(CLOSE,22);
AA升:DIFF>0 AND REF(DIFF,1)<=0;
另:预警是在选股公式做好以后,在预警条件里面把公式添加进去的,而不用专门做预警公式,11楼的同学如果还不懂的话,请跟帖。

评分

参与人数 1威望 +2 庄币 +2 收起 理由
股市盗贼 + 2 + 2 精品文章

查看全部评分

回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-18 09:44 | 显示全部楼层
回15楼,指标不错,但是有时候数值过小,有在附图上显示不出来的现象,先回帖如下:
VAR11:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR11*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR11*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR11*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
AA3:=(EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10) ;
BB:=AA3>REF(HHV(AA3,60),1);
CC:=HHV(AA3,60);
大底:=FILTER(AA3>10 ,1) ;
VA1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买1:=IF(CLOSE>OPEN,VA1*(HIGH-LOW),IF(CLOSE<OPEN,VA1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
{主卖1:=IF(CLOSE>OPEN,0-VA1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VA1*(HIGH-LOW),0-VOL/2));
AA6:=(主买1-(-主卖1))/主买1;}
大底>0  AND C<O;

评分

参与人数 1威望 +2 庄币 +2 收起 理由
股市盗贼 + 2 + 2 精品文章

查看全部评分

回复 支持 反对

使用道具 举报

发表于 2010-4-18 09:53 | 显示全部楼层
我是一菜鸟,有很多不懂的问题。老大的意思是说这个公式不能放在预警里使用吗?
回复 支持 反对

使用道具 举报

发表于 2010-4-18 10:11 | 显示全部楼层
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-11-20 23:41 , Processed in 0.121825 second(s), 15 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表