老钱庄股票论坛

 找回密码
 5秒快速注册
   扫一扫关注老钱庄微信号 关闭
扫一扫关注老钱庄财经微信号 关闭
查看: 657999|回复: 5540

[通达信] 免费为大家改写选股指标

    [复制链接]
发表于 2010-4-16 16:24 | 显示全部楼层 |阅读模式
本帖最后由 老覃阿呜 于 2016-7-27 19:26 编辑

免费为大家改写选股指标,即把普通指标改成选股指标,选股条件要求具体、明确,笼统模糊的概念无能为力,请有需求的同学跟帖,请发源码,谢谢!

评分

参与人数 36威望 +72 庄币 +62 收起 理由
如此淡定 + 2 + 1 赞一个!
houjingkui + 1 + 2 这个要顶
古瀍居仕 + 2 + 2 感谢为股友服务
童心gg + 2 + 2 楼主真的身手不凡,我非常敬佩你!祝你财源.
飘红1957 + 2 您的文章很棒,精品文章

查看全部评分

发表于 2010-4-16 17:01 | 显示全部楼层
V1:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇线:MA((CLOSE-V1)/V1,1),COLORYELLOW,LINETHICK2;
买点:IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012,0.5,0),STICK;
稳赚:IF(COUNT(神奇线>REF(神奇线,1),3)=3 AND COUNT(神奇线<0,10)=10 AND REF(神奇线,3)=LLV(神奇线,10),0.5,0);
V2:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
V3:=(EMA(CLOSE,6)-EMA(CLOSE,12))*100;
猎庄:V3<13 AND V2>9,STICK,COLORFFFFFF,LINETHICK2;
YD:=COUNT(C<REF(0,1),13)>=10 OR COUNT(C<REF(C,2),13)>=10 AND COUNT(H/L>1.048,13)>=7;
DTJJ:=DMA(C,V/MA(V,13)/13);
XJPL:=C/DTJJ<0.91;
A1:=YD AND XJPL;
STICKLINE(A1,0,0.50,4,1),COLORFFCCCC;
AA1:=CROSS(REF(C,3),REF(MA(C,20),3));
BB1:=COUNT(C>MA(C,20),3)=3;
CC1:=CROSS(C,MA(C,20)) AND (C-MA(C,20))/MA(C,20)>0.03;
突破月线:IF((AA1 AND BB1) OR CC1,0.5,0),STICK,LINETHICK2,COLORRED;
DRAWICON((AA1 AND BB1) OR CC1,0.6,1); 谢谢老师,改一个猎庄等于1的选股公式
回复 支持 反对

使用道具 举报

发表于 2010-4-16 17:01 | 显示全部楼层
谢谢老师,改一个猎庄等于1的选股公式
回复 支持 反对

使用道具 举报

发表于 2010-4-16 23:35 | 显示全部楼层
进来看看
回复 支持 反对

使用道具 举报

发表于 2010-4-17 01:20 | 显示全部楼层
老师您好:学生有一副图指标,希望老师在百忙之中帮助学生改个选股公式!在火焰山后出现红箭头的选股公式!谢谢老师!
A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
DRAWICON(CROSS(趋势,0),0,1);
{机构建仓区:0,LINETHICK0,COLORFFFF00; 这是句故弄玄虚的代码}
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
STICKLINE(趋势<=13,0,20,5,0),COLORCC9900;
DRAWTEXT(FILTER(趋势<=13,15),30,'准备现金'),COLORCC9900;
STICKLINE(趋势<=13 AND VAR4>13,0,50,5,0),COLOR0099FF;
VAR5:=FILTER((趋势<=13 AND VAR4>13),10);
DRAWTEXT(VAR5,60,'买入'),COLOR0099FF;
STICKLINE(趋势>=90 AND VAR4,0,30,5,0),COLORGRAY;
VAR6:=FILTER((趋势>=90 AND VAR4),10);
DRAWTEXT(VAR6,40,'清仓'),COLORGRAY;
VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;
STICKLINE(VAR9>90,100,105,10,2),COLORRED;
VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
火焰山:EMA(IF(LOW<=VAR7 AND 趋势<40,(VAR11+VAR12),0),3)/618,COLORRED,LINETHICK2;
STICKLINE(火焰山>0,0 ,火焰山*1.2,8,0 ),COLORRED;
VAR13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
VAR14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趋势线: 趋势,COLORFF0000,LINETHICK2;
VAR16:=MAX(EMA(VAR13,2)-EMA(VAR14,5),0)*200;
VAR17:=EMA(VAR16,5);
波浪峰:VAR17,STICK,COLORFF00FF;
STICKLINE(VAR17<REF(VAR17,1),0,VAR17,1,0),COLOR00FF00;
VAR18:=MA(趋势线,8);
IF(CROSS(VAR2,VAR18) AND VAR2<15,50,0),COLORRED;
DRAWTEXT(CROSS(趋势线,VAR2)AND 趋势线>REF(趋势线,1)AND 趋势线<50,50,'追涨'),COLORFF0000;
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-17 13:10 | 显示全部楼层
回2楼同学,感谢信任,给您修改的指标如下:
V2:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
V3:=(EMA(CLOSE,6)-EMA(CLOSE,12))*100;
猎庄:V3<13 AND V2>9;
通达信测试通过,但是没选到股票,如果应用另外两个:稳赚和突破月线,那能选到股票的几率也许会增加,现一并改好送上,也以此回复那些说来骗分的同学,谢谢。
稳赚:
V1:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇线:=MA((CLOSE-V1)/V1,1);
稳赚:COUNT(神奇线>REF(神奇线,1),3)=3 AND COUNT(神奇线<0,10)=10 AND REF(神奇线,3)=LLV(神奇线,10);
突破月线:
AA1:=CROSS(REF(C,3),REF(MA(C,20),3));
BB1:=COUNT(C>MA(C,20),3)=3;
CC1:=CROSS(C,MA(C,20)) AND (C-MA(C,20))/MA(C,20)>0.03;
突破月线:(AA1 AND BB1) OR CC1;
经测试,突破月线选股,今天选到20只,呵呵!

评分

参与人数 1威望 +1 收起 理由
laozhi426 + 1

查看全部评分

回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-17 13:28 | 显示全部楼层
回六楼同学,火焰山后出现“买入”,呵呵,这个“后”需要探讨,我现在让它大于零,你也可以把他变成一个参数,让它在一个特定的范围内可以调节改变,也许效果会更好的,现把我改的贴给你:
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
VAR5:=FILTER((趋势<=13 AND VAR4>13),10);
VAR7:=LLV(LOW,30);
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
火焰山:=EMA(IF(LOW<=VAR7 AND 趋势<40,(VAR11+VAR12),0),3)/618;
xg:火焰山>0 and var5;
可以改变参数的:(当然这个需要提前设定参数,稍微复杂些,如果不会使用,可以直接用上面的)
{N,0,100,0}
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
VAR5:=FILTER((趋势<=13 AND VAR4>13),10);
VAR7:=LLV(LOW,30);
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
火焰山:=EMA(IF(LOW<=VAR7 AND 趋势<40,(VAR11+VAR12),0),3)/618;
xg:火焰山>N and var5;

评分

参与人数 1威望 +2 收起 理由
飘红1957 + 2

查看全部评分

回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-17 13:39 | 显示全部楼层
呵呵,把选股结果贴图以示验证  

                                       
回复 支持 反对

使用道具 举报

 楼主| 发表于 2010-4-17 13:41 | 显示全部楼层
毁谤止于事实,呵呵,欢迎大家努力跟帖,让我们来一起探讨!

评分

参与人数 1威望 +2 收起 理由
飘红1957 + 2

查看全部评分

回复 支持 反对

使用道具 举报

发表于 2010-4-17 17:40 | 显示全部楼层
相信楼主身手不凡。有一公式请改选股公式,和预警公式。红箭头出现及时发信号。先谢谢。
VAR1:=LLV(LOW,13);
VAR2:=HHV(HIGH,13);
VAR3:=SMA((CLOSE-VAR1)/(VAR2-VAR1)*100,5,1);
VAR4:=SMA((VAR2-CLOSE)/(VAR2-VAR1)*100,5,1);
DRAWBAND(VAR3,RGB(155,50,50),50,RGB(0,100,50));
主力:VAR3,COLORRED;
散户:VAR4,COLORGREEN;
VAR5:=SMA(MAX(CLOSE-REF(CLOSE,1),0),5,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),5,1)*100;
操作:=EMA(VAR5,3),COLORYELLOW;
STICKLINE(C,90,90,1,0),COLOR3C3CFF;
STICKLINE(C,50,50,1,0),COLORYELLOW;
STICKLINE(C,10,10,1,0),COLORCYAN;
N1:=7;
界:=38,COLORFF3311;  
加仓线:=51,COLORFF1155;
LC:=REF(CLOSE,1);
X:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORFFFFFF;
魔鬼:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1),COLOR00FF00;
TJ1:=X=魔鬼;
TJ2:=X<REF(X,1);
DRAWICON(TJ1 AND TJ2,X,1);
VAR2M:=(HIGH+LOW+CLOSE*2)/4;
VAR3M:=EMA(VAR2M,21);
VAR4M:=STD(VAR2M,21);
VAR5M:=((VAR2M-VAR3M)/VAR4M*100+200)/4;
VAR6:=(EMA(VAR5M,5)-25)*1.56;
AK:=EMA(VAR6,2)*1.22;
AD1:=EMA(AK,2);
注意:=CROSS(AD1,AK);
DRAWTEXT(注意,散户,'变');
回复 支持 反对

使用道具 举报

关于老钱庄 | 广告合作 | 商务合作 | 意见反馈 | 免责声明 | 友情链接
    经营性网站备案信息 安徽黄埔网络科
技有限公司 安徽大时代投
资咨询有限公司 可信网站 网上交易保障中心

信息产业部信息备案:闽ICP备13021446号-4 茂名市公安局网警备案:4409023010511号
老钱庄股票论坛网友发表的帖子纯属个人意见,老钱庄股票论坛不负任何责任! 股市有风险,投资需谨慎!
共同建设网络精神文明,欢迎广大网友举报论坛上的不良信息,我们会在第一时间内及时处理!

[ 广告服务咨询QQ:2806911298 ] [ 合作联系电话 :15396270234 联系QQ : 800025923 ]

值班QQ: 800025923 值班电话:0592-5962326

小黑屋|手机版|Archiver|老钱庄

GMT+8, 2017-11-21 01:06 , Processed in 0.103811 second(s), 18 queries .

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表